]> git.pld-linux.org Git - packages/lasso.git/blob - lasso.spec
- pl, Group fixes
[packages/lasso.git] / lasso.spec
1 #
2 # TODO
3 # - fix tests (some linkage errors)
4
5 # Conditional build:
6 %bcond_with     wsd             # wsd
7 %bcond_with     tests           # build tests
8 %bcond_without  java            # Java bindings
9 %bcond_without  php             # PHP bindings
10 %bcond_without  perl            # Perl bindings
11 %bcond_without  python          # Python 2.x bindings
12
13 Summary:        Liberty Alliance Single Sign On
14 Summary(pl.UTF-8):      Implementacja Liberty Alliance Single Sign On
15 Name:           lasso
16 Version:        2.4.0
17 Release:        1
18 License:        GPL v2+
19 Group:          Libraries
20 Source0:        http://dev.entrouvert.org/lasso/%{name}-%{version}.tar.gz
21 # Source0-md5:  3d04aaff37c816aa16f2d1bcc2639f27
22 Patch1:         0001-Fix-java-version-detection.patch
23 Patch2:         0001-Fix-generators-for-parsing-of-integer-values.patch
24 Patch3:         0002-xml-xml.c-fix-liberal-use-of-casting-for-the-SNIPPET.patch
25 URL:            http://lasso.entrouvert.org/
26 %{?with_wsf:BuildRequires: cyrus-sasl-devel}
27 BuildRequires:  glib2-devel
28 BuildRequires:  gtk-doc
29 BuildRequires:  libtool
30 BuildRequires:  libxml2-devel
31 BuildRequires:  openssl-devel
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpmbuild(macros) >= 1.315
34 BuildRequires:  xmlsec1-devel
35 BuildRequires:  xmlsec1-openssl-devel
36 %if %{with php}
37 BuildRequires:  expat-devel
38 BuildRequires:  php-devel
39 BuildRequires:  python
40 %endif
41 %if %{with perl}
42 BuildRequires:  perl(ExtUtils::MakeMaker)
43 BuildRequires:  perl(Test::More)
44 %endif
45 %if %{with java}
46 BuildRequires:  jdk
47 BuildRequires:  rpm-javaprov
48 %endif
49 %if %{with python}
50 BuildRequires:  python-devel
51 BuildRequires:  python-lxml
52 BuildRequires:  rpm-pythonprov
53 %endif
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 Lasso is a library that implements the Liberty Alliance Single Sign On
58 standards, including the SAML and SAML2 specifications. It allows to
59 handle the whole life-cycle of SAML based Federations, and provides
60 bindings for multiple languages.
61
62 %description -l pl.UTF-8
63 Lasso to biblioteka implementująca standardy Liberty Alliance Single
64 Sign On, w tym specyfikacje SAML i SAML2. Pozwala obsłużyć cały cykl
65 życia "Federacji" opartych na SAML, zapewnia wiązania dla wielu
66 języków.
67
68 %package devel
69 Summary:        Lasso development headers
70 Summary(pl.UTF-8):      Pliki nagłówkowe Lasso
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description devel
75 This package contains the header files for Lasso.
76
77 %description devel -l pl.UTF-8
78 Ten pakiet zawiera pliki nagłówkowe Lasso.
79
80 %package -n perl-%{name}
81 Summary:        Liberty Alliance Single Sign On (lasso) Perl bindings
82 Summary(pl.UTF-8):      Wiązania Perla do Liberty Alliance Single Sign On (lasso)
83 Group:          Development/Languages/Perl
84 Requires:       %{name} = %{version}-%{release}
85
86 %description -n perl-%{name}
87 Perl language bindings for the lasso (Liberty Alliance Single Sign On)
88 library.
89
90 %description -n perl-%{name} -l pl.UTF-8
91 Wiązania Perla do biblioteki lasso (Liberty Alliance Single Sign On).
92
93 %package -n java-%{name}
94 Summary:        Liberty Alliance Single Sign On (lasso) Java bindings
95 Summary(pl.UTF-8):      Wiązania Javy do Liberty Alliance Single Sign On (lasso)
96 Group:          Libraries/Java
97 Requires:       %{name} = %{version}-%{release}
98 Requires:       jpackage-utils
99 Requires:       jre
100
101 %description -n java-%{name}
102 Java language bindings for the lasso (Liberty Alliance Single Sign On)
103 library.
104
105 %description -n java-%{name} -l pl.UTF-8
106 Wiązania Javy do biblioteki lasso (Liberty Alliance Single Sign On).
107
108 %package -n php-%{name}
109 Summary:        Liberty Alliance Single Sign On (lasso) PHP bindings
110 Summary(pl.UTF-8):      Wiązania PHP do Liberty Alliance Single Sign On (lasso)
111 Group:          Development/Languages/PHP
112 Requires:       %{name} = %{version}-%{release}
113
114 %description -n php-%{name}
115 PHP language bindings for the lasso (Liberty Alliance Single Sign On)
116 library.
117
118 %description -n php-%{name} -l pl.UTF-8
119 Wiązania PHP do biblioteki lasso (Liberty Alliance Single Sign On).
120
121 %package -n python-%{name}
122 Summary:        Liberty Alliance Single Sign On (lasso) Python bindings
123 Summary(pl.UTF-8):      Wiązania Pythona do Liberty Alliance Single Sign On (lasso)
124 Group:          Libraries/Python
125 Requires:       %{name} = %{version}-%{release}
126
127 %description -n python-%{name}
128 Python language bindings for the lasso (Liberty Alliance Single Sign
129 On) library.
130
131 %description -n python-%{name} -l pl.UTF-8
132 Wiązania Pythona do biblioteki lasso (Liberty Alliance Single Sign
133 On).
134
135 %prep
136 %setup -q
137 %patch1 -p1
138 %patch2 -p1
139 %patch3 -p1
140
141 %{__sed} -i -e '
142         s/OPTIMIZE="-g"/CC="%{__cc}" OPTIMIZE="%{rpmcflags}" INSTALLDIRS=vendor/
143 ' bindings/perl/Makefile.am
144
145 %build
146 %{__libtoolize}
147 %{__gtkdocize}
148 %{__aclocal}
149 %{__autoconf}
150 %{__automake}
151 %configure \
152         --disable-static \
153         --disable-silent-rules \
154         %{!?with_tests:--disable-tests} \
155         %{!?with_java:--disable-java} \
156         %{!?with_python:--disable-python} \
157         %{!?with_perl:--disable-perl} \
158 %if %{with php}
159         --enable-php5=yes \
160         --with-php5-config-dir=%{php_sysconfdir}/conf.d \
161 %else
162         --enable-php5=no \
163 %endif
164 %if %{with wsf}
165         --enable-wsf \
166         --with-sasl2=%{_prefix}/sasl2 \
167 %endif
168
169 %{__make}
170
171 %if %{with tests}
172 %{__make} check
173 %endif
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177 %{__make} install \
178         DESTDIR=$RPM_BUILD_ROOT
179
180 find $RPM_BUILD_ROOT -type f -name '*.la' | xargs rm -v
181
182 # Perl subpackage
183 %if %{with perl}
184 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
185 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Lasso/.packlist
186 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Lasso/Lasso.bs
187 %endif
188
189 %if %{with python}
190 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
191 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
192 %py_postclean
193 %endif
194
195 # Remove bogus doc files
196 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 %post   -p /sbin/ldconfig
202 %postun -p /sbin/ldconfig
203
204 %files
205 %defattr(644,root,root,755)
206 %doc AUTHORS COPYING NEWS README
207 %attr(755,root,root) %{_libdir}/liblasso.so.*.*.*
208 %attr(755,root,root) %ghost %{_libdir}/liblasso.so.3
209
210 %files devel
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/liblasso.so
213 %{_pkgconfigdir}/lasso.pc
214 %{_includedir}/lasso
215
216 %if %{with perl}
217 %files -n perl-%{name}
218 %defattr(644,root,root,755)
219 %{perl_vendorarch}/Lasso.pm
220 %dir %{perl_vendorarch}/auto/Lasso
221 %attr(755,root,root) %{perl_vendorarch}/auto/Lasso/Lasso.so
222 %endif
223
224 %if %{with java}
225 %files -n java-%{name}
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_jnidir}/libjnilasso.so
228 %{_javadir}/lasso.jar
229 %endif
230
231 %if %{with php}
232 %files -n php-%{name}
233 %defattr(644,root,root,755)
234 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/lasso.ini
235 %attr(755,root,root) %{php_extensiondir}/lasso.so
236 %{php_data_dir}/lasso.php
237 %endif
238
239 %if %{with python}
240 %files -n python-%{name}
241 %defattr(644,root,root,755)
242 %{py_sitedir}/lasso.py[co]
243 %attr(755,root,root) %{py_sitedir}/_lasso.so
244 %endif
This page took 0.225804 seconds and 3 git commands to generate.