]> git.pld-linux.org Git - packages/lasem.git/blob - lasem.spec
noarch apidocs
[packages/lasem.git] / lasem.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Lasem - MathML and SVG rendering library
7 Summary(pl.UTF-8):      Lasem - biblioteka do renderowania MathML i SVG
8 Name:           lasem
9 Version:        0.4.1
10 Release:        2
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/lasem/0.4/%{name}-%{version}.tar.xz
14 # Source0-md5:  05f24217fbd83504a3d867e6d71909ed
15 URL:            http://live.gnome.org/Lasem
16 BuildRequires:  bison
17 BuildRequires:  cairo-devel >= 1.2
18 BuildRequires:  flex
19 BuildRequires:  gdk-pixbuf2-devel >= 2.16
20 BuildRequires:  gettext-devel
21 BuildRequires:  glib2-devel >= 2.0
22 BuildRequires:  gobject-introspection-devel >= 0.6.7
23 BuildRequires:  gtk-doc >= 1.14
24 BuildRequires:  intltool >= 0.45.0
25 BuildRequires:  libxml2-devel >= 2.0
26 BuildRequires:  pango-devel >= 1:1.16.0
27 BuildRequires:  pkgconfig
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 Requires:       cairo >= 1.2
31 Requires:       gdk-pixbuf2 >= 2.16
32 Requires:       pango >= 1:1.16.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Lasem aims to be a C/GObject based SVG/MathML renderer and editor,
37 supporting CSS style sheets (only rendering is implemented for now).
38 It uses cairo and pango as its rendering abstraction layer, and then
39 support numerous output formats: xlib, PNG, SVG, PDF, PS, EPS...
40
41 %description -l pl.UTF-8
42 Lasem ma być opartą na C/GObject biblioteką do renderowania i edycji
43 SVG/MathML z obsługą arkuszy stylów CSS (na razie zaimplementowane
44 jest tylko renderowanie). Wykorzystuje cairo i pango jako warstwę
45 abstrakcji przy renderowaniu, a następnie obsługuje wiele formatów
46 wyjściowych: xlib, PNG, SVG, PDF, PS, EPS...
47
48 %package devel
49 Summary:        Header files for lasem library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki lasem
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       cairo-devel >= 1.2
54 Requires:       gdk-pixbuf2-devel >= 2.16
55 Requires:       glib2-devel >= 2.0
56 Requires:       libxml2-devel >= 2.0
57 Requires:       pango-devel >= 1:1.16.0
58
59 %description devel
60 Header files for lasem library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki lasem.
64
65 %package static
66 Summary:        Static lasem library
67 Summary(pl.UTF-8):      Statyczna biblioteka lasem
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static lasem library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka lasem.
76
77 %package apidocs
78 Summary:        lasem API documentation
79 Summary(pl.UTF-8):      Dokumentacja API biblioteki lasem
80 Group:          Documentation
81 %if "%{_rpmversion}" >= "5"
82 BuildArch:      noarch
83 %endif
84
85 %description apidocs
86 API documentation for lasem library.
87
88 %description apidocs -l pl.UTF-8
89 Dokumentacja API biblioteki lasem.
90
91 %prep
92 %setup -q
93
94 %build
95 %configure \
96         --disable-silent-rules \
97         %{!?with_static_libs:--disable-static} \
98         --with-html-dir=%{_gtkdocdir}
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 # obsoleted by pkg-config
107 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
108 # packaged as %doc
109 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/lasem-0.4
110
111 %find_lang %{name}-0.4
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files -f %{name}-0.4.lang
120 %defattr(644,root,root,755)
121 %doc AUTHORS NEWS README TODO
122 %attr(755,root,root) %{_bindir}/lasem-render-0.4
123 %attr(755,root,root) %{_libdir}/liblasem-0.4.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/liblasem-0.4.so.4
125 %{_libdir}/girepository-1.0/Lasem-0.4.typelib
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/liblasem-0.4.so
130 %{_includedir}/lasem-0.4
131 %{_datadir}/gir-1.0/Lasem-0.4.gir
132 %{_pkgconfigdir}/lasem-0.4.pc
133
134 %if %{with static_libs}
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/liblasem-0.4.a
138 %endif
139
140 %if %{with apidocs}
141 %files apidocs
142 %defattr(644,root,root,755)
143 %{_gtkdocdir}/lasem-0.4
144 %endif
This page took 0.076679 seconds and 4 git commands to generate.