]> git.pld-linux.org Git - packages/laptop-mode-tools.git/blob - laptop-mode-tools.spec
- noarch subpackage is rpm5 only
[packages/laptop-mode-tools.git] / laptop-mode-tools.spec
1 #
2 # Conditional build:
3 %bcond_with     apm             # build apm package
4 %bcond_without  acpi    # build acpi package
5
6 # TODO:
7 # - subpackage with files for pbbuttonsd and pmud
8 # - fix *.conf manuals (should be .5 and referenced as such)
9 # - /etc/apm not owned, should it be /etc/pm?
10
11 %ifnarch %{ix86} %{x8664} ia64
12 %undefine               with_acpi
13 %endif
14 %ifnarch %{ix86} arm mips ppc sh
15 %undefine               with_apm
16 %endif
17 Summary:        Laptop Mode Tools
18 Summary(pl.UTF-8):      Narzędzia do trybu laptopowego
19 Name:           laptop-mode-tools
20 Version:        1.71
21 Release:        1
22 License:        GPL
23 Group:          Applications/System
24 Source0:        https://github.com/rickysarraf/laptop-mode-tools/archive/%{version}.tar.gz
25 # Source0-md5:  8b9a2d9db7dd9d0a99b635a1185f292c
26 Source1:        %{name}.init
27 URL:            https://github.com/rickysarraf/laptop-mode-tools
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.714
30 Requires(post,preun):   /sbin/chkconfig
31 %if %{with apm} && %{with acpi}
32 Requires:       %{name}-scripts = %{version}-%{release}
33 %else
34 %{?with_acpi:Requires:  acpid}
35 %{?with_apm:Requires:   apmd}
36 Obsoletes:      laptop-mode-tools-scripts
37 %endif
38 Suggests:       hdparm
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Laptop mode (also known as laptopmode, laptop-mode and laptop_mode,
43 for search engine purposes :) ) is a kernel "mode" that allows you to
44 extend the battery life of your laptop. It does this by intelligently
45 grouping write activity on your disks, so that only reads of uncached
46 data result in a disk spinup. It causes a significant improvement in
47 battery life (for usage patterns that allow it).
48
49 %description -l pl.UTF-8
50 Tryb laptopowy (laptop mode) to "tryb" pracy jądra umożliwiający
51 wydłużenie czasu życia baterii laptopa. Czyni to inteligentnie
52 grupując zapisy na dyski w ten sposób, że tylko odczyt
53 niezbuforowanych danych powoduje rozpędzenie dysku. Powoduje znaczącą
54 poprawę czasu życia baterii.
55
56 %package acpi
57 Summary:        ACPI scripts for laptop mode tools
58 Summary(pl.UTF-8):      Skrypty ACPI dla narzędzi do trybu laptopowego
59 Group:          Applications/System
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       acpid
62 Provides:       %{name}-scripts = %{version}-%{release}
63
64 %description acpi
65 ACPI scripts for laptop mode tools.
66
67 %description acpi -l pl.UTF-8
68 Skrypty ACPI dla narzędzi do trybu laptopowego.
69
70 %package apm
71 Summary:        APM scripts for laptop mode tools
72 Summary(pl.UTF-8):      Skrypty APM dla narzędzi do trybu laptopowego
73 Group:          Applications/System
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       apmd
76 Provides:       %{name}-scripts = %{version}-%{release}
77
78 %description apm
79 APM scripts for laptop mode tools.
80
81 %description apm -l pl.UTF-8
82 Skrypty APM dla narzędzi do trybu laptopowego.
83
84 %package gui
85 Summary:        GUI for laptop mode tools
86 Summary(pl.UTF-8):      GUI dla narzędzi do trybu laptopowego
87 Group:          Applications/X11
88 Requires:       python-PyQt4
89 Requires:       python-modules
90 Requires:       %{name} = %{version}-%{release}
91 %if "%{_rpmversion}" >= "5"
92 BuildArch:      noarch
93 %endif
94
95 %description gui
96 GUI for laptop mode tools.
97
98 %description gui -l pl.UTF-8
99 GUI dla narzędzi do trybu laptopowego.
100
101 %prep
102 %setup -q
103
104 %{__sed} -i -e 's|/usr/bin/env python2|/usr/bin/python|' gui/LMT.py
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT%{_bindir}
109
110 %{__make} install \
111         INSTALL=install \
112         INIT_D=$RPM_BUILD_ROOT/etc/rc.d/init.d \
113         ULIB_D=%{_libdir} \
114         MAN_D=%{_mandir} \
115         TMPFILES_D=/usr/lib/tmpfiles.d \
116         %{!?with_acpi:ACPI=disabled} \
117         %{!?with_apm:APM=disabled} \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/laptop-mode
121
122 install -p gui/LMT.py $RPM_BUILD_ROOT%{_datadir}/%{name}/lmt.py
123 install -p gui/lmt-config-gui $RPM_BUILD_ROOT%{_bindir}/
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 /sbin/chkconfig --add laptop-mode
130 %service laptop-mode restart
131
132 %preun
133 if [ "$1" = "0" ]; then
134         %service laptop-mode stop
135         /sbin/chkconfig --del laptop-mode
136 fi
137
138 %files
139 %defattr(644,root,root,755)
140 %doc README.md Documentation/*
141 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/laptop-mode/*.conf
142 %dir %{_sysconfdir}/laptop-mode
143 %dir %{_sysconfdir}/laptop-mode/batt-start
144 %dir %{_sysconfdir}/laptop-mode/batt-stop
145 %dir %{_sysconfdir}/laptop-mode/conf.d
146 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/laptop-mode/conf.d/*.conf
147 %dir %{_sysconfdir}/laptop-mode/lm-ac-start
148 %dir %{_sysconfdir}/laptop-mode/lm-ac-stop
149 %dir %{_sysconfdir}/laptop-mode/nolm-ac-start
150 %dir %{_sysconfdir}/laptop-mode/nolm-ac-stop
151 %attr(754,root,root) /etc/rc.d/init.d/laptop-mode
152 %attr(755,root,root) /lib/udev/lmt-udev
153 /lib/udev/rules.d/99-laptop-mode.rules
154 /usr/lib/tmpfiles.d/laptop-mode.conf
155 /lib/systemd/system/laptop-mode.service
156 /lib/systemd/system/laptop-mode.timer
157 /lib/systemd/system/lmt-poll.service
158 %dir %{_libdir}/pm-utils/sleep.d
159 %attr(755,root,root) %{_libdir}/pm-utils/sleep.d/01laptop-mode
160 %dir %{_datadir}/%{name}
161 %dir %{_datadir}/%{name}/modules
162 %attr(755,root,root) %{_datadir}/%{name}/modules/*
163 %dir %{_datadir}/%{name}/module-helpers
164 %attr(755,root,root) %{_datadir}/%{name}/module-helpers/*
165 %attr(755,root,root) %{_sbindir}/laptop_mode
166 %attr(755,root,root) %{_sbindir}/lm-profiler
167 %attr(755,root,root) %{_sbindir}/lm-syslog-setup
168 %{_mandir}/man8/laptop_mode.8*
169 %{_mandir}/man8/lm-profiler.8*
170 %{_mandir}/man8/lm-syslog-setup.8*
171 # should be man5
172 %{_mandir}/man8/laptop-mode.conf.8*
173 %{_mandir}/man8/lm-profiler.conf.8*
174
175 %if %{with acpi}
176 # skip subpackage if only one backend built
177 %{?with_apm:%files acpi}
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_sysconfdir}/acpi/actions/lm_*.sh
180 %{_sysconfdir}/acpi/events/lm_*
181 %endif
182
183 %if %{with apm}
184 # skip subpackage if only one backend built
185 %{?with_acpi:%files apm}
186 %defattr(644,root,root,755)
187 # XXX: dir not owned
188 %attr(755,root,root) %{_sysconfdir}/apm/event.d/laptop-mode
189 %endif
190
191 %files gui
192 %defattr(644,root,root,755)
193 %{_datadir}/%{name}/lmt.py
194 %attr(755,root,root) %{_bindir}/lmt-config-gui
195 %{_datadir}/polkit-1/actions/org.linux.lmt.gui.policy
This page took 0.07908 seconds and 3 git commands to generate.