]> git.pld-linux.org Git - packages/lal.git/blob - lal.spec
- up to 6.15.0
[packages/lal.git] / lal.spec
1 Summary:        LALSuite is comprised of various gravitational wave data analysis routines
2 Name:           lal
3 Version:        6.15.0
4 Release:        1
5 License:        GPL v2
6 Group:          Applications/Science
7 Source0:        https://www.lsc-group.phys.uwm.edu/daswg/download/software/source/lalsuite/%{name}-%{version}.tar.gz
8 # Source0-md5:  67fb4647b08f9ba2b9c4e561daf6e3e5
9 URL:            https://www.lsc-group.phys.uwm.edu/daswg/projects/lalsuite.html
10 BuildRequires:  fftw3-common-devel
11 BuildRequires:  gsl-devel
12 BuildRequires:  metaio-devel
13 BuildRequires:  pkgconfig
14 BuildRequires:  python
15 BuildRequires:  texlive-dvips
16 BuildRequires:  texlive-format-pdflatex
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 LALSuite is comprised of various gravitational wave data analysis
21 routines written in C following the ISO/IEC 9899:1999 standard, more
22 commonly referred to as C99.
23
24 %package devel
25 Summary:        Development files for LAL
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}-%{release}
28 Requires:       fftw3-devel
29 Requires:       fftw3-single-devel
30 Requires:       zlib-devel
31
32 %description devel
33 Development files for LAL.
34
35 %package static
36 Summary:        Static LAL library
37 Group:          Development/Libraries
38 Requires:       %{name}-devel = %{version}-%{release}
39
40 %description static
41 Static LAL library.
42
43 %package -n python-lal
44 Summary:        LAL Python bindings
45 Group:          Libraries/Python
46 Requires:       %{name} = %{version}-%{release}
47
48 %description  -n python-lal
49 LAL Python bindings.
50
51 %prep
52 %setup -q
53
54 %build
55 %configure \
56         ac_cv_path_GIT=no-you-dont
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 install -d $RPM_BUILD_ROOT/etc/shrc.d
66 mv $RPM_BUILD_ROOT%{_sysconfdir}/*sh $RPM_BUILD_ROOT/etc/shrc.d
67
68 %py_postclean
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc AUTHORS README
76 %{_sysconfdir}/shrc.d/lal-user-env.*
77 %attr(755,root,root) %{_bindir}/lal-simd-detect
78 %attr(755,root,root) %{_bindir}/lal-version
79 %attr(755,root,root) %{_libdir}/liblal.so.*.*.*
80 %attr(755,root,root) %ghost %{_libdir}/liblal.so.11
81 %attr(755,root,root) %{_libdir}/liblalsupport.so.*.*.*
82 %attr(755,root,root) %ghost %{_libdir}/liblalsupport.so.7
83
84 %files devel
85 %defattr(644,root,root,755)
86 %{_libdir}/lib*.la
87 %{_libdir}/lib*.so
88 %{_pkgconfigdir}/*.pc
89 %dir %{_includedir}/lal
90 %{_includedir}/lal/*
91
92 %files static
93 %defattr(644,root,root,755)
94 %{_libdir}/lib*.a
95
96 %files -n python-lal
97 %defattr(644,root,root,755)
98 %dir %{py_sitedir}/lal
99 %{py_sitedir}/lal/*.py[co]
100 %dir %{py_sitedir}/lal/spectrum
101 %{py_sitedir}/lal/spectrum/*.py[co]
102 %dir %{py_sitedir}/lal/utils
103 %{py_sitedir}/lal/utils/*.py[co]
This page took 0.058861 seconds and 3 git commands to generate.