]> git.pld-linux.org Git - packages/lal.git/blob - lal.spec
b4deac5e58a725c0e6703f940e41cfd61f2549a9
[packages/lal.git] / lal.spec
1 # TODO: bconds for boinc, cuda
2 Summary:        LALSuite - various gravitational wave data analysis routines
3 Summary(pl.UTF-8):      LALSuite - różne procedury do analizy danych fal grawitacyjnych
4 Name:           lal
5 Version:        7.1.4
6 Release:        3
7 License:        GPL v2
8 Group:          Applications/Science
9 Source0:        http://software.ligo.org/lscsoft/source/lalsuite/%{name}-%{version}.tar.xz
10 # Source0-md5:  248e9728fe10db12239957b83b6a1316
11 Patch0:         %{name}-env.patch
12 Patch1:         no-simd.patch
13 URL:            https://wiki.ligo.org/DASWG/LALSuite
14 BuildRequires:  autoconf >= 2.63
15 BuildRequires:  automake >= 1:1.11
16 BuildRequires:  fftw3-devel
17 BuildRequires:  fftw3-single-devel
18 BuildRequires:  gsl-devel >= 1.13
19 BuildRequires:  hdf5-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool >= 2:2
22 BuildRequires:  octave-devel >= 2:3.2.0
23 BuildRequires:  pkgconfig
24 BuildRequires:  python3-devel
25 BuildRequires:  python3-numpy-devel
26 # 2.0.12 for octave 3.2, 3.0.7 for octave 4.0, 3.0.12 for octave 4.2
27 BuildRequires:  swig >= 3.0.12
28 BuildRequires:  swig-python >= 2.0.12
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  texlive-dvips
31 BuildRequires:  texlive-format-pdflatex
32 BuildRequires:  xz
33 BuildRequires:  zlib-devel
34 Requires:       gsl >= 1.13
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 LALSuite is comprised of various gravitational wave data analysis
39 routines written in C following the ISO/IEC 9899:1999 standard, more
40 commonly referred to as C99.
41
42 %description -l pl.UTF-8
43 LALSuite składa się z różnych procedur do analizy danych fal
44 grawitacyjnych, napisanych w C zgodnie ze standardem ISO/IEC
45 9899:1999, bardziej znanym jako C99.
46
47 %package devel
48 Summary:        Header files for LAL core libraries
49 Summary(pl.UTF-8):      Pliki nagłówkowe podstawowych bibliotek LAL
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       fftw3-devel
53 Requires:       fftw3-single-devel
54 Requires:       gsl-devel >= 1.13
55 Requires:       zlib-devel
56
57 %description devel
58 Header files for LAL core libraries.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe podstawowych bibliotek LAL.
62
63 %package static
64 Summary:        Static LAL core libraries
65 Summary(pl.UTF-8):      Statyczne podstawowe biblioteki LAL
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static LAL core libraries.
71
72 %description static -l pl.UTF-8
73 Statyczne podstawowe biblioteki LAL.
74
75 %package -n octave-lal
76 Summary:        Octave LAL interface
77 Summary(pl.UTF-8):      Interfejs Octave do bibliotek LAL
78 Group:          Applications/Math
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       octave
81
82 %description -n octave-lal
83 Octave LAL interface.
84
85 %description -n octave-lal -l pl.UTF-8
86 Interfejs Octave do bibliotek LAL.
87
88 %package -n python3-lal
89 Summary:        LAL Python bindings
90 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek LAL
91 Group:          Libraries/Python
92 Requires:       %{name} = %{version}-%{release}
93 Requires:       python3-modules >= 1:2.6
94 Requires:       python3-numpy >= 1:1.7
95
96 %description -n python3-lal
97 LAL Python bindings.
98
99 %description -n python3-lal -l pl.UTF-8
100 Wiązania Pythona do bibliotek LAL.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %ifarch %{ix86}
106 %patch1 -p1
107 %endif
108
109 %build
110 %{__libtoolize}
111 %{__aclocal} -I gnuscripts
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure \
116         ac_cv_path_GIT=no-you-dont \
117         --disable-silent-rules \
118         --enable-swig
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 # Fix undefined variable genereted by configure
128 %{__sed} -i -e 's/\${PYTHON_EXEC_PREFIX}/\${prefix}/' \
129         $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
130
131 # obsoleted by pkg-config
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/liblal*.la
133
134 install -d $RPM_BUILD_ROOT/etc/shrc.d
135 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/*sh $RPM_BUILD_ROOT/etc/shrc.d
136
137 %py_postclean
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %files
143 %defattr(644,root,root,755)
144 %doc AUTHORS README.md
145 %{_sysconfdir}/shrc.d/lal-user-env.csh
146 %{_sysconfdir}/shrc.d/lal-user-env.fish
147 %{_sysconfdir}/shrc.d/lal-user-env.sh
148 %attr(755,root,root) %{_bindir}/lal_simd_detect
149 %attr(755,root,root) %{_bindir}/lal_version
150 %attr(755,root,root) %{_libdir}/liblal.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/liblal.so.20
152 %attr(755,root,root) %{_libdir}/liblalsupport.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/liblalsupport.so.14
154
155 %files devel
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/liblal.so
158 %attr(755,root,root) %{_libdir}/liblalsupport.so
159 %{_includedir}/lal
160 %{_pkgconfigdir}/lal.pc
161 %{_pkgconfigdir}/lalsupport.pc
162
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/liblal.a
166 %{_libdir}/liblalsupport.a
167
168 %files -n octave-lal
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/octave/*/site/oct/*/lal.oct
171
172 %files -n python3-lal
173 %defattr(644,root,root,755)
174 %dir %{py3_sitedir}/lal
175 %attr(755,root,root) %{py3_sitedir}/lal/_lal.so
176 %{py3_sitedir}/lal/*.py
177 %{py3_sitedir}/lal/__pycache__
178 %dir %{py3_sitedir}/lal/utils
179 %{py3_sitedir}/lal/utils/*.py
180 %{py3_sitedir}/lal/utils/__pycache__
This page took 0.06801 seconds and 2 git commands to generate.