]> git.pld-linux.org Git - packages/lal.git/blob - lal.spec
04a17536d288e02f700d090843d3a9500b295b15
[packages/lal.git] / lal.spec
1 # TODO: bconds for boinc, cuda
2 Summary:        LALSuite - various gravitational wave data analysis routines
3 Summary(pl.UTF-8):      LALSuite - różne procedury do analizy danych fal grawitacyjnych
4 Name:           lal
5 Version:        7.2.4
6 Release:        1
7 License:        GPL v2
8 Group:          Applications/Science
9 Source0:        http://software.igwn.org/lscsoft/source/lalsuite/%{name}-%{version}.tar.xz
10 # Source0-md5:  14994c1e60f71409e3765ece76adb021
11 Patch0:         %{name}-env.patch
12 Patch1:         no-simd.patch
13 Patch2:         %{name}-swig.patch
14 Patch3:         %{name}-octave.patch
15 URL:            https://wiki.ligo.org/Computing/DASWG/LALSuite
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  fftw3-devel
19 BuildRequires:  fftw3-single-devel
20 BuildRequires:  gsl-devel >= 1.13
21 BuildRequires:  hdf5-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:2
24 BuildRequires:  octave-devel >= 2:6
25 BuildRequires:  pkgconfig
26 BuildRequires:  python3-devel >= 1:3.5
27 BuildRequires:  python3-numpy-devel
28 # 2.0.12 for octave 3.2, 3.0.7 for octave 4.0, 3.0.12 for octave 4.2, 4.1.0 for octave 6
29 BuildRequires:  swig >= 4.1.0
30 BuildRequires:  swig-python >= 2.0.12
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  texlive-dvips
33 BuildRequires:  texlive-format-pdflatex
34 BuildRequires:  xz
35 BuildRequires:  zlib-devel
36 Requires:       gsl >= 1.13
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 LALSuite is comprised of various gravitational wave data analysis
41 routines written in C following the ISO/IEC 9899:1999 standard, more
42 commonly referred to as C99.
43
44 %description -l pl.UTF-8
45 LALSuite składa się z różnych procedur do analizy danych fal
46 grawitacyjnych, napisanych w C zgodnie ze standardem ISO/IEC
47 9899:1999, bardziej znanym jako C99.
48
49 %package devel
50 Summary:        Header files for LAL core libraries
51 Summary(pl.UTF-8):      Pliki nagłówkowe podstawowych bibliotek LAL
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       fftw3-devel
55 Requires:       fftw3-single-devel
56 Requires:       gsl-devel >= 1.13
57 Requires:       zlib-devel
58
59 %description devel
60 Header files for LAL core libraries.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe podstawowych bibliotek LAL.
64
65 %package static
66 Summary:        Static LAL core libraries
67 Summary(pl.UTF-8):      Statyczne podstawowe biblioteki LAL
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static LAL core libraries.
73
74 %description static -l pl.UTF-8
75 Statyczne podstawowe biblioteki LAL.
76
77 %package -n octave-lal
78 Summary:        Octave LAL interface
79 Summary(pl.UTF-8):      Interfejs Octave do bibliotek LAL
80 Group:          Applications/Math
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       octave
83
84 %description -n octave-lal
85 Octave LAL interface.
86
87 %description -n octave-lal -l pl.UTF-8
88 Interfejs Octave do bibliotek LAL.
89
90 %package -n python3-lal
91 Summary:        LAL Python bindings
92 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek LAL
93 Group:          Libraries/Python
94 Requires:       %{name} = %{version}-%{release}
95 Requires:       python3-modules >= 1:2.6
96 Requires:       python3-numpy >= 1:1.7
97 Obsoletes:      python-lal < 7
98
99 %description -n python3-lal
100 LAL Python bindings.
101
102 %description -n python3-lal -l pl.UTF-8
103 Wiązania Pythona do bibliotek LAL.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %ifarch %{ix86}
109 %patch1 -p1
110 %endif
111 %patch2 -p1
112 %patch3 -p1
113
114 %build
115 %{__libtoolize}
116 %{__aclocal} -I gnuscripts
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         ac_cv_path_GIT=no-you-dont \
122         --disable-silent-rules \
123         --enable-swig
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 # Fix undefined variable genereted by configure
133 %{__sed} -i -e 's/\${PYTHON_EXEC_PREFIX}/\${prefix}/' \
134         $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
135
136 # obsoleted by pkg-config
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/liblal*.la
138
139 install -d $RPM_BUILD_ROOT/etc/shrc.d
140 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/*sh $RPM_BUILD_ROOT/etc/shrc.d
141
142 %py_postclean
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files
148 %defattr(644,root,root,755)
149 %doc AUTHORS README.md
150 %{_sysconfdir}/shrc.d/lal-user-env.csh
151 %{_sysconfdir}/shrc.d/lal-user-env.fish
152 %{_sysconfdir}/shrc.d/lal-user-env.sh
153 %attr(755,root,root) %{_bindir}/lal_cache
154 %attr(755,root,root) %{_bindir}/lal_fftw_wisdom
155 %attr(755,root,root) %{_bindir}/lal_fftwf_wisdom
156 %attr(755,root,root) %{_bindir}/lal_path2cache
157 %attr(755,root,root) %{_bindir}/lal_searchsum2cache
158 %attr(755,root,root) %{_bindir}/lal_simd_detect
159 %attr(755,root,root) %{_bindir}/lal_tconvert
160 %attr(755,root,root) %{_bindir}/lal_version
161 %attr(755,root,root) %{_libdir}/liblal.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/liblal.so.20
163 %attr(755,root,root) %{_libdir}/liblalsupport.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/liblalsupport.so.14
165 %{_mandir}/man1/lal_cache.1*
166 %{_mandir}/man1/lal_fftw_wisdom.1*
167 %{_mandir}/man1/lal_fftwf_wisdom.1*
168 %{_mandir}/man1/lal_path2cache.1*
169 %{_mandir}/man1/lal_searchsum2cache.1*
170 %{_mandir}/man1/lal_simd_detect.1*
171 %{_mandir}/man1/lal_tconvert.1*
172 %{_mandir}/man1/lal_version.1*
173
174 %files devel
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/liblal.so
177 %attr(755,root,root) %{_libdir}/liblalsupport.so
178 %{_includedir}/lal
179 %{_pkgconfigdir}/lal.pc
180 %{_pkgconfigdir}/lalsupport.pc
181
182 %files static
183 %defattr(644,root,root,755)
184 %{_libdir}/liblal.a
185 %{_libdir}/liblalsupport.a
186
187 %files -n octave-lal
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/octave/*/site/oct/*/lal.oct
190
191 %files -n python3-lal
192 %defattr(644,root,root,755)
193 %dir %{py3_sitedir}/lal
194 %attr(755,root,root) %{py3_sitedir}/lal/_lal.so
195 %{py3_sitedir}/lal/*.py
196 %{py3_sitedir}/lal/__pycache__
197 %dir %{py3_sitedir}/lal/utils
198 %{py3_sitedir}/lal/utils/*.py
199 %{py3_sitedir}/lal/utils/__pycache__
This page took 0.256877 seconds and 2 git commands to generate.