]> git.pld-linux.org Git - packages/lal-xml.git/blob - lal-xml.spec
rebuild with python 3.10
[packages/lal-xml.git] / lal-xml.spec
1 Summary:        LAL wrapping of the XML library
2 Summary(pl.UTF-8):      Obudowanie LAL do biblioteki XML
3 Name:           lal-xml
4 Version:        1.2.4
5 Release:        5
6 License:        GPL v2+
7 Group:          Libraries
8 Source0:        http://software.ligo.org/lscsoft/source/lalsuite/lalxml-%{version}.tar.xz
9 # Source0-md5:  8890f9630f59a5cc9e9c32df29f5da5c
10 Patch0:         %{name}-env.patch
11 URL:            https://wiki.ligo.org/DASWG/LALSuite
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  gsl-devel >= 1.13
15 BuildRequires:  lal-devel >= 6.18.0
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:2
18 BuildRequires:  libxml2-devel >= 1:2.6
19 BuildRequires:  octave-devel >= 1:3.2.0
20 BuildRequires:  pkgconfig
21 BuildRequires:  python3-devel
22 BuildRequires:  python3-numpy-devel
23 BuildRequires:  swig >= 3.0.12
24 BuildRequires:  swig-python >= 2.0.12
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 BuildRequires:  zlib-devel
28 Requires:       gsl >= 1.13
29 Requires:       lal >= 6.18.0
30 Requires:       libxml2 >= 1:2.6
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 LAL wrapping of the XML library.
35
36 %description -l pl.UTF-8
37 Obudowanie LAL do biblioteki XML.
38
39 %package devel
40 Summary:        Header files for lal-xml library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki lal-xml
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       gsl-devel >= 1.13
45 Requires:       lal-devel >= 6.18.0
46 Requires:       libxml2-devel >= 1:2.6
47
48 %description devel
49 Header files for lal-xml library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki lal-xml.
53
54 %package static
55 Summary:        Static lal-xml library
56 Summary(pl.UTF-8):      Statyczna biblioteka lal-xml
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static lal-xml library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka lal-xml.
65
66 %package -n octave-lalxml
67 Summary:        Octave interface for LAL XML
68 Summary(pl.UTF-8):      Interfejs Octave do biblioteki LAL XML
69 Group:          Applications/Math
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       octave-lal >= 6.18.0
72
73 %description -n octave-lalxml
74 Octave interface for LAL XML.
75
76 %description -n octave-lalxml -l pl.UTF-8
77 Interfejs Octave do biblioteki LAL XML.
78
79 %package -n python3-lalxml
80 Summary:        Python bindings for LAL XML
81 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki LAL XML
82 Group:          Libraries/Python
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       python3-lal >= 6.18.0
85 Requires:       python3-modules >= 1:2.6
86
87 %description -n python3-lalxml
88 Python bindings for LAL XML.
89
90 %description -n python3-lalxml -l pl.UTF-8
91 Wiązania Pythona do biblioteki LAL XML.
92
93 %prep
94 %setup -q -n lalxml-%{version}
95 %patch0 -p1
96
97 %build
98 %{__libtoolize}
99 %{__aclocal} -I gnuscripts
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         PYTHON=%{__python3} \
105         --disable-dependency-tracking \
106         --enable-swig
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 # obsoleted by pkg-config
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/liblalxml.la
117
118 install -d $RPM_BUILD_ROOT/etc/shrc.d
119 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/*sh $RPM_BUILD_ROOT/etc/shrc.d
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS README
130 %attr(755,root,root) %{_bindir}/lalxml_version
131 %attr(755,root,root) %{_libdir}/liblalxml.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/liblalxml.so.2
133 %{_datadir}/lalxml
134 /etc/shrc.d/lalxml-user-env.csh
135 /etc/shrc.d/lalxml-user-env.fish
136 /etc/shrc.d/lalxml-user-env.sh
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/liblalxml.so
141 %{_includedir}/lal/LALXML*.h
142 %{_includedir}/lal/SWIGLALXML*.h
143 %{_includedir}/lal/SWIGLALXML*.i
144 %{_includedir}/lal/swiglalxml.i
145 %{_pkgconfigdir}/lalxml.pc
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/liblalxml.a
150
151 %files -n octave-lalxml
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/octave/*/site/oct/*/lalxml.oct
154
155 %files -n python3-lalxml
156 %defattr(644,root,root,755)
157 %dir %{py3_sitedir}/lalxml
158 %attr(755,root,root) %{py3_sitedir}/lalxml/_lalxml.so
159 %{py3_sitedir}/lalxml/*.py
160 %{py3_sitedir}/lalxml/__pycache__
This page took 0.054621 seconds and 3 git commands to generate.