]> git.pld-linux.org Git - packages/lal-simulation.git/blob - lal-simulation.spec
Release 3 (by relup.sh)
[packages/lal-simulation.git] / lal-simulation.spec
1 #
2 # Conditional build:
3 %bcond_without  openmp  # OpenMP support
4 #
5 Summary:        LAL Simulation library
6 Summary(pl.UTF-8):      Biblioteka LAL Simulation
7 Name:           lal-simulation
8 Version:        3.0.0
9 Release:        3
10 License:        GPL v2+
11 Group:          Libraries
12 Source0:        http://software.ligo.org/lscsoft/source/lalsuite/lalsimulation-%{version}.tar.xz
13 # Source0-md5:  1790f203ca631fa93dc69bddcd19d055
14 Patch0:         %{name}-env.patch
15 Patch1:         no-Werror.patch
16 URL:            https://wiki.ligo.org/DASWG/LALSuite
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  gsl-devel >= 1.13
20 BuildRequires:  lal-devel >= 6.18.0
21 %{?with_openmp:BuildRequires:   libgomp-devel}
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:2
24 BuildRequires:  octave-devel >= 1:3.2.0
25 BuildRequires:  pkgconfig
26 BuildRequires:  python3-devel
27 BuildRequires:  python3-numpy-devel
28 BuildRequires:  swig >= 3.0.12
29 BuildRequires:  swig-python >= 2.0.12
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 BuildRequires:  zlib-devel
33 Requires:       gsl >= 1.13
34 Requires:       lal >= 6.18.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 LAL wrapping of the Simulation LIGO_LW XML library.
39
40 %description -l pl.UTF-8
41 Obudowanie LAL do biblioteki Simulation LILO_LW XML.
42
43 %package devel
44 Summary:        Header files for lal-simulation library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki lal-simulation
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       lal-devel >= 6.18.0
49
50 %description devel
51 Header files for lal-simulation library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki lal-simulation.
55
56 %package static
57 Summary:        Static lal-simulation library
58 Summary(pl.UTF-8):      Statyczna biblioteka lal-simulation
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static lal-simulation library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka lal-simulation.
67
68 %package -n octave-lalsimulation
69 Summary:        Octave interface for LAL Simulation
70 Summary(pl.UTF-8):      Interfejs Octave do biblioteki LAL Simulation
71 Group:          Applications/Math
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       octave-lal >= 6.18.0
74
75 %description -n octave-lalsimulation
76 Octave interface for LAL Simulation.
77
78 %description -n octave-lalsimulation -l pl.UTF-8
79 Interfejs Octave do biblioteki LAL Simulation.
80
81 %package -n python3-lalsimulation
82 Summary:        Python bindings for LAL Simulation
83 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki LAL Simulation
84 Group:          Libraries/Python
85 Requires:       %{name} = %{version}-%{release}
86 Requires:       python3-lal >= 6.18.0
87 Requires:       python3-modules >= 1:2.6
88
89 %description -n python3-lalsimulation
90 Python bindings for LAL Simulation.
91
92 %description -n python3-lalsimulation -l pl.UTF-8
93 Wiązania Pythona do biblioteki LAL Simulation.
94
95 %prep
96 %setup -q -n lalsimulation-%{version}
97 %patch0 -p1
98 %patch1 -p1
99
100 %build
101 %{__libtoolize}
102 %{__aclocal} -I gnuscripts
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         %{!?with_openmp:--disable-openmp} \
108         --enable-swig
109 %{__make} V=1
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 # obsoleted by pkg-config
118 %{__rm} $RPM_BUILD_ROOT%{_libdir}/liblalsimulation.la
119
120 install -d $RPM_BUILD_ROOT/etc/shrc.d
121 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/*sh $RPM_BUILD_ROOT/etc/shrc.d
122
123 %py_postclean
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS README.md
134 %attr(755,root,root) %{_bindir}/lalsim-*
135 %attr(755,root,root) %{_bindir}/lalsimulation_version
136 %attr(755,root,root) %{_libdir}/liblalsimulation.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/liblalsimulation.so.29
138 %{_datadir}/lalsimulation
139 /etc/shrc.d/lalsimulation-user-env.csh
140 /etc/shrc.d/lalsimulation-user-env.fish
141 /etc/shrc.d/lalsimulation-user-env.sh
142 %{_mandir}/man1/lalsim*.1*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/liblalsimulation.so
147 %{_includedir}/lal/LALSim*.h
148 %{_includedir}/lal/SWIGLALSimulation*.h
149 %{_includedir}/lal/SWIGLALSimulation*.i
150 %{_includedir}/lal/swiglalsimulation.i
151 %{_pkgconfigdir}/lalsimulation.pc
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/liblalsimulation.a
156
157 %files -n octave-lalsimulation
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/octave/*/site/oct/*/lalsimulation.oct
160
161 %files -n python3-lalsimulation
162 %defattr(644,root,root,755)
163 %dir %{py3_sitedir}/lalsimulation
164 %attr(755,root,root) %{py3_sitedir}/lalsimulation/_lalsimulation.so
165 %{py3_sitedir}/lalsimulation/*.py
166 %{py3_sitedir}/lalsimulation/__pycache__
167 %dir %{py3_sitedir}/lalsimulation/nrfits
168 %{py3_sitedir}/lalsimulation/nrfits/*.py
169 %{py3_sitedir}/lalsimulation/nrfits/__pycache__
170 %dir %{py3_sitedir}/lalsimulation/tilts_at_infinity
171 %{py3_sitedir}/lalsimulation/tilts_at_infinity/*.py
172 %{py3_sitedir}/lalsimulation/tilts_at_infinity/__pycache__
This page took 0.103604 seconds and 3 git commands to generate.