]> git.pld-linux.org Git - packages/lal-frame.git/blob - lal-frame.spec
Release 3 (by relup.sh)
[packages/lal-frame.git] / lal-frame.spec
1 # TODO: framec support (BR: pkgconfig(framecppc) >= 2.0.0)
2 Summary:        LAL wrapping of the LILO/Virgo Frame library
3 Summary(pl.UTF-8):      Obudowanie LAL do biblioteki LILO/Virgo Frame
4 Name:           lal-frame
5 Version:        1.5.5
6 Release:        3
7 License:        GPL v2+
8 Group:          Libraries
9 Source0:        http://software.ligo.org/lscsoft/source/lalsuite/lalframe-%{version}.tar.xz
10 # Source0-md5:  ec22d5d44122dcda02d1ce67757ed121
11 Patch0:         %{name}-env.patch
12 URL:            https://wiki.ligo.org/DASWG/LALSuite
13 BuildRequires:  autoconf >= 2.63
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  lal-devel >= 6.18.0
16 BuildRequires:  libframe-devel >= 8.41.5
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtool >= 2:2
19 BuildRequires:  octave-devel >= 1:3.2.0
20 BuildRequires:  pkgconfig
21 BuildRequires:  python3-devel
22 BuildRequires:  python3-numpy-devel
23 BuildRequires:  swig >= 3.0.12
24 BuildRequires:  swig-python >= 2.0.12
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 BuildRequires:  zlib-devel
28 Requires:       lal >= 6.18.0
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 LAL wrapping of the LILO/Virgo Frame library.
33
34 %description -l pl.UTF-8
35 Obudowanie LAL do biblioteki LILO/Virgo Frame.
36
37 %package devel
38 Summary:        Header files for lal-frame library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki lal-frame
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       lal-devel >= 6.18.0
43 Requires:       libframe-devel
44
45 %description devel
46 Header files for lal-frame library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki lal-frame.
50
51 %package static
52 Summary:        Static lal-frame library
53 Summary(pl.UTF-8):      Statyczna biblioteka lal-frame
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static lal-frame library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka lal-frame.
62
63 %package -n octave-lalframe
64 Summary:        Octave interface for LAL Frame
65 Summary(pl.UTF-8):      Interfejs Octave do biblioteki LAL Frame
66 Group:          Applications/Math
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       octave-lal >= 6.18.0
69
70 %description -n octave-lalframe
71 Octave interface for LAL Frame.
72
73 %description -n octave-lalframe -l pl.UTF-8
74 Interfejs Octave do biblioteki LAL Frame.
75
76 %package -n python3-lalframe
77 Summary:        Python bindings for LAL Frame
78 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki LAL Frame
79 Group:          Libraries/Python
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       python3-lal >= 6.18.0
82 Requires:       python3-modules >= 1:2.6
83
84 %description -n python3-lalframe
85 Python bindings for LAL Frame.
86
87 %description -n python3-lalframe -l pl.UTF-8
88 Wiązania Pythona do biblioteki LAL Frame.
89
90 %prep
91 %setup -q -n lalframe-%{version}
92 %patch0 -p1
93
94 %build
95 %{__libtoolize}
96 %{__aclocal} -I gnuscripts
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --disable-silent-rules \
102         --enable-swig
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 # obsoleted by pkg-config
112 %{__rm} $RPM_BUILD_ROOT%{_libdir}/liblalframe.la
113
114 install -d $RPM_BUILD_ROOT/etc/shrc.d
115 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/*sh $RPM_BUILD_ROOT/etc/shrc.d
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS README.md
126 %attr(755,root,root) %{_bindir}/lalfr-*
127 %attr(755,root,root) %{_bindir}/lalframe_version
128 %attr(755,root,root) %{_libdir}/liblalframe.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/liblalframe.so.11
130 /etc/shrc.d/lalframe-user-env.csh
131 /etc/shrc.d/lalframe-user-env.fish
132 /etc/shrc.d/lalframe-user-env.sh
133 %{_mandir}/man1/lalfr-*.1*
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/liblalframe.so
138 %{_includedir}/lal/FrameCalibration.h
139 %{_includedir}/lal/LALFrStream.h
140 %{_includedir}/lal/LALFrame*.h
141 %{_includedir}/lal/SWIGLALFrame*.h
142 %{_includedir}/lal/SWIGLALFrame*.i
143 %{_includedir}/lal/swiglalframe.i
144 %{_pkgconfigdir}/lalframe.pc
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/liblalframe.a
149
150 %files -n octave-lalframe
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/octave/*/site/oct/*/lalframe.oct
153
154 %files -n python3-lalframe
155 %defattr(644,root,root,755)
156 %dir %{py3_sitedir}/lalframe
157 %attr(755,root,root) %{py3_sitedir}/lalframe/_lalframe.so
158 %{py3_sitedir}/lalframe/*.py
159 %{py3_sitedir}/lalframe/__pycache__
160 %dir %{py3_sitedir}/lalframe/utils
161 %{py3_sitedir}/lalframe/utils/*.py
162 %{py3_sitedir}/lalframe/utils/__pycache__
This page took 0.056669 seconds and 3 git commands to generate.