]> git.pld-linux.org Git - packages/kp6-plasma-welcome.git/blob - kp6-plasma-welcome.spec
- updated to 6.0.1
[packages/kp6-plasma-welcome.git] / kp6-plasma-welcome.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    6.0.1
5 %define         qtver           5.15.2
6 %define         kpname          plasma-welcome
7 %define         kf6ver          5.102.0
8
9 Summary:        Plasma Welcome App
10 Name:           kp6-%{kpname}
11 Version:        6.0.1
12 Release:        1
13 License:        LGPL v2.1+
14 Group:          X11/Applications
15 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
16 # Source0-md5:  159ab3fbdb73a06d8ec238da0c707d37
17 URL:            https://kde.org/
18 BuildRequires:  Qt6Core-devel >= 5.15.2
19 BuildRequires:  Qt6Gui-devel >= 5.15.2
20 BuildRequires:  Qt6Network-devel
21 BuildRequires:  Qt6Qml-devel
22 BuildRequires:  Qt6Quick-devel
23 BuildRequires:  Qt6Svg-devel
24 BuildRequires:  Qt6Widgets-devel >= 5.15.0
25 BuildRequires:  cmake >= 3.16.0
26 BuildRequires:  fontconfig-devel
27 BuildRequires:  freetype-devel
28 BuildRequires:  gettext
29 BuildRequires:  gettext-devel
30 BuildRequires:  ka6-kaccounts-integration-devel
31 BuildRequires:  kf6-attica-devel >= 5.103.0
32 BuildRequires:  kf6-extra-cmake-modules >= 5.82
33 BuildRequires:  kf6-kauth-devel >= 5.103.0
34 BuildRequires:  kf6-kcodecs-devel >= 5.103.0
35 BuildRequires:  kf6-kcompletion-devel >= 5.103.0
36 BuildRequires:  kf6-kconfigwidgets-devel >= 5.103.0
37 BuildRequires:  kf6-kcoreaddons-devel >= 5.97.0
38 BuildRequires:  kf6-kdbusaddons-devel >= 5.98
39 BuildRequires:  kf6-kdeclarative-devel >= 5.98
40 BuildRequires:  kf6-ki18n-devel >= 5.98
41 BuildRequires:  kf6-kio-devel >= 5.98
42 BuildRequires:  kf6-kirigami-devel >= 5.98
43 BuildRequires:  kf6-kitemviews-devel >= 5.103.0
44 BuildRequires:  kf6-kjobwidgets-devel >= 5.103.0
45 BuildRequires:  kf6-knewstuff-devel >= 5.98
46 BuildRequires:  kf6-knotifications-devel >= 5.98
47 BuildRequires:  kf6-kpackage-devel >= 5.103.0
48 BuildRequires:  kf6-kservice-devel >= 5.98
49 BuildRequires:  kf6-kwidgetsaddons-devel >= 5.103.0
50 BuildRequires:  kf6-kwindowsystem-devel >= 5.98
51 BuildRequires:  kf6-kxmlgui-devel >= 5.103.0
52 BuildRequires:  kf6-solid-devel >= 5.103.0
53 BuildRequires:  kirigami-addons-devel >= 0.11.90
54 BuildRequires:  kuserfeedback-devel
55 BuildRequires:  ninja
56 BuildRequires:  pkgconfig
57 BuildRequires:  pkgconfig
58 BuildRequires:  rpmbuild(macros) >= 1.164
59 BuildRequires:  xz
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %define         qt6dir          %{_libdir}/qt6
63
64 %description
65 A Friendly onboarding wizard for Plasma
66
67 Welcome Center is the perfect introduction to KDE Plasma! It can help
68 you learn how to connect to the internet, install apps, customize the
69 system, and more!
70
71 There are two usage modes:
72 - Run the app normally and it will show a welcome/onboarding wizard.
73 - Run the app with the `--after-upgrade-to` argument to show a
74   post-upgrade message. For example: `plasma-welcome --after-upgrade-to
75   5.25`.
76
77 %prep
78 %setup -q -n %{kpname}-%{version}
79
80 %build
81 %cmake -B build \
82         -G Ninja \
83         %{!?with_tests:-DBUILD_TESTING=OFF} \
84         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
85         -DKDE_INSTALL_DOCBUNDLEDIR=%{_kdedocdir}
86 %ninja_build -C build
87
88 %if %{with tests}
89 ctest
90 %endif
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 %ninja_install -C build
95
96 %find_lang %{kpname} --all-name --with-kde
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files -f %{kpname}.lang
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_bindir}/plasma-welcome
104 %attr(755,root,root) %{_libdir}/qt6/plugins/kf6/kded/kded_plasma-welcome.so
105 %{_desktopdir}/org.kde.plasma-welcome.desktop
106 %{_datadir}/metainfo/org.kde.plasma-welcome.appdata.xml
This page took 0.02976 seconds and 3 git commands to generate.