]> git.pld-linux.org Git - packages/kp5-polkit-kde-agent.git/blob - kp5-polkit-kde-agent.spec
24f7c27ecdeab4c51ae132761e6373fea8a85773
[packages/kp5-polkit-kde-agent.git] / kp5-polkit-kde-agent.spec
1 %define         kdeplasmaver    5.23.4
2 %define         qtver           5.9.0
3 %define         kpname          polkit-kde-agent
4
5 Summary:        Daemon providing a polkit authentication UI for KDE
6 Name:           kp5-%{kpname}
7 Version:        5.23.4
8 Release:        2
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-1-%{version}.tar.xz
12 # Source0-md5:  a4c54e6faa3539f87327fed2957d46e6
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  cmake >= 2.8.12
16 BuildRequires:  kf5-kconfig-devel
17 BuildRequires:  kf5-kcoreaddons-devel
18 BuildRequires:  kf5-kcrash-devel
19 BuildRequires:  kf5-kdbusaddons-devel
20 BuildRequires:  kf5-ki18n-devel
21 BuildRequires:  kf5-kiconthemes-devel
22 BuildRequires:  kf5-knotifications-devel
23 BuildRequires:  kf5-kwidgetsaddons-devel
24 BuildRequires:  kf5-kwindowsystem-devel
25 BuildRequires:  ninja
26 BuildRequires:  polkit-qt5-1-gui-devel
27 BuildRequires:  rpmbuild(macros) >= 1.164
28 BuildRequires:  xz
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         qt5dir          %{_libdir}/qt5
32
33 %description
34 Daemon providing a polkit authentication UI for KDE.
35
36 %prep
37 %setup -q -n %{kpname}-1-%{version}
38
39 %build
40 install -d build
41 cd build
42 %cmake -G Ninja \
43         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
44         -DHTML_INSTALL_DIR=%{_kdedocdir} \
45         ../
46 %ninja_build
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %ninja_install -C build
51
52 %find_lang %{kpname} --all-name --with-kde
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post -p /sbin/ldconfig
58 %postun -p /sbin/ldconfig
59
60 %files -f %{kpname}.lang
61 %defattr(644,root,root,755)
62 %attr(755,root,root) %{_libexecdir}/polkit-kde-authentication-agent-1
63 /etc/xdg/autostart/polkit-kde-authentication-agent-1.desktop
64 %{_datadir}/knotifications5/policykit1-kde.notifyrc
65 %{_desktopdir}/org.kde.polkit-kde-authentication-agent-1.desktop
66 %{systemduserunitdir}/plasma-polkit-agent.service
This page took 0.019411 seconds and 2 git commands to generate.