]> git.pld-linux.org Git - packages/kp5-polkit-kde-agent.git/blob - kp5-polkit-kde-agent.spec
1e8cd3c7a9ce2639d8e44a2e7ef4d27c82116223
[packages/kp5-polkit-kde-agent.git] / kp5-polkit-kde-agent.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.25.3
5 %define         qtver           5.15.2
6 %define         kpname          polkit-kde-agent
7
8 Summary:        Daemon providing a polkit authentication UI for KDE
9 Name:           kp5-%{kpname}
10 Version:        5.25.3
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-1-%{version}.tar.xz
15 # Source0-md5:  8a53db3e1e2c0f860ce0ac5ffd4dc65b
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-kconfig-devel
20 BuildRequires:  kf5-kcoreaddons-devel
21 BuildRequires:  kf5-kcrash-devel
22 BuildRequires:  kf5-kdbusaddons-devel
23 BuildRequires:  kf5-ki18n-devel
24 BuildRequires:  kf5-kiconthemes-devel
25 BuildRequires:  kf5-knotifications-devel
26 BuildRequires:  kf5-kwidgetsaddons-devel
27 BuildRequires:  kf5-kwindowsystem-devel
28 BuildRequires:  ninja
29 BuildRequires:  polkit-qt5-1-gui-devel
30 BuildRequires:  rpmbuild(macros) >= 1.164
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 Daemon providing a polkit authentication UI for KDE.
38
39 %prep
40 %setup -q -n %{kpname}-1-%{version}
41
42 %build
43 install -d build
44 cd build
45 %cmake -G Ninja \
46         %{!?with_tests:-DBUILD_TESTING=OFF} \
47         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
48         -DHTML_INSTALL_DIR=%{_kdedocdir} \
49         ../
50 %ninja_build
51
52 %if %{with tests}
53 ctest
54 %endif
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 %ninja_install -C build
59
60 %find_lang %{kpname} --all-name --with-kde
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post -p /sbin/ldconfig
66 %postun -p /sbin/ldconfig
67
68 %files -f %{kpname}.lang
69 %defattr(644,root,root,755)
70 %attr(755,root,root) %{_libexecdir}/polkit-kde-authentication-agent-1
71 /etc/xdg/autostart/polkit-kde-authentication-agent-1.desktop
72 %{_datadir}/knotifications5/policykit1-kde.notifyrc
73 %{_desktopdir}/org.kde.polkit-kde-authentication-agent-1.desktop
74 %{systemduserunitdir}/plasma-polkit-agent.service
This page took 0.026333 seconds and 2 git commands to generate.