]> git.pld-linux.org Git - packages/kp5-plymouth-kcm.git/blob - kp5-plymouth-kcm.spec
- updated to 5.26.1
[packages/kp5-plymouth-kcm.git] / kp5-plymouth-kcm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.26.1
5 %define         qtver           5.15.2
6 %define         kpname          plymouth-kcm
7
8 Summary:        KDE Config Module for Plyouth
9 Name:           kp5-%{kpname}
10 Version:        5.26.1
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  57d928ef871616ddbf38401debe1530a
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= 5.15.0
18 BuildRequires:  Qt5Gui-devel >= 5.15.0
19 BuildRequires:  Qt5Network-devel >= 5.15.0
20 BuildRequires:  Qt5Qml-devel >= 5.15.2
21 BuildRequires:  Qt5Quick-devel >= 5.15.0
22 BuildRequires:  cmake >= 2.8.12
23 BuildRequires:  gettext-devel
24 BuildRequires:  kf5-extra-cmake-modules >= 5.82
25 BuildRequires:  kf5-karchive-devel >= 5.82
26 BuildRequires:  kf5-kconfig-devel >= 5.82
27 BuildRequires:  kf5-kdeclarative-devel >= 5.82
28 BuildRequires:  kf5-ki18n-devel >= 5.82
29 BuildRequires:  kf5-kio-devel >= 5.82
30 BuildRequires:  kf5-knewstuff-devel >= 5.82
31 BuildRequires:  ninja
32 BuildRequires:  plymouth-devel
33 BuildRequires:  rpmbuild(macros) >= 1.164
34 BuildRequires:  xz
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         qt5dir          %{_libdir}/qt5
38
39 %description
40 KDE Config Module for Plymouth.
41
42 %prep
43 %setup -q -n %{kpname}-%{version}
44
45 %build
46 install -d build
47 cd build
48 %cmake -G Ninja \
49         %{!?with_tests:-DBUILD_TESTING=OFF} \
50         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
51         -DHTML_INSTALL_DIR=%{_kdedocdir} \
52         ../
53 %ninja_build
54
55 %if %{with tests}
56 ctest
57 %endif
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 %ninja_install -C build
62
63 %find_lang %{kpname} --all-name --with-kde
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post   -p /sbin/ldconfig
69 %postun -p /sbin/ldconfig
70
71 %files -f %{kpname}.lang
72 %defattr(644,root,root,755)
73 %attr(755,root,root) %{_bindir}/kplymouththemeinstaller
74 %attr(755,root,root) %{_prefix}/libexec/kauth/plymouthhelper
75 %{_datadir}/dbus-1/system-services/org.kde.kcontrol.kcmplymouth.service
76 %{_datadir}/dbus-1/system.d/org.kde.kcontrol.kcmplymouth.conf
77 %{_datadir}/knsrcfiles/plymouth.knsrc
78 %dir %{_datadir}/kpackage/kcms/kcm_plymouth
79 %dir %{_datadir}/kpackage/kcms/kcm_plymouth/contents
80 %dir %{_datadir}/kpackage/kcms/kcm_plymouth/contents/ui
81 %{_datadir}/kpackage/kcms/kcm_plymouth/contents/ui/main.qml
82 %{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmplymouth.policy
83 %{_libdir}/qt5/plugins/plasma/kcms/systemsettings/kcm_plymouth.so
84 %{_desktopdir}/kcm_plymouth.desktop
This page took 0.065877 seconds and 3 git commands to generate.