]> git.pld-linux.org Git - packages/kp5-plasma-thunderbolt.git/blob - kp5-plasma-thunderbolt.spec
- updated to 5.24.4
[packages/kp5-plasma-thunderbolt.git] / kp5-plasma-thunderbolt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.24.4
5 %define         qtver           5.9.0
6 %define         kpname          plasma-thunderbolt
7 %define         kf5ver          5.39.0
8
9 Summary:        plasma-nm
10 Name:           kp5-%{kpname}
11 Version:        5.24.4
12 Release:        1
13 License:        LGPL v2.1+
14 Group:          X11/Libraries
15 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
16 # Source0-md5:  345f01891b5d5e722ead609932cd9d6a
17 URL:            http://www.kde.org/
18 BuildRequires:  Qt5Core-devel >= 5.15.0
19 BuildRequires:  Qt5DBus-devel >= 5.15.0
20 BuildRequires:  Qt5Gui-devel >= 5.15.0
21 BuildRequires:  Qt5Network-devel >= 5.15.2
22 BuildRequires:  Qt5Qml-devel >= 5.15.2
23 BuildRequires:  Qt5Quick-devel >= 5.15.0
24 BuildRequires:  cmake >= 2.8.12
25 BuildRequires:  gettext-devel
26 BuildRequires:  kf5-extra-cmake-modules >= 5.70
27 BuildRequires:  kf5-kauth-devel >= 5.85.0
28 BuildRequires:  kf5-kcmutils-devel >= 5.70
29 BuildRequires:  kf5-kcodecs-devel >= 5.85.0
30 BuildRequires:  kf5-kconfig-devel >= 5.85.0
31 BuildRequires:  kf5-kcoreaddons-devel >= 5.85.0
32 BuildRequires:  kf5-kdbusaddons-devel >= 5.70
33 BuildRequires:  kf5-kdeclarative-devel >= 5.70
34 BuildRequires:  kf5-ki18n-devel >= 5.70
35 BuildRequires:  kf5-knotifications-devel >= 5.70
36 BuildRequires:  kf5-kpackage-devel >= 5.85.0
37 BuildRequires:  kf5-kservice-devel >= 5.85.0
38 BuildRequires:  ninja
39 BuildRequires:  pkgconfig
40 BuildRequires:  rpmbuild(macros) >= 1.164
41 BuildRequires:  xz
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         qt5dir          %{_libdir}/qt5
45
46 %description
47 This repository contains a Plasma Sytem Settings module and a KDED
48 module to handle authorization of Thunderbolt devices connected to the
49 computer. There's also a shared library (libkbolt) that implements
50 common interface between the modules and the system-wide bolt daemon,
51 which does the actual hard work of talking to the kernel.
52
53 %prep
54 %setup -q -n %{kpname}-%{version}
55
56 %build
57 install -d build
58 cd build
59 %cmake -G Ninja \
60         %{!?with_tests:-DBUILD_TESTING=OFF} \
61         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
62         -DHTML_INSTALL_DIR=%{_kdedocdir} \
63         ../
64 %ninja_build
65
66 %if %{with tests}
67 ctest
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 %ninja_install -C build
73
74 %find_lang %{kpname} --all-name --with-kde
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files -f %{kpname}.lang
83 %defattr(644,root,root,755)
84 %{_libdir}/libkbolt.so
85 %{_libdir}/qt5/plugins/kf5/kded/kded_bolt.so
86 %{_datadir}/knotifications5/kded_bolt.notifyrc
87 %dir %{_datadir}/kpackage/kcms/kcm_bolt
88 %dir %{_datadir}/kpackage/kcms/kcm_bolt/contents
89 %dir %{_datadir}/kpackage/kcms/kcm_bolt/contents/ui
90 %{_datadir}/kpackage/kcms/kcm_bolt/contents/ui/DeviceList.qml
91 %{_datadir}/kpackage/kcms/kcm_bolt/contents/ui/DeviceView.qml
92 %{_datadir}/kpackage/kcms/kcm_bolt/contents/ui/main.qml
93 %{_datadir}/kpackage/kcms/kcm_bolt/contents/ui/utils.js
94 %{_libdir}/qt5/plugins/plasma/kcms/systemsettings/kcm_bolt.so
95 %{_desktopdir}/kcm_bolt.desktop
This page took 0.075456 seconds and 3 git commands to generate.