]> git.pld-linux.org Git - packages/kp5-plasma-thunderbolt.git/blob - kp5-plasma-thunderbolt.spec
- updated to 5.23.1
[packages/kp5-plasma-thunderbolt.git] / kp5-plasma-thunderbolt.spec
1 %define         kdeplasmaver    5.23.1
2 %define         qtver           5.9.0
3 %define         kpname          plasma-thunderbolt
4 %define         kf5ver          5.39.0
5
6 Summary:        plasma-nm
7 Name:           kp5-%{kpname}
8 Version:        5.23.1
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          X11/Libraries
12 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
13 # Source0-md5:  2d7609382cd96ea11749a63b970cc19b
14 URL:            http://www.kde.org/
15 BuildRequires:  Qt5Core-devel >= 5.15.0
16 BuildRequires:  Qt5DBus-devel >= 5.15.0
17 BuildRequires:  Qt5Gui-devel >= 5.15.0
18 BuildRequires:  Qt5Network-devel >= 5.15.2
19 BuildRequires:  Qt5Qml-devel >= 5.15.2
20 BuildRequires:  Qt5Quick-devel >= 5.15.0
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  gettext-devel
23 BuildRequires:  kf5-extra-cmake-modules >= 5.70
24 BuildRequires:  kf5-kauth-devel >= 5.85.0
25 BuildRequires:  kf5-kcmutils-devel >= 5.70
26 BuildRequires:  kf5-kcodecs-devel >= 5.85.0
27 BuildRequires:  kf5-kconfig-devel >= 5.85.0
28 BuildRequires:  kf5-kcoreaddons-devel >= 5.85.0
29 BuildRequires:  kf5-kdbusaddons-devel >= 5.70
30 BuildRequires:  kf5-kdeclarative-devel >= 5.70
31 BuildRequires:  kf5-ki18n-devel >= 5.70
32 BuildRequires:  kf5-knotifications-devel >= 5.70
33 BuildRequires:  kf5-kpackage-devel >= 5.85.0
34 BuildRequires:  kf5-kservice-devel >= 5.85.0
35 BuildRequires:  ninja
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpmbuild(macros) >= 1.164
38 BuildRequires:  xz
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         qt5dir          %{_libdir}/qt5
42
43 %description
44 This repository contains a Plasma Sytem Settings module and a KDED
45 module to handle authorization of Thunderbolt devices connected to the
46 computer. There's also a shared library (libkbolt) that implements
47 common interface between the modules and the system-wide bolt daemon,
48 which does the actual hard work of talking to the kernel.
49
50 %prep
51 %setup -q -n %{kpname}-%{version}
52
53 %build
54 install -d build
55 cd build
56 %cmake -G Ninja \
57         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
58         -DHTML_INSTALL_DIR=%{_kdedocdir} \
59         ../
60 %ninja_build
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %ninja_install -C build
65
66 %find_lang %{kpname} --all-name --with-kde
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post -p /sbin/ldconfig
72 %postun -p /sbin/ldconfig
73
74 %files -f %{kpname}.lang
75 %defattr(644,root,root,755)
76 %{_libdir}/libkbolt.so
77 %{_libdir}/qt5/plugins/kcms/kcm_bolt.so
78 %{_libdir}/qt5/plugins/kf5/kded/kded_bolt.so
79 %{_datadir}/knotifications5/kded_bolt.notifyrc
80 %dir %{_datadir}/kpackage/kcms/kcm_bolt
81 %dir %{_datadir}/kpackage/kcms/kcm_bolt/contents
82 %dir %{_datadir}/kpackage/kcms/kcm_bolt/contents/ui
83 %{_datadir}/kpackage/kcms/kcm_bolt/contents/ui/DeviceList.qml
84 %{_datadir}/kpackage/kcms/kcm_bolt/contents/ui/DeviceView.qml
85 %{_datadir}/kpackage/kcms/kcm_bolt/contents/ui/main.qml
86 %{_datadir}/kpackage/kcms/kcm_bolt/contents/ui/utils.js
87 %{_datadir}/kpackage/kcms/kcm_bolt/metadata.desktop
88 %{_datadir}/kpackage/kcms/kcm_bolt/metadata.json
89 %{_datadir}/kservices5/kcm_bolt.desktop
This page took 0.091499 seconds and 3 git commands to generate.