]> git.pld-linux.org Git - packages/kp5-plasma-systemmonitor.git/blob - kp5-plasma-systemmonitor.spec
- updated to 5.25.4
[packages/kp5-plasma-systemmonitor.git] / kp5-plasma-systemmonitor.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.25.4
5 %define         qtver           5.15.2
6 %define         kpname          plasma-systemmonitor
7 %define         kf5ver          5.39.0
8
9 Summary:        plasma-systemmonitor
10 Name:           kp5-%{kpname}
11 Version:        5.25.4
12 Release:        1
13 License:        LGPL v2.1+
14 Group:          X11/Libraries
15 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
16 # Source0-md5:  030f1d0236b31407745300858f4f6db5
17 URL:            http://www.kde.org/
18 BuildRequires:  Qt5Core-devel >= %{qtver}
19 BuildRequires:  Qt5DBus-devel >= 5.15.0
20 BuildRequires:  Qt5Gui-devel >= 5.15.0
21 BuildRequires:  Qt5Network-devel >= 5.15.0
22 BuildRequires:  Qt5Qml-devel >= 5.15.2
23 BuildRequires:  Qt5Quick-devel >= 5.15.0
24 BuildRequires:  Qt5Widgets-devel >= 5.15.0
25 BuildRequires:  cmake >= 2.8.12
26 BuildRequires:  gettext-devel
27 BuildRequires:  kf5-extra-cmake-modules >= 5.82
28 BuildRequires:  kf5-kconfig-devel >= 5.82
29 BuildRequires:  kf5-kdbusaddons-devel >= 5.82
30 BuildRequires:  kf5-kdeclarative-devel >= 5.82
31 BuildRequires:  kf5-kglobalaccel-devel >= 5.82
32 BuildRequires:  kf5-ki18n-devel >= 5.82
33 BuildRequires:  kf5-kiconthemes-devel >= 5.82
34 BuildRequires:  kf5-kio-devel >= 5.82
35 BuildRequires:  kf5-kitemmodels-devel >= 5.82
36 BuildRequires:  kf5-knewstuff-devel >= 5.82
37 BuildRequires:  kf5-kservice-devel >= 5.85.0
38 BuildRequires:  kp5-libksysguard-devel >= 5.22.5
39
40 BuildRequires:  ninja
41 BuildRequires:  pkgconfig
42 BuildRequires:  rpmbuild(macros) >= 1.164
43 BuildRequires:  xz
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         qt5dir          %{_libdir}/qt5
47
48 %description
49 An application for monitoring system resources.
50
51 plasma-systemmonitor provides an interface for monitoring system
52 sensors, process information and other system resources. It is built
53 on top of the faces system also used to provide widgets for
54 plasma-dekstop and makes use of the ksystemstats daemon to provide
55 sensor information. It allows extensive customisation of pages, so it
56 can be made to show exactly which data people want to see.
57
58 %prep
59 %setup -q -n %{kpname}-%{version}
60
61 %build
62 install -d build
63 cd build
64 %cmake -G Ninja \
65         %{!?with_tests:-DBUILD_TESTING=OFF} \
66         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
67         -DHTML_INSTALL_DIR=%{_kdedocdir} \
68         ../
69 %ninja_build
70
71 %if %{with tests}
72 ctest
73 %endif
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 %ninja_install -C build
78
79 %find_lang %{kpname} --all-name --with-kde
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files -f %{kpname}.lang
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_bindir}/plasma-systemmonitor
87 %{_libdir}/qt5/qml/org/kde/ksysguard/page
88 %{_libdir}/qt5/qml/org/kde/ksysguard/table
89 %{_desktopdir}/org.kde.plasma-systemmonitor.desktop
90 %{_datadir}/config.kcfg/systemmonitor.kcfg
91 %{_datadir}/knsrcfiles/plasma-systemmonitor.knsrc
92 %{_datadir}/ksysguard/sensorfaces/org.kde.ksysguard.applicationstable
93 %{_datadir}/ksysguard/sensorfaces/org.kde.ksysguard.processtable
94 %{_datadir}/plasma-systemmonitor
95 %dir %{_datadir}/plasma/kinfocenter/externalmodules
96 %{_datadir}/plasma/kinfocenter/externalmodules/kcm_external_plasma-systemmonitor.desktop
This page took 0.112879 seconds and 3 git commands to generate.