]> git.pld-linux.org Git - packages/kp5-plasma-integration.git/blob - kp5-plasma-integration.spec
- update to 5.21.2
[packages/kp5-plasma-integration.git] / kp5-plasma-integration.spec
1 # TODO:
2 # PackageKit qt5
3 #
4 %define         kdeplasmaver    5.21.2
5 %define         qtver           5.9.0
6 %define         kpname          plasma-integration
7
8 Summary:        KDE Plasma Integration
9 Name:           kp5-%{kpname}
10 Version:        5.21.2
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  5f22260cee05c50c7d603aa9e700b5ec
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  fontconfig-devel
20 BuildRequires:  kf5-attica-devel
21 BuildRequires:  kf5-kactivities-stats-devel
22 BuildRequires:  kf5-kauth-devel
23 BuildRequires:  kf5-kcmutils-devel
24 BuildRequires:  kf5-kdbusaddons-devel
25 BuildRequires:  kf5-kdeclarative-devel
26 BuildRequires:  kf5-kdelibs4support-devel
27 BuildRequires:  kf5-kdoctools-devel
28 BuildRequires:  kf5-kglobalaccel-devel
29 BuildRequires:  kf5-ki18n-devel
30 BuildRequires:  kf5-knewstuff-devel
31 BuildRequires:  kf5-knotifications-devel
32 BuildRequires:  kf5-knotifyconfig-devel
33 BuildRequires:  kf5-kpeople-devel
34 BuildRequires:  kf5-krunner-devel
35 BuildRequires:  kf5-kwallet-devel
36 BuildRequires:  kf5-kwayland-devel
37 BuildRequires:  kf5-plasma-framework-devel
38 BuildRequires:  kp5-breeze-devel
39 BuildRequires:  ninja
40 BuildRequires:  rpmbuild(macros) >= 1.164
41 BuildRequires:  xorg-driver-input-evdev-devel
42 BuildRequires:  xorg-driver-input-synaptics-devel
43 BuildRequires:  xorg-lib-libXft-devel
44 BuildRequires:  xz
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         qt5dir          %{_libdir}/qt5
48
49 %description
50 KDE Plasma Integration.
51
52 %prep
53 %setup -q -n %{kpname}-%{version}
54
55 %build
56 install -d build
57 cd build
58 %cmake -G Ninja \
59         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
60         ../
61 %ninja_build
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 %ninja_install -C build
66
67 %find_lang %{kpname} --all-name --with-kde
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files -f %{kpname}.lang
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{_libdir}/qt5/plugins/platformthemes/KDEPlasmaPlatformTheme.so
78 %{_datadir}/kconf_update/fonts_akregator.pl
79 %{_datadir}/kconf_update/fonts_akregator.upd
80 %{_datadir}/kconf_update/fonts_global.pl
81 %{_datadir}/kconf_update/fonts_global.upd
82 %{_datadir}/kconf_update/fonts_global_toolbar.upd
83 %{_datadir}/kconf_update/fonts_kate.pl
84 %{_datadir}/kconf_update/fonts_kate.upd
This page took 0.095496 seconds and 3 git commands to generate.