]> git.pld-linux.org Git - packages/kp5-plasma-integration.git/blob - kp5-plasma-integration.spec
- updated to 5.23.1
[packages/kp5-plasma-integration.git] / kp5-plasma-integration.spec
1 # TODO:
2 # PackageKit qt5
3 #
4 %define         kdeplasmaver    5.23.1
5 %define         qtver           5.9.0
6 %define         kpname          plasma-integration
7
8 Summary:        KDE Plasma Integration
9 Name:           kp5-%{kpname}
10 Version:        5.23.1
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  2621433f73b9ce63b09f73efeb0ed147
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  fontconfig-devel
20 BuildRequires:  kf5-attica-devel
21 BuildRequires:  kf5-kactivities-stats-devel
22 BuildRequires:  kf5-kauth-devel
23 BuildRequires:  kf5-kcmutils-devel
24 BuildRequires:  kf5-kdbusaddons-devel
25 BuildRequires:  kf5-kdeclarative-devel
26 BuildRequires:  kf5-kdelibs4support-devel
27 BuildRequires:  kf5-kdoctools-devel
28 BuildRequires:  kf5-kglobalaccel-devel
29 BuildRequires:  kf5-ki18n-devel
30 BuildRequires:  kf5-knewstuff-devel
31 BuildRequires:  kf5-knotifications-devel
32 BuildRequires:  kf5-knotifyconfig-devel
33 BuildRequires:  kf5-kpeople-devel
34 BuildRequires:  kf5-krunner-devel
35 BuildRequires:  kf5-kwallet-devel
36 BuildRequires:  kf5-kwayland-devel
37 BuildRequires:  kf5-plasma-framework-devel
38 BuildRequires:  kp5-breeze-devel
39 BuildRequires:  ninja
40 BuildRequires:  rpmbuild(macros) >= 1.164
41 BuildRequires:  xorg-driver-input-evdev-devel
42 BuildRequires:  xorg-driver-input-synaptics-devel
43 BuildRequires:  xorg-lib-libXft-devel
44 BuildRequires:  xz
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         qt5dir          %{_libdir}/qt5
48
49 %description
50 KDE Plasma Integration.
51
52 %package devel
53 Summary:        Header files for %{kpname} development
54 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
55 Group:          X11/Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description devel
59 Header files for %{kpname} development.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe dla programistów używających %{kpname}.
63
64 %prep
65 %setup -q -n %{kpname}-%{version}
66
67 %build
68 install -d build
69 cd build
70 %cmake -G Ninja \
71         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
72         ../
73 %ninja_build
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 %ninja_install -C build
78
79 %find_lang %{kpname} --all-name --with-kde
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files -f %{kpname}.lang
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_libdir}/qt5/plugins/platformthemes/KDEPlasmaPlatformTheme.so
90 %attr(755,root,root) %{_libdir}/qt5/plugins/platforminputcontexts/plasmaimplatforminputcontextplugin.so
91 %{_datadir}/kconf_update/fonts_akregator.pl
92 %{_datadir}/kconf_update/fonts_akregator.upd
93 %{_datadir}/kconf_update/fonts_global.pl
94 %{_datadir}/kconf_update/fonts_global.upd
95 %{_datadir}/kconf_update/fonts_global_toolbar.upd
96 %{_datadir}/kconf_update/fonts_kate.pl
97 %{_datadir}/kconf_update/fonts_kate.upd
98
99 %files devel
100 %defattr(644,root,root,755)
101 %{_includedir}/PlasmaKeyData
102 %{_pkgconfigdir}/plasma-key-data.pc
This page took 0.074153 seconds and 3 git commands to generate.