]> git.pld-linux.org Git - packages/kp5-plasma-integration.git/blob - kp5-plasma-integration.spec
194b554dd721a39563e53ca18a55b088a751a8be
[packages/kp5-plasma-integration.git] / kp5-plasma-integration.spec
1 # TODO:
2 # PackageKit qt5
3 #
4 %define         kdeplasmaver    5.24.3
5 %define         qtver           5.15.2
6 %define         kpname          plasma-integration
7
8 Summary:        KDE Plasma Integration
9 Name:           kp5-%{kpname}
10 Version:        5.24.3
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  5cbfc4b8d729e0334e6c13a98f6017ed
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Quick-controls2-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  fontconfig-devel
21 BuildRequires:  kf5-attica-devel
22 BuildRequires:  kf5-kactivities-stats-devel
23 BuildRequires:  kf5-kauth-devel
24 BuildRequires:  kf5-kcmutils-devel
25 BuildRequires:  kf5-kdbusaddons-devel
26 BuildRequires:  kf5-kdeclarative-devel
27 BuildRequires:  kf5-kdelibs4support-devel
28 BuildRequires:  kf5-kdoctools-devel
29 BuildRequires:  kf5-kglobalaccel-devel
30 BuildRequires:  kf5-ki18n-devel
31 BuildRequires:  kf5-knewstuff-devel
32 BuildRequires:  kf5-knotifications-devel
33 BuildRequires:  kf5-knotifyconfig-devel
34 BuildRequires:  kf5-kpeople-devel
35 BuildRequires:  kf5-krunner-devel
36 BuildRequires:  kf5-kwallet-devel
37 BuildRequires:  kf5-kwayland-devel
38 BuildRequires:  kf5-plasma-framework-devel
39 BuildRequires:  kp5-breeze-devel
40 BuildRequires:  ninja
41 BuildRequires:  rpmbuild(macros) >= 1.164
42 BuildRequires:  xorg-driver-input-evdev-devel
43 BuildRequires:  xorg-driver-input-synaptics-devel
44 BuildRequires:  xorg-lib-libXft-devel
45 BuildRequires:  xz
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         qt5dir          %{_libdir}/qt5
49
50 %description
51 KDE Plasma Integration.
52
53 %package devel
54 Summary:        Header files for %{kpname} development
55 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
56 Group:          X11/Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description devel
60 Header files for %{kpname} development.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe dla programistów używających %{kpname}.
64
65 %prep
66 %setup -q -n %{kpname}-%{version}
67
68 %build
69 install -d build
70 cd build
71 %cmake -G Ninja \
72         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
73         ../
74 %ninja_build
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 %ninja_install -C build
79
80 %find_lang %{kpname} --all-name --with-kde
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files -f %{kpname}.lang
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/qt5/plugins/platformthemes/KDEPlasmaPlatformTheme.so
91 %attr(755,root,root) %{_libdir}/qt5/plugins/platforminputcontexts/plasmaimplatforminputcontextplugin.so
92 %{_datadir}/kconf_update/fonts_akregator.pl
93 %{_datadir}/kconf_update/fonts_akregator.upd
94 %{_datadir}/kconf_update/fonts_global.pl
95 %{_datadir}/kconf_update/fonts_global.upd
96 %{_datadir}/kconf_update/fonts_global_toolbar.upd
97 %{_datadir}/kconf_update/fonts_kate.pl
98 %{_datadir}/kconf_update/fonts_kate.upd
99
100 %files devel
101 %defattr(644,root,root,755)
102 %{_includedir}/PlasmaKeyData
103 %{_pkgconfigdir}/plasma-key-data.pc
This page took 0.87086 seconds and 2 git commands to generate.