]> git.pld-linux.org Git - packages/kp5-plasma-disks.git/blob - kp5-plasma-disks.spec
- updated to 5.26.4
[packages/kp5-plasma-disks.git] / kp5-plasma-disks.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.26.4
5 %define         qtver           5.15.2
6 %define         kpname          plasma-disks
7 %define         kf5ver          5.39.0
8
9 Summary:        plasma-disks
10 Name:           kp5-%{kpname}
11 Version:        5.26.4
12 Release:        1
13 License:        LGPL v2.1+
14 Group:          X11/Libraries
15 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
16 # Source0-md5:  3f1e7dfe3bfb45bab458c3867d92cd9f
17 URL:            http://www.kde.org/
18 BuildRequires:  Qt5Core-devel >= 5.15.0
19 BuildRequires:  Qt5Gui-devel >= 5.15.0
20 BuildRequires:  cmake >= 2.8.12
21 BuildRequires:  gettext-devel
22 BuildRequires:  kf5-extra-cmake-modules >= 5.82
23 BuildRequires:  kf5-kauth-devel >= 5.82
24 BuildRequires:  kf5-kcoreaddons-devel >= 5.85.0
25 BuildRequires:  kf5-kdbusaddons-devel >= 5.82
26 BuildRequires:  kf5-kdeclarative-devel >= 5.82
27 BuildRequires:  kf5-ki18n-devel >= 5.82
28 BuildRequires:  kf5-kio-devel >= 5.82
29 BuildRequires:  kf5-knotifications-devel >= 5.82
30 BuildRequires:  kf5-kservice-devel >= 5.85.0
31 BuildRequires:  kf5-solid-devel >= 5.85.0
32 BuildRequires:  ninja
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.164
35 BuildRequires:  xz
36 Requires:       python3
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         qt5dir          %{_libdir}/qt5
40
41 %description
42 plasma-disks.
43
44 %prep
45 %setup -q -n %{kpname}-%{version}
46
47 %build
48 install -d build
49 cd build
50 %cmake -G Ninja \
51         %{!?with_tests:-DBUILD_TESTING=OFF} \
52         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
53         -DHTML_INSTALL_DIR=%{_kdedocdir} \
54         ../
55 %ninja_build
56
57 %if %{with tests}
58 ctest
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 %ninja_install -C build
64
65 %find_lang %{kpname} --all-name --with-kde
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files -f %{kpname}.lang
71 %defattr(644,root,root,755)
72 %{_libdir}/qt5/plugins/kf5/kded/smart.so
73 %attr(755,root,root) %{_prefix}/libexec/kauth/kded-smart-helper
74 %{_datadir}/dbus-1/system-services/org.kde.kded.smart.service
75 %{_datadir}/dbus-1/system.d/org.kde.kded.smart.conf
76 %{_datadir}/knotifications5/org.kde.kded.smart.notifyrc
77 %{_datadir}/kpackage/kcms/plasma_disks
78 %{_datadir}/metainfo/org.kde.plasma.disks.metainfo.xml
79 %{_datadir}/polkit-1/actions/org.kde.kded.smart.policy
80 %{_libdir}/qt5/plugins/plasma/kcms/kinfocenter/smart.so
This page took 0.109349 seconds and 3 git commands to generate.