]> git.pld-linux.org Git - packages/kp5-plank-player.git/blob - kp5-plank-player.spec
- updated to 5.27.2
[packages/kp5-plank-player.git] / kp5-plank-player.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.27.2
5 %define         qtver           5.15.2
6 %define         kpname          plank-player
7 Summary:        Multimedia Player for playing local files on Plasma Bigscreen
8 Name:           kp5-%{kpname}
9 Version:        5.27.2
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  4685c478ea6dc6579ccc50d9f2ef9ada
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Quick-devel
17 BuildRequires:  cmake >= 2.8.12
18 BuildRequires:  gettext
19 BuildRequires:  gstreamer-devel
20 BuildRequires:  kf5-extra-cmake-modules
21 BuildRequires:  kf5-ki18n-devel
22 BuildRequires:  kf5-kirigami2-devel
23 BuildRequires:  ninja
24 BuildRequires:  pipewire-devel
25 BuildRequires:  qt5-build >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.164
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Multimedia Player for playing local files on Plasma Bigscreen.
33
34 %prep
35 %setup -q -n %{kpname}-%{version}
36
37 %build
38 install -d build
39 cd build
40 %cmake -G Ninja \
41         %{!?with_tests:-DBUILD_TESTING=OFF} \
42         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
43         -DHTML_INSTALL_DIR=%{_kdedocdir} \
44         ..
45 %ninja_build
46
47 %if %{with tests}
48 ctest
49 %endif
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %ninja_install -C build
54
55 %find_lang %{kpname} --all-name --with-kde
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files -f %{kpname}.lang
61 %defattr(644,root,root,755)
62 %doc README.md
63 %attr(755,root,root) %{_bindir}/plank-player
64 %{_desktopdir}/org.plank.player.desktop
65 %{_iconsdir}/hicolor/128x128/apps/plank-player.png
66 %{_iconsdir}/hicolor/256x256/apps/plank-player.png
67 %{_datadir}/metainfo/org.kde.invent.plank_player.metainfo.xml
This page took 0.217179 seconds and 3 git commands to generate.