]> git.pld-linux.org Git - packages/kp5-milou.git/blob - kp5-milou.spec
7803b2a7221861ece2544633b7f8188a76b20334
[packages/kp5-milou.git] / kp5-milou.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.25.3
5 %define         qtver           5.15.2
6 %define         kpname          milou
7 Summary:        A dedicated search application built on top of Baloo
8 Name:           kp5-%{kpname}
9 Version:        5.25.3
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  eda384bc6749e8319c330d48d6b50061
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  cmake >= 2.8.12
18 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
19 BuildRequires:  kf5-kdeclarative-devel
20 BuildRequires:  kf5-ki18n-devel
21 BuildRequires:  kf5-krunner-devel
22 BuildRequires:  kf5-kservice-devel
23 BuildRequires:  kf5-plasma-framework-devel
24 BuildRequires:  ninja
25 BuildRequires:  qt5-build >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.164
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 A dedicated search application built on top of Baloo.
33
34 %prep
35 %setup -q -n %{kpname}-%{version}
36
37 %build
38 install -d build
39 cd build
40 %cmake -G Ninja \
41         %{!?with_tests:-DBUILD_TESTING=OFF} \
42         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
43         -DHTML_INSTALL_DIR=%{_kdedocdir} \
44         ..
45 %ninja_build
46
47 %if %{with tests}
48 ctest
49 %endif
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %ninja_install -C build
54
55 %find_lang %{kpname} --all-name --with-kde
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post   -p /sbin/ldconfig
61 %postun -p /sbin/ldconfig
62
63 %files -f %{kpname}.lang
64 %defattr(644,root,root,755)
65 %ghost %{_libdir}/libmilou.so.5
66 %attr(755,root,root) %{_libdir}/libmilou.so.*.*.*
67 %{_libdir}/qt5/qml/org/kde/milou
68 %{_datadir}/plasma/plasmoids/org.kde.milou
69 %{_datadir}/metainfo/org.kde.milou.appdata.xml
70 %{_datadir}/kservices5/plasma-applet-org.kde.milou.desktop
This page took 0.062227 seconds and 2 git commands to generate.