]> git.pld-linux.org Git - packages/kp5-kwrited.git/blob - kp5-kwrited.spec
- updated to 5.24.4
[packages/kp5-kwrited.git] / kp5-kwrited.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.24.4
5 %define         qtver           5.9.0
6 %define         kpname          kwrited
7 Summary:        kwrited
8 Name:           kp5-%{kpname}
9 Version:        5.24.4
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          Base
13 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  e63d70c0c3f3ba9e20236bc1e8c9040a
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel
17 BuildRequires:  Qt5Gui-devel >= %{qtver}
18 BuildRequires:  Qt5Widgets-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  gettext-devel
21 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
22 BuildRequires:  kf5-kcoreaddons-devel
23 BuildRequires:  kf5-kdbusaddons-devel
24 BuildRequires:  kf5-ki18n-devel
25 BuildRequires:  kf5-knotifications-devel
26 BuildRequires:  kf5-kpty-devel
27 BuildRequires:  ninja
28 BuildRequires:  qt5-build >= %{qtver}
29 BuildRequires:  rpmbuild(macros) >= 1.164
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 KDE Plasma daemon listening for wall and write messages.
36
37 %prep
38 %setup -q -n %{kpname}-%{version}
39
40 %build
41 install -d build
42 cd build
43 %cmake -G Ninja \
44         %{!?with_tests:-DBUILD_TESTING=OFF} \
45         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
46         -DHTML_INSTALL_DIR=%{_kdedocdir} \
47         ..
48 %ninja_build
49
50 %if %{with tests}
51 ctest
52 %endif
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 %ninja_install -C build
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %{_libdir}/qt5/plugins/kf5/kded/kwrited.so
64 %{_datadir}/knotifications5/kwrited.notifyrc
This page took 0.041715 seconds and 3 git commands to generate.