]> git.pld-linux.org Git - packages/kp5-kwayland-server.git/blob - kp5-kwayland-server.spec
- updated to 5.22.4
[packages/kp5-kwayland-server.git] / kp5-kwayland-server.spec
1 # TODO:
2 # wayland-scanner from wayland project
3 #
4 %define         kdeplasmaver    5.22.4
5 %define         qtver           5.9.0
6 %define         kpname          kwayland-server
7
8 Summary:        Qt-style Client and Server library wrapper for the Wayland libraries
9 Name:           kp5-%{kpname}
10 Version:        5.22.4
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  365f7cd632d41447561ec1bdf7497bba
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-kwindowsystem-devel >= 5.82.0
20 BuildRequires:  kf5-plasma-wayland-protocols-devel >= 1.3.0
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  wayland-devel
23 BuildRequires:  xz
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         qt5dir          %{_libdir}/qt5
27
28 %description
29 Qt-style Client and Server library wrapper for the Wayland libraries.
30
31 %package devel
32 Summary:        Header files for %{kpname} development
33 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
34 Group:          X11/Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for %{kpname} development.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe dla programistów używających %{kpname}.
42
43 %prep
44 %setup -q -n %{kpname}-%{version}
45
46 %build
47 install -d build
48 cd build
49 %cmake \
50         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
51         ../
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} -C build/ install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post -p /sbin/ldconfig
64 %postun -p /sbin/ldconfig
65
66 %files
67 %defattr(644,root,root,755)
68 %{_datadir}/qlogging-categories5/kwaylandserver.categories
69 %ghost %{_libdir}/libKWaylandServer.so.5
70 %attr(755,root,root) %{_libdir}/libKWaylandServer.so.*.*.*
71
72 %files devel
73 %defattr(644,root,root,755)
74 %{_includedir}/kwaylandserver_version.h
75 %dir %{_includedir}/KWaylandServer
76 %{_includedir}/KWaylandServer/*.h
77 %dir %{_libdir}/cmake/KWaylandServer
78 %{_libdir}/cmake/KWaylandServer/KWaylandServerConfig.cmake
79 %{_libdir}/cmake/KWaylandServer/KWaylandServerConfigVersion.cmake
80 %{_libdir}/cmake/KWaylandServer/KWaylandServerTargets-pld.cmake
81 %{_libdir}/cmake/KWaylandServer/KWaylandServerTargets.cmake
82 %{_libdir}/libKWaylandServer.so
This page took 0.118707 seconds and 3 git commands to generate.