]> git.pld-linux.org Git - packages/kp5-kwayland-server.git/blob - kp5-kwayland-server.spec
rebuild with qt5-5.15.6
[packages/kp5-kwayland-server.git] / kp5-kwayland-server.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 # TODO:
5 # wayland-scanner from wayland project
6 #
7 %define         kdeplasmaver    5.24.5
8 %define         qtver           5.15.2
9 %define         kpname          kwayland-server
10
11 Summary:        Qt-style Client and Server library wrapper for the Wayland libraries
12 Name:           kp5-%{kpname}
13 Version:        5.24.5
14 Release:        2
15 License:        LGPL v2.1+
16 Group:          X11/Libraries
17 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
18 # Source0-md5:  598ae49b82277a94c5b35ac2b22f2cee
19 URL:            http://www.kde.org/
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5WaylandClient-devel >= %{qtver}
22 BuildRequires:  cmake >= 2.8.12
23 BuildRequires:  kf5-kwindowsystem-devel >= 5.82.0
24 BuildRequires:  kf5-plasma-wayland-protocols-devel >= 1.6.0
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  wayland-devel
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         qt5dir          %{_libdir}/qt5
31
32 %description
33 Qt-style Client and Server library wrapper for the Wayland libraries.
34
35 %package devel
36 Summary:        Header files for %{kpname} development
37 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
38 Group:          X11/Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for %{kpname} development.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe dla programistów używających %{kpname}.
46
47 %prep
48 %setup -q -n %{kpname}-%{version}
49
50 %build
51 install -d build
52 cd build
53 %cmake \
54         %{!?with_tests:-DBUILD_TESTING=OFF} \
55         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
56         ../
57 %{__make}
58
59 %if %{with tests}
60 ctest
61 %endif
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} -C build/ install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files
76 %defattr(644,root,root,755)
77 %{_datadir}/qlogging-categories5/kwaylandserver.categories
78 %ghost %{_libdir}/libKWaylandServer.so.5
79 %attr(755,root,root) %{_libdir}/libKWaylandServer.so.*.*.*
80
81 %files devel
82 %defattr(644,root,root,755)
83 %{_includedir}/kwaylandserver_version.h
84 %dir %{_includedir}/KWaylandServer
85 %{_includedir}/KWaylandServer/*.h
86 %dir %{_libdir}/cmake/KWaylandServer
87 %{_libdir}/cmake/KWaylandServer/KWaylandServerConfig.cmake
88 %{_libdir}/cmake/KWaylandServer/KWaylandServerConfigVersion.cmake
89 %{_libdir}/cmake/KWaylandServer/KWaylandServerTargets-pld.cmake
90 %{_libdir}/cmake/KWaylandServer/KWaylandServerTargets.cmake
91 %{_libdir}/libKWaylandServer.so
This page took 0.096187 seconds and 3 git commands to generate.