]> git.pld-linux.org Git - packages/kp5-kwayland-server.git/blob - kp5-kwayland-server.spec
- BR: Qt5WaylandClient-devel
[packages/kp5-kwayland-server.git] / kp5-kwayland-server.spec
1 # TODO:
2 # wayland-scanner from wayland project
3 #
4 %define         kdeplasmaver    5.23.3
5 %define         qtver           5.15.2
6 %define         kpname          kwayland-server
7
8 Summary:        Qt-style Client and Server library wrapper for the Wayland libraries
9 Name:           kp5-%{kpname}
10 Version:        5.23.3
11 Release:        2
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  645b6bf98b8bd130fe1d6ba77986a200
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5WaylandClient-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-kwindowsystem-devel >= 5.82.0
21 BuildRequires:  kf5-plasma-wayland-protocols-devel >= 1.3.0
22 BuildRequires:  rpmbuild(macros) >= 1.164
23 BuildRequires:  wayland-devel
24 BuildRequires:  xz
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         qt5dir          %{_libdir}/qt5
28
29 %description
30 Qt-style Client and Server library wrapper for the Wayland libraries.
31
32 %package devel
33 Summary:        Header files for %{kpname} development
34 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
35 Group:          X11/Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Header files for %{kpname} development.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe dla programistów używających %{kpname}.
43
44 %prep
45 %setup -q -n %{kpname}-%{version}
46
47 %build
48 install -d build
49 cd build
50 %cmake \
51         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
52         ../
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} -C build/ install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post -p /sbin/ldconfig
65 %postun -p /sbin/ldconfig
66
67 %files
68 %defattr(644,root,root,755)
69 %{_datadir}/qlogging-categories5/kwaylandserver.categories
70 %ghost %{_libdir}/libKWaylandServer.so.5
71 %attr(755,root,root) %{_libdir}/libKWaylandServer.so.*.*.*
72
73 %files devel
74 %defattr(644,root,root,755)
75 %{_includedir}/kwaylandserver_version.h
76 %dir %{_includedir}/KWaylandServer
77 %{_includedir}/KWaylandServer/*.h
78 %dir %{_libdir}/cmake/KWaylandServer
79 %{_libdir}/cmake/KWaylandServer/KWaylandServerConfig.cmake
80 %{_libdir}/cmake/KWaylandServer/KWaylandServerConfigVersion.cmake
81 %{_libdir}/cmake/KWaylandServer/KWaylandServerTargets-pld.cmake
82 %{_libdir}/cmake/KWaylandServer/KWaylandServerTargets.cmake
83 %{_libdir}/libKWaylandServer.so
This page took 0.084634 seconds and 3 git commands to generate.