]> git.pld-linux.org Git - packages/kp5-kwayland-server.git/blob - kp5-kwayland-server.spec
31458a67140f8cc972f9b8e61934a387c511be5c
[packages/kp5-kwayland-server.git] / kp5-kwayland-server.spec
1 # TODO:
2 # wayland-scanner from wayland project
3 #
4 %define         kdeplasmaver    5.21.4
5 %define         qtver           5.9.0
6 %define         kpname          kwayland-server
7
8 Summary:        Qt-style Client and Server library wrapper for the Wayland libraries
9 Name:           kp5-%{kpname}
10 Version:        5.21.4
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  75fee34b93f18a0f36a06771167959d7
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  rpmbuild(macros) >= 1.164
20 BuildRequires:  wayland-devel
21 BuildRequires:  xz
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         qt5dir          %{_libdir}/qt5
25
26 %description
27 Qt-style Client and Server library wrapper for the Wayland libraries.
28
29 %package devel
30 Summary:        Header files for %{kpname} development
31 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
32 Group:          X11/Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Header files for %{kpname} development.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe dla programistów używających %{kpname}.
40
41 %prep
42 %setup -q -n %{kpname}-%{version}
43
44 %build
45 install -d build
46 cd build
47 %cmake \
48         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
49         ../
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} -C build/ install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post -p /sbin/ldconfig
62 %postun -p /sbin/ldconfig
63
64 %files
65 %defattr(644,root,root,755)
66 %{_datadir}/qlogging-categories5/kwaylandserver.categories
67 %ghost %{_libdir}/libKWaylandServer.so.5
68 %attr(755,root,root) %{_libdir}/libKWaylandServer.so.*.*.*
69
70 %files devel
71 %defattr(644,root,root,755)
72 %{_includedir}/kwaylandserver_version.h
73 %dir %{_includedir}/KWaylandServer
74 %{_includedir}/KWaylandServer/*.h
75 %dir %{_libdir}/cmake/KWaylandServer
76 %{_libdir}/cmake/KWaylandServer/KWaylandServerConfig.cmake
77 %{_libdir}/cmake/KWaylandServer/KWaylandServerConfigVersion.cmake
78 %{_libdir}/cmake/KWaylandServer/KWaylandServerTargets-pld.cmake
79 %{_libdir}/cmake/KWaylandServer/KWaylandServerTargets.cmake
80 %{_libdir}/libKWaylandServer.so
This page took 0.074704 seconds and 2 git commands to generate.