]> git.pld-linux.org Git - packages/kp5-kwallet-pam.git/blob - kp5-kwallet-pam.spec
- updated to 5.24.5
[packages/kp5-kwallet-pam.git] / kp5-kwallet-pam.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.24.5
5 %define         qtver           5.9.0
6 %define         kpname          kwallet-pam
7 Summary:        KWallet PAM integration
8 Name:           kp5-%{kpname}
9 Version:        5.24.5
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          Base
13 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  0ee9d2bcc73d974fb06d0ac4a0e96e11
15 URL:            http://www.kde.org/
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
18 BuildRequires:  pam-devel
19 BuildRequires:  qt5-build >= %{qtver}
20 BuildRequires:  rpmbuild(macros) >= 1.164
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 KWallet PAM integration.
27
28 %prep
29 %setup -q -n %{kpname}-%{version}
30
31 %build
32 install -d build
33 cd build
34 %cmake -G Ninja \
35         %{!?with_tests:-DBUILD_TESTING=OFF} \
36         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
37         -DCMAKE_INSTALL_LIBDIR:PATH=/%{_lib} \
38         -DHTML_INSTALL_DIR=%{_kdedocdir} \
39         ..
40 %ninja_build
41
42 %if %{with tests}
43 ctest
44 %endif
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %ninja_install -C build
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %attr(755,root,root) /%{_lib}/security/pam_kwallet5.so
56 /etc/xdg/autostart/pam_kwallet_init.desktop
57 %attr(755,root,root) %{_libexecdir}/pam_kwallet_init
58 %{systemduserunitdir}/plasma-kwallet-pam.service
This page took 0.186238 seconds and 3 git commands to generate.