]> git.pld-linux.org Git - packages/kp5-ksystemstats.git/blob - kp5-ksystemstats.spec
9c9ad078c5b8110538a6838ec283447b2f3b7511
[packages/kp5-ksystemstats.git] / kp5-ksystemstats.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.27.1
5 %define         qtver           5.15.2
6 %define         kpname          ksystemstats
7 Summary:        ksystemstats
8 Name:           kp5-%{kpname}
9 Version:        5.27.1
10 Release:        1
11 License:        BSD Clause 2
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  1e4c38406a16b49c1969cded135b256f
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= 5.15.0
17 BuildRequires:  cmake >= 2.8.12
18 BuildRequires:  gettext-devel
19 BuildRequires:  kf5-extra-cmake-modules >= 5.82
20 BuildRequires:  kf5-kcoreaddons-devel >= 5.85.0
21 BuildRequires:  kf5-kdbusaddons-devel >= 5.82
22 BuildRequires:  kf5-kio-devel >= 5.82
23 BuildRequires:  kf5-networkmanager-qt-devel >= 5.82
24 BuildRequires:  kf5-solid-devel >= 5.85.0
25 BuildRequires:  kp5-libksysguard-devel
26 BuildRequires:  libnl-devel
27 BuildRequires:  udev-devel
28
29 BuildRequires:  ninja
30 BuildRequires:  pkgconfig
31 BuildRequires:  qt5-build >= %{qtver}
32 BuildRequires:  qt5-qmake
33 BuildRequires:  rpmbuild(macros) >= 1.596
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xz
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 KSystemStats is a daemon that collects statistics about the running
40 system.
41
42 %prep
43 %setup -q -n %{kpname}-%{version}
44
45 %build
46 install -d build
47 cd build
48 %cmake -G Ninja \
49         %{!?with_tests:-DBUILD_TESTING=OFF} \
50         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
51         -DHTML_INSTALL_DIR=%{_kdedocdir} \
52         ..
53 %ninja_build
54
55 %if %{with tests}
56 ctest
57 %endif
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{_iconsdir}/{breeze-dark,breeze}
62 %ninja_install -C build
63
64 %find_lang %{kpname} --all-name --with-kde
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files -f %{kpname}.lang
70 %defattr(644,root,root,755)
71 %attr(755,root,root) %{_bindir}/kstatsviewer
72 %attr(755,root,root) %{_bindir}/ksystemstats
73 %{systemduserunitdir}/plasma-ksystemstats.service
74 %{_libdir}/qt5/plugins/ksystemstats
75 %{_datadir}/dbus-1/services/org.kde.ksystemstats.service
This page took 0.052869 seconds and 2 git commands to generate.