]> git.pld-linux.org Git - packages/kp5-khotkeys.git/blob - kp5-khotkeys.spec
e7d2e209e3f3124cda0b0ee632b3298efa9ad109
[packages/kp5-khotkeys.git] / kp5-khotkeys.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.27.8
5 %define         qtver           5.15.2
6 %define         kpname          khotkeys
7
8 Summary:        Hot keys handling
9 Name:           kp5-%{kpname}
10 Version:        5.27.8
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  048e81bdcceaf0f6e57c74bd1046b9d7
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  kf5-kdelibs4support-devel
19 BuildRequires:  cmake >= 3.16.0
20 BuildRequires:  kf5-kcmutils-devel
21 BuildRequires:  kf5-kdbusaddons-devel
22 BuildRequires:  kf5-kdelibs4support-devel
23 BuildRequires:  kf5-kglobalaccel-devel
24 BuildRequires:  kf5-ki18n-devel
25 BuildRequires:  kf5-kio-devel
26 BuildRequires:  kf5-kxmlgui-devel
27 BuildRequires:  kf5-plasma-framework-devel
28 BuildRequires:  kp5-plasma-workspace-devel
29 BuildRequires:  ninja
30 BuildRequires:  rpmbuild(macros) >= 1.164
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 Hot keys handling.
38
39 %package devel
40 Summary:        Header files for %{kpname} development
41 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
42 Group:          X11/Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for %{kpname} development.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe dla programistów używających %{kpname}.
50
51 %prep
52 %setup -q -n %{kpname}-%{version}
53
54 %build
55 %cmake -B build \
56         -G Ninja \
57         %{!?with_tests:-DBUILD_TESTING=OFF} \
58         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
59         -DHTML_INSTALL_DIR=%{_kdedocdir}
60 %ninja_build -C build
61
62 %if %{with tests}
63 ctest
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %ninja_install -C build
69
70 %find_lang %{kpname} --all-name --with-kde
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files -f %{kpname}.lang
79 %defattr(644,root,root,755)
80 %ghost %{_libdir}/libkhotkeysprivate.so.5
81 %attr(755,root,root) %{_libdir}/libkhotkeysprivate.so.*.*.*
82 %attr(755,root,root) %{_libdir}/qt5/plugins/kcm_hotkeys.so
83 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/khotkeys.so
84 %{_datadir}/dbus-1/interfaces/org.kde.khotkeys.xml
85 %{_datadir}/khotkeys
86 %{_datadir}/kservices5/khotkeys.desktop
87
88 %files devel
89 %defattr(644,root,root,755)
90 %{_libdir}/cmake/KHotKeysDBusInterface
This page took 0.055166 seconds and 2 git commands to generate.