]> git.pld-linux.org Git - packages/kp5-khotkeys.git/blob - kp5-khotkeys.spec
- updated to 5.25.4
[packages/kp5-khotkeys.git] / kp5-khotkeys.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.25.4
5 %define         qtver           5.15.2
6 %define         kpname          khotkeys
7
8 Summary:        Hot keys handling
9 Name:           kp5-%{kpname}
10 Version:        5.25.4
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  943b40a2a7e3738618ddb070233fe6f4
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  kf5-kdelibs4support-devel
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-kcmutils-devel
21 BuildRequires:  kf5-kdbusaddons-devel
22 BuildRequires:  kf5-kdelibs4support-devel
23 BuildRequires:  kf5-kglobalaccel-devel
24 BuildRequires:  kf5-ki18n-devel
25 BuildRequires:  kf5-kio-devel
26 BuildRequires:  kf5-kxmlgui-devel
27 BuildRequires:  kf5-plasma-framework-devel
28 BuildRequires:  kp5-plasma-workspace-devel
29 BuildRequires:  ninja
30 BuildRequires:  rpmbuild(macros) >= 1.164
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 Hot keys handling.
38
39 %package devel
40 Summary:        Header files for %{kpname} development
41 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
42 Group:          X11/Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for %{kpname} development.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe dla programistów używających %{kpname}.
50
51 %prep
52 %setup -q -n %{kpname}-%{version}
53
54 %build
55 install -d build
56 cd build
57 %cmake -G Ninja \
58         %{!?with_tests:-DBUILD_TESTING=OFF} \
59         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
60         -DHTML_INSTALL_DIR=%{_kdedocdir} \
61         ../
62 %ninja_build
63
64 %if %{with tests}
65 ctest
66 %endif
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 %ninja_install -C build
71
72 %find_lang %{kpname} --all-name --with-kde
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files -f %{kpname}.lang
81 %defattr(644,root,root,755)
82 %ghost %{_libdir}/libkhotkeysprivate.so.5
83 %attr(755,root,root) %{_libdir}/libkhotkeysprivate.so.*.*.*
84 %attr(755,root,root) %{_libdir}/qt5/plugins/kcm_hotkeys.so
85 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/khotkeys.so
86 %{_datadir}/dbus-1/interfaces/org.kde.khotkeys.xml
87 %{_datadir}/khotkeys
88 %{_datadir}/kservices5/khotkeys.desktop
89
90 %files devel
91 %defattr(644,root,root,755)
92 %{_libdir}/cmake/KHotKeysDBusInterface
This page took 0.058107 seconds and 3 git commands to generate.