]> git.pld-linux.org Git - packages/kp5-kgamma5.git/blob - kp5-kgamma5.spec
05d16fa373244513ef13848f8181bcce31915853
[packages/kp5-kgamma5.git] / kp5-kgamma5.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.25.5
5 %define         qtver           5.15.2
6 %define         kpname          kgamma5
7 Summary:        kgamma5
8 Name:           kp5-%{kpname}
9 Version:        5.25.5
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  0c2b7afef01994a52810e435ab3bc159
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel >= %{qtver}
18 BuildRequires:  Qt5Widgets-devel >= %{qtver}
19 BuildRequires:  Qt5X11Extras-devel >= %{qtver}
20 BuildRequires:  cmake >= 2.8.12
21 BuildRequires:  gettext-devel
22 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
23 BuildRequires:  kf5-kdelibs4support-devel
24 BuildRequires:  kf5-kdoctools-devel
25 BuildRequires:  ninja
26 BuildRequires:  qt5-build >= %{qtver}
27 BuildRequires:  rpmbuild(macros) >= 1.164
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xorg-lib-libX11-devel
30 BuildRequires:  xorg-lib-libXxf86vm-devel
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This module is a tool for monitor gamma correction. With proper gamma
36 settings, your display (websites, images, etc.) will look the same on
37 your monitor as on other monitors. It allows you to alter the
38 monitor's gamma correction of the X-Server. But that's not all to do.
39
40 %prep
41 %setup -q -n %{kpname}-%{version}
42
43 %build
44 install -d build
45 cd build
46 %cmake -G Ninja \
47         %{!?with_tests:-DBUILD_TESTING=OFF} \
48         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
49         -DHTML_INSTALL_DIR=%{_kdedocdir} \
50         ..
51 %ninja_build
52
53 %if %{with tests}
54 ctest
55 %endif
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %ninja_install -C build
60
61 %find_lang %{kpname} --all-name --with-kde
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files -f %{kpname}.lang
67 %defattr(644,root,root,755)
68 %{_libdir}/qt5/plugins/plasma/kcminit/kcm_kgamma_init.so
69 %{_libdir}/qt5/plugins/plasma/kcms/systemsettings/kcm_kgamma.so
70 %{_datadir}/kgamma
This page took 0.060061 seconds and 2 git commands to generate.