]> git.pld-linux.org Git - packages/kp5-breeze-plymouth.git/blob - kp5-breeze-plymouth.spec
- updated to 5.24.4
[packages/kp5-breeze-plymouth.git] / kp5-breeze-plymouth.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.24.4
5 %define         qtver           5.9.0
6 %define         kpname          breeze-plymouth
7
8 Summary:        breeze-plymouth
9 Name:           kp5-%{kpname}
10 Version:        5.24.4
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  b652fa6a3d3245e2cc12bb646bd325b4
16 URL:            http://www.kde.org/
17 BuildRequires:  cmake >= 2.8.12
18 BuildRequires:  kf5-extra-cmake-modules >= 1.8.0
19 BuildRequires:  ninja
20 BuildRequires:  plymouth-devel
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  xz
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         qt5dir          %{_libdir}/qt5
26
27 %description
28 breeze-plymouth.
29
30 %prep
31 %setup -q -n %{kpname}-%{version}
32
33 %build
34 install -d build
35 cd build
36 %cmake -G Ninja \
37         %{!?with_tests:-DBUILD_TESTING=OFF} \
38         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
39         -DHTML_INSTALL_DIR=%{_kdedocdir} \
40         ../
41 %ninja_build
42
43 %if %{with tests}
44 ctest
45 %endif
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 %ninja_install -C build
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %{_libdir}/plymouth/breeze-text.so
57 %{_datadir}/plymouth/themes/breeze-text
58 %{_datadir}/plymouth/themes/breeze
This page took 0.043635 seconds and 3 git commands to generate.