]> git.pld-linux.org Git - packages/kp5-breeze-gtk.git/blob - kp5-breeze-gtk.spec
072f7a8efdb264b900ddff82795f5032c7cb2d7a
[packages/kp5-breeze-gtk.git] / kp5-breeze-gtk.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.25.3
5 %define         qtver           5.15.2
6 %define         kpname          breeze-gtk
7 Summary:        Artwork, styles and assets for the Breeze visual style for the Plasma Desktop
8 Name:           kp5-%{kpname}
9 Version:        5.25.3
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  80258358f1f8ce90605ba73ebb46005b
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5DBus-devel
18 BuildRequires:  Qt5Gui-devel
19 BuildRequires:  Qt5Widgets-devel
20 BuildRequires:  Qt5X11Extras-devel
21 BuildRequires:  Qt5Xml-devel
22 BuildRequires:  cmake >= 2.8.12
23 BuildRequires:  gettext-devel
24 BuildRequires:  hardlink >= 1.0-3
25 BuildRequires:  kf5-attica-devel
26 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
27 BuildRequires:  kf5-frameworkintegration-devel
28 BuildRequires:  kf5-kauth-devel
29 BuildRequires:  kf5-kcmutils-devel
30 BuildRequires:  kf5-kcodecs-devel
31 BuildRequires:  kf5-kconfig-devel
32 BuildRequires:  kf5-kconfigwidgets-devel
33 BuildRequires:  kf5-kcoreaddons-devel
34 BuildRequires:  kf5-kguiaddons-devel
35 BuildRequires:  kf5-ki18n-devel
36 BuildRequires:  kf5-kiconthemes-devel
37 BuildRequires:  kf5-kservice-devel
38 BuildRequires:  kf5-kwidgetsaddons-devel
39 BuildRequires:  kf5-kwindowsystem-devel
40 BuildRequires:  kp5-breeze-devel
41 BuildRequires:  kp5-kdecoration-devel >= %{kdeplasmaver}
42 BuildRequires:  libstdc++-devel
43 BuildRequires:  ninja
44 BuildRequires:  pkgconfig
45 BuildRequires:  python3-pycairo-devel
46 BuildRequires:  qt5-build >= %{qtver}
47 BuildRequires:  qt5-qmake
48 BuildRequires:  rpmbuild(macros) >= 1.596
49 BuildRequires:  sassc
50 BuildRequires:  tar >= 1:1.22
51 BuildRequires:  xz
52 Requires:       gtk-update-icon-cache
53 Requires:       hicolor-icon-theme
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %define         _debugsource_packages   0
57
58 %description
59 Artwork, styles and assets for the Breeze visual style for the Plasma
60 Desktop.
61
62 %package -n %{kpname}-icon-theme
63 Summary:        Breeze icon theme
64 Summary(pl.UTF-8):      Breeze Motyw ikon
65 Group:          Themes
66 Requires:       gtk-update-icon-cache
67 Requires:       hicolor-icon-theme
68 Conflicts:      kp5-breeze < 5.4.0-5
69 BuildArch:      noarch
70
71 %description -n %{kpname}-icon-theme
72 Breeze is an icon theme.
73
74 %description -n %{kpname}-icon-theme -l pl.UTF-8
75 Breeze to motyw ikon.
76
77 %package -n %{kpname}-cursor-theme
78 Summary:        Breeze cursor theme
79 Group:          Themes
80 Conflicts:      breeze-icon-theme < 5.4.0-7
81 Conflicts:      kp5-breeze < 5.4.0-5
82 BuildArch:      noarch
83
84 %description -n %{kpname}-cursor-theme
85 Breeze cursor theme.
86
87 %prep
88 %setup -q -n %{kpname}-%{version}
89
90 %build
91 install -d build
92 cd build
93 %cmake -G Ninja \
94         %{!?with_tests:-DBUILD_TESTING=OFF} \
95         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
96         ..
97 %ninja_build
98
99 %if %{with tests}
100 ctest
101 %endif
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 %ninja_install -C build
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post
111 %update_icon_cache hicolor
112
113 %postun
114 %update_icon_cache hicolor
115
116 %files
117 %defattr(644,root,root,755)
118 %{_datadir}/themes/Breeze-Dark
119 %{_datadir}/themes/Breeze
This page took 0.104998 seconds and 2 git commands to generate.