]> git.pld-linux.org Git - packages/kp5-bluedevil.git/blob - kp5-bluedevil.spec
- updated to 5.24.2
[packages/kp5-bluedevil.git] / kp5-bluedevil.spec
1 %define         kdeplasmaver    5.24.2
2 %define         qtver           5.9.0
3 %define         kpname          bluedevil
4 Summary:        Integrate the Bluetooth technology within KDE workspace and applications
5 Name:           kp5-%{kpname}
6 Version:        5.24.2
7 Release:        1
8 License:        GPL v2+/LGPL v2.1+
9 Group:          X11/Libraries
10 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
11 # Source0-md5:  cb6f392c3b0c3c9bfb4c223c7bb0ad1c
12 URL:            http://www.kde.org/
13 BuildRequires:  Qt5Core-devel >= %{qtver}
14 BuildRequires:  Qt5Quick-devel >= %{qtver}
15 BuildRequires:  Qt5Widgets-devel >= %{qtver}
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  kf5-bluez-qt-devel
18 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
19 BuildRequires:  kf5-kconfigwidgets-devel
20 BuildRequires:  kf5-kdbusaddons-devel
21 BuildRequires:  kf5-kdeclarative-devel
22 BuildRequires:  kf5-kded-devel
23 BuildRequires:  kf5-kio-devel
24 BuildRequires:  kf5-kirigami2-devel
25 BuildRequires:  kf5-knotifications-devel
26 BuildRequires:  kf5-kwidgetsaddons-devel
27 BuildRequires:  kf5-kwindowsystem-devel
28 BuildRequires:  kf5-plasma-framework-devel
29 BuildRequires:  ninja
30 BuildRequires:  qt5-build >= %{qtver}
31 BuildRequires:  rpmbuild(macros) >= 1.164
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Integrate the Bluetooth technology within KDE workspace and
38 applications.
39
40 %prep
41 %setup -q -n %{kpname}-%{version}
42
43 %build
44 install -d build
45 cd build
46 %cmake -G Ninja \
47         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
48         -DHTML_INSTALL_DIR=%{_kdedocdir} \
49         ..
50 %ninja_build
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 %ninja_install -C build
55
56 %find_lang bluedevil --all-name --with-kde
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post   -p /sbin/ldconfig
62 %postun -p /sbin/ldconfig
63
64 %files -f bluedevil.lang
65 %defattr(644,root,root,755)
66 %attr(755,root,root) %{_bindir}/bluedevil-sendfile
67 %attr(755,root,root) %{_bindir}/bluedevil-wizard
68 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/bluedevil.so
69 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_bluetooth.so
70 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_obexftp.so
71 %dir %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth
72 %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/qmldir
73 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/libbluetoothplugin.so
74 %{_desktopdir}/org.kde.bluedevilsendfile.desktop
75 %{_desktopdir}/org.kde.bluedevilwizard.desktop
76 %dir %{_datadir}/bluedevilwizard
77 %{_datadir}/bluedevilwizard/pin-code-database.xml
78 %{_datadir}/knotifications5/bluedevil.notifyrc
79 %{_datadir}/mime/packages/bluedevil-mime.xml
80 %{_datadir}/plasma/plasmoids/org.kde.plasma.bluetooth
81 %{_datadir}/remoteview/bluetooth-network.desktop
82 %{_datadir}/metainfo/org.kde.plasma.bluetooth.appdata.xml
83 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth
84 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents
85 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui
86 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/Device.qml
87 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/General.qml
88 %{_datadir}/kservices5/plasma-applet-org.kde.plasma.bluetooth.desktop
89 %{_libdir}/qt5/plugins/plasma/kcms/systemsettings/kcm_bluetooth.so
90 %{_desktopdir}/kcm_bluetooth.desktop
91 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/main.qml
92 %{_datadir}/qlogging-categories5/bluedevil.categories
This page took 0.064091 seconds and 4 git commands to generate.