]> git.pld-linux.org Git - packages/kp5-bluedevil.git/blob - kp5-bluedevil.spec
- updated to 5.26.5
[packages/kp5-bluedevil.git] / kp5-bluedevil.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.26.5
5 %define         qtver           5.15.2
6 %define         kpname          bluedevil
7 Summary:        Integrate the Bluetooth technology within KDE workspace and applications
8 Name:           kp5-%{kpname}
9 Version:        5.26.5
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  3440d7a273988cddb711ddd864ae85d7
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Quick-devel >= %{qtver}
18 BuildRequires:  Qt5Widgets-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-bluez-qt-devel
21 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
22 BuildRequires:  kf5-kcmutils-devel
23 BuildRequires:  kf5-kconfigwidgets-devel
24 BuildRequires:  kf5-kdbusaddons-devel
25 BuildRequires:  kf5-kdeclarative-devel
26 BuildRequires:  kf5-kded-devel
27 BuildRequires:  kf5-ki18n-devel
28 BuildRequires:  kf5-kio-devel
29 BuildRequires:  kf5-kirigami2-devel
30 BuildRequires:  kf5-knotifications-devel
31 BuildRequires:  kf5-kwidgetsaddons-devel
32 BuildRequires:  kf5-kwindowsystem-devel
33 BuildRequires:  kf5-plasma-framework-devel
34 BuildRequires:  ninja
35 BuildRequires:  qt5-build >= %{qtver}
36 BuildRequires:  rpmbuild(macros) >= 1.164
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Integrate the Bluetooth technology within KDE workspace and
43 applications.
44
45 %prep
46 %setup -q -n %{kpname}-%{version}
47
48 %build
49 install -d build
50 cd build
51 %cmake -G Ninja \
52         %{!?with_tests:-DBUILD_TESTING=OFF} \
53         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
54         -DHTML_INSTALL_DIR=%{_kdedocdir} \
55         ..
56 %ninja_build
57
58 %if %{with tests}
59 ctest
60 %endif
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %ninja_install -C build
65
66 %find_lang bluedevil --all-name --with-kde
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post   -p /sbin/ldconfig
72 %postun -p /sbin/ldconfig
73
74 %files -f bluedevil.lang
75 %defattr(644,root,root,755)
76 %attr(755,root,root) %{_bindir}/bluedevil-sendfile
77 %attr(755,root,root) %{_bindir}/bluedevil-wizard
78 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/bluedevil.so
79 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_bluetooth.so
80 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_obexftp.so
81 %dir %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth
82 %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/qmldir
83 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/libbluetoothplugin.so
84 %{_desktopdir}/org.kde.bluedevilsendfile.desktop
85 %{_desktopdir}/org.kde.bluedevilwizard.desktop
86 %dir %{_datadir}/bluedevilwizard
87 %{_datadir}/bluedevilwizard/pin-code-database.xml
88 %{_datadir}/knotifications5/bluedevil.notifyrc
89 %{_datadir}/mime/packages/bluedevil-mime.xml
90 %{_datadir}/plasma/plasmoids/org.kde.plasma.bluetooth
91 %{_datadir}/remoteview/bluetooth-network.desktop
92 %{_datadir}/metainfo/org.kde.plasma.bluetooth.appdata.xml
93 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth
94 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents
95 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui
96 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/Device.qml
97 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/General.qml
98 %{_datadir}/kservices5/plasma-applet-org.kde.plasma.bluetooth.desktop
99 %{_libdir}/qt5/plugins/plasma/kcms/systemsettings/kcm_bluetooth.so
100 %{_desktopdir}/kcm_bluetooth.desktop
101 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/main.qml
102 %{_datadir}/qlogging-categories5/bluedevil.categories
This page took 0.094286 seconds and 4 git commands to generate.