]> git.pld-linux.org Git - packages/kp5-bluedevil.git/blob - kp5-bluedevil.spec
- updated to 5.24.4
[packages/kp5-bluedevil.git] / kp5-bluedevil.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.24.4
5 %define         qtver           5.9.0
6 %define         kpname          bluedevil
7 Summary:        Integrate the Bluetooth technology within KDE workspace and applications
8 Name:           kp5-%{kpname}
9 Version:        5.24.4
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  5a1bddbf1466d9eff12e5c96788be18a
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Quick-devel >= %{qtver}
18 BuildRequires:  Qt5Widgets-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-bluez-qt-devel
21 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
22 BuildRequires:  kf5-kconfigwidgets-devel
23 BuildRequires:  kf5-kdbusaddons-devel
24 BuildRequires:  kf5-kdeclarative-devel
25 BuildRequires:  kf5-kded-devel
26 BuildRequires:  kf5-kio-devel
27 BuildRequires:  kf5-kirigami2-devel
28 BuildRequires:  kf5-knotifications-devel
29 BuildRequires:  kf5-kwidgetsaddons-devel
30 BuildRequires:  kf5-kwindowsystem-devel
31 BuildRequires:  kf5-plasma-framework-devel
32 BuildRequires:  ninja
33 BuildRequires:  qt5-build >= %{qtver}
34 BuildRequires:  rpmbuild(macros) >= 1.164
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Integrate the Bluetooth technology within KDE workspace and
41 applications.
42
43 %prep
44 %setup -q -n %{kpname}-%{version}
45
46 %build
47 install -d build
48 cd build
49 %cmake -G Ninja \
50         %{!?with_tests:-DBUILD_TESTING=OFF} \
51         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
52         -DHTML_INSTALL_DIR=%{_kdedocdir} \
53         ..
54 %ninja_build
55
56 %if %{with tests}
57 ctest
58 %endif
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %ninja_install -C build
63
64 %find_lang bluedevil --all-name --with-kde
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post   -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
71
72 %files -f bluedevil.lang
73 %defattr(644,root,root,755)
74 %attr(755,root,root) %{_bindir}/bluedevil-sendfile
75 %attr(755,root,root) %{_bindir}/bluedevil-wizard
76 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/bluedevil.so
77 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_bluetooth.so
78 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_obexftp.so
79 %dir %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth
80 %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/qmldir
81 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/libbluetoothplugin.so
82 %{_desktopdir}/org.kde.bluedevilsendfile.desktop
83 %{_desktopdir}/org.kde.bluedevilwizard.desktop
84 %dir %{_datadir}/bluedevilwizard
85 %{_datadir}/bluedevilwizard/pin-code-database.xml
86 %{_datadir}/knotifications5/bluedevil.notifyrc
87 %{_datadir}/mime/packages/bluedevil-mime.xml
88 %{_datadir}/plasma/plasmoids/org.kde.plasma.bluetooth
89 %{_datadir}/remoteview/bluetooth-network.desktop
90 %{_datadir}/metainfo/org.kde.plasma.bluetooth.appdata.xml
91 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth
92 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents
93 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui
94 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/Device.qml
95 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/General.qml
96 %{_datadir}/kservices5/plasma-applet-org.kde.plasma.bluetooth.desktop
97 %{_libdir}/qt5/plugins/plasma/kcms/systemsettings/kcm_bluetooth.so
98 %{_desktopdir}/kcm_bluetooth.desktop
99 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/main.qml
100 %{_datadir}/qlogging-categories5/bluedevil.categories
This page took 0.091039 seconds and 4 git commands to generate.