]> git.pld-linux.org Git - packages/kp5-bluedevil.git/blob - kp5-bluedevil.spec
dd2f9d79db050caf4b2e3217d1af136eb9f5a9b1
[packages/kp5-bluedevil.git] / kp5-bluedevil.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.26.0
5 %define         qtver           5.15.2
6 %define         kpname          bluedevil
7 Summary:        Integrate the Bluetooth technology within KDE workspace and applications
8 Name:           kp5-%{kpname}
9 Version:        5.26.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  e0f02b1a601ea8c20cb7eb8fcb1e20d3
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Quick-devel >= %{qtver}
18 BuildRequires:  Qt5Widgets-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-bluez-qt-devel
21 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
22 BuildRequires:  kf5-kconfigwidgets-devel
23 BuildRequires:  kf5-kdbusaddons-devel
24 BuildRequires:  kf5-kdeclarative-devel
25 BuildRequires:  kf5-kded-devel
26 BuildRequires:  kf5-ki18n-devel
27 BuildRequires:  kf5-kio-devel
28 BuildRequires:  kf5-kirigami2-devel
29 BuildRequires:  kf5-knotifications-devel
30 BuildRequires:  kf5-kwidgetsaddons-devel
31 BuildRequires:  kf5-kwindowsystem-devel
32 BuildRequires:  kf5-plasma-framework-devel
33 BuildRequires:  ninja
34 BuildRequires:  qt5-build >= %{qtver}
35 BuildRequires:  rpmbuild(macros) >= 1.164
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Integrate the Bluetooth technology within KDE workspace and
42 applications.
43
44 %prep
45 %setup -q -n %{kpname}-%{version}
46
47 %build
48 install -d build
49 cd build
50 %cmake -G Ninja \
51         %{!?with_tests:-DBUILD_TESTING=OFF} \
52         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
53         -DHTML_INSTALL_DIR=%{_kdedocdir} \
54         ..
55 %ninja_build
56
57 %if %{with tests}
58 ctest
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 %ninja_install -C build
64
65 %find_lang bluedevil --all-name --with-kde
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post   -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
72
73 %files -f bluedevil.lang
74 %defattr(644,root,root,755)
75 %attr(755,root,root) %{_bindir}/bluedevil-sendfile
76 %attr(755,root,root) %{_bindir}/bluedevil-wizard
77 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/bluedevil.so
78 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_bluetooth.so
79 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_obexftp.so
80 %dir %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth
81 %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/qmldir
82 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/libbluetoothplugin.so
83 %{_desktopdir}/org.kde.bluedevilsendfile.desktop
84 %{_desktopdir}/org.kde.bluedevilwizard.desktop
85 %dir %{_datadir}/bluedevilwizard
86 %{_datadir}/bluedevilwizard/pin-code-database.xml
87 %{_datadir}/knotifications5/bluedevil.notifyrc
88 %{_datadir}/mime/packages/bluedevil-mime.xml
89 %{_datadir}/plasma/plasmoids/org.kde.plasma.bluetooth
90 %{_datadir}/remoteview/bluetooth-network.desktop
91 %{_datadir}/metainfo/org.kde.plasma.bluetooth.appdata.xml
92 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth
93 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents
94 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui
95 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/Device.qml
96 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/General.qml
97 %{_datadir}/kservices5/plasma-applet-org.kde.plasma.bluetooth.desktop
98 %{_libdir}/qt5/plugins/plasma/kcms/systemsettings/kcm_bluetooth.so
99 %{_desktopdir}/kcm_bluetooth.desktop
100 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/main.qml
101 %{_datadir}/qlogging-categories5/bluedevil.categories
This page took 0.067476 seconds and 2 git commands to generate.