]> git.pld-linux.org Git - packages/kp5-bluedevil.git/blob - kp5-bluedevil.spec
- BRs
[packages/kp5-bluedevil.git] / kp5-bluedevil.spec
1 %define         kdeplasmaver    5.23.4
2 %define         qtver           5.9.0
3 %define         kpname          bluedevil
4 Summary:        Integrate the Bluetooth technology within KDE workspace and applications
5 Name:           kp5-%{kpname}
6 Version:        5.23.4
7 Release:        1
8 License:        GPL v2+/LGPL v2.1+
9 Group:          X11/Libraries
10 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
11 # Source0-md5:  129d38e7781b6b8de4228d5798a43cfb
12 URL:            http://www.kde.org/
13 BuildRequires:  Qt5Core-devel >= %{qtver}
14 BuildRequires:  Qt5Quick-devel >= %{qtver}
15 BuildRequires:  Qt5Widgets-devel >= %{qtver}
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  kf5-bluez-qt-devel
18 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
19 BuildRequires:  kf5-kdbusaddons-devel
20 BuildRequires:  kf5-kdeclarative-devel
21 BuildRequires:  kf5-kded-devel
22 BuildRequires:  kf5-kio-devel
23 BuildRequires:  kf5-knotifications-devel
24 BuildRequires:  kf5-kwidgetsaddons-devel
25 BuildRequires:  kf5-kwindowsystem-devel
26 BuildRequires:  kf5-plasma-framework-devel
27 BuildRequires:  ninja
28 BuildRequires:  qt5-build >= %{qtver}
29 BuildRequires:  rpmbuild(macros) >= 1.164
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Integrate the Bluetooth technology within KDE workspace and
36 applications.
37
38 %prep
39 %setup -q -n %{kpname}-%{version}
40
41 %build
42 install -d build
43 cd build
44 %cmake -G Ninja \
45         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
46         -DHTML_INSTALL_DIR=%{_kdedocdir} \
47         ..
48 %ninja_build
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 %ninja_install -C build
53
54 %find_lang bluedevil --all-name --with-kde
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post   -p /sbin/ldconfig
60 %postun -p /sbin/ldconfig
61
62 %files -f bluedevil.lang
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_bindir}/bluedevil-sendfile
65 %attr(755,root,root) %{_bindir}/bluedevil-wizard
66 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/bluedevil.so
67 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_bluetooth.so
68 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_obexftp.so
69 %dir %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth
70 %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/qmldir
71 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/libbluetoothplugin.so
72 %{_desktopdir}/org.kde.bluedevilsendfile.desktop
73 %{_desktopdir}/org.kde.bluedevilwizard.desktop
74 %dir %{_datadir}/bluedevilwizard
75 %{_datadir}/bluedevilwizard/pin-code-database.xml
76 %{_datadir}/knotifications5/bluedevil.notifyrc
77 %{_datadir}/mime/packages/bluedevil-mime.xml
78 %{_datadir}/plasma/plasmoids/org.kde.plasma.bluetooth
79 %{_datadir}/remoteview/bluetooth-network.desktop
80 %{_datadir}/metainfo/org.kde.plasma.bluetooth.appdata.xml
81 %{_libdir}/qt5/plugins/kcms/kcm_bluetooth.so
82 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth
83 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents
84 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui
85 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/Bluetooth.qml
86 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/Device.qml
87 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/General.qml
88 %{_datadir}/kpackage/kcms/kcm_bluetooth/metadata.desktop
89 %{_datadir}/kpackage/kcms/kcm_bluetooth/metadata.json
90 %{_datadir}/kservices5/bluetooth.desktop
This page took 0.074717 seconds and 3 git commands to generate.