]> git.pld-linux.org Git - packages/kp5-bluedevil.git/blob - kp5-bluedevil.spec
0870e2ed4ba668ec061ea4062e0c965540961022
[packages/kp5-bluedevil.git] / kp5-bluedevil.spec
1 %define         kdeplasmaver    5.22.3
2 %define         qtver           5.9.0
3 %define         kpname          bluedevil
4 Summary:        Integrate the Bluetooth technology within KDE workspace and applications
5 Name:           kp5-%{kpname}
6 Version:        5.22.3
7 Release:        1
8 License:        GPL v2+/LGPL v2.1+
9 Group:          X11/Libraries
10 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
11 # Source0-md5:  2470696d3b759f5868b7fd00c4a8edda
12 URL:            http://www.kde.org/
13 BuildRequires:  Qt5Core-devel >= %{qtver}
14 BuildRequires:  cmake >= 2.8.12
15 BuildRequires:  kf5-bluez-qt-devel
16 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
17 BuildRequires:  kf5-kded-devel
18 BuildRequires:  ninja
19 BuildRequires:  qt5-build >= %{qtver}
20 BuildRequires:  rpmbuild(macros) >= 1.164
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Integrate the Bluetooth technology within KDE workspace and
27 applications.
28
29 %prep
30 %setup -q -n %{kpname}-%{version}
31
32 %build
33 install -d build
34 cd build
35 %cmake -G Ninja \
36         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
37         -DHTML_INSTALL_DIR=%{_kdedocdir} \
38         ..
39 %ninja_build
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 %ninja_install -C build
44
45 %find_lang bluedevil --all-name --with-kde
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post   -p /sbin/ldconfig
51 %postun -p /sbin/ldconfig
52
53 %files -f bluedevil.lang
54 %defattr(644,root,root,755)
55 %attr(755,root,root) %{_bindir}/bluedevil-sendfile
56 %attr(755,root,root) %{_bindir}/bluedevil-wizard
57 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/bluedevil.so
58 %attr(755,root,root) %{_libdir}/qt5/plugins/kio_bluetooth.so
59 %attr(755,root,root) %{_libdir}/qt5/plugins/kio_obexftp.so
60 %dir %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth
61 %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/qmldir
62 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/libbluetoothplugin.so
63 %{_desktopdir}/org.kde.bluedevilsendfile.desktop
64 %{_desktopdir}/org.kde.bluedevilwizard.desktop
65 %dir %{_datadir}/bluedevilwizard
66 %{_datadir}/bluedevilwizard/pin-code-database.xml
67 %{_datadir}/knotifications5/bluedevil.notifyrc
68 %{_datadir}/kservices5/bluetooth.protocol
69 %{_datadir}/kservices5/obexftp.protocol
70 %{_datadir}/kservices5/plasma-applet-org.kde.plasma.bluetooth.desktop
71 %{_datadir}/mime/packages/bluedevil-mime.xml
72 %{_datadir}/plasma/plasmoids/org.kde.plasma.bluetooth
73 %{_datadir}/remoteview/bluetooth-network.desktop
74 %{_datadir}/metainfo/org.kde.plasma.bluetooth.appdata.xml
75 %{_libdir}/qt5/plugins/kcms/kcm_bluetooth.so
76 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth
77 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents
78 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui
79 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/Bluetooth.qml
80 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/Device.qml
81 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/General.qml
82 %{_datadir}/kpackage/kcms/kcm_bluetooth/metadata.desktop
83 %{_datadir}/kpackage/kcms/kcm_bluetooth/metadata.json
84 %{_datadir}/kservices5/bluetooth.desktop
This page took 0.089061 seconds and 2 git commands to generate.