]> git.pld-linux.org Git - packages/kp5-aura-browser.git/blob - kp5-aura-browser.spec
76144c1fd0a8096ebd3a30128e88e7bacadbf123
[packages/kp5-aura-browser.git] / kp5-aura-browser.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.26.3
5 %define         qtver           5.15.2
6 %define         kpname          aura-browser
7 Summary:        Browser for a fully immersed Big Screen experience
8 Name:           kp5-%{kpname}
9 Version:        5.26.3
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  a3732a8d1b2d4e3a01553f5bad2866fa
15 URL:            http://www.kde.org/
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  kf5-extra-cmake-modules
18 BuildRequires:  ninja
19 BuildRequires:  qt5-build >= %{qtver}
20 BuildRequires:  rpmbuild(macros) >= 1.164
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Browser for a fully immersed Big Screen experience allowing you to
27 navigate the world wide web using just your remote control.
28
29 %prep
30 %setup -q -n %{kpname}-%{version}
31
32 %build
33 install -d build
34 cd build
35 %cmake -G Ninja \
36         %{!?with_tests:-DBUILD_TESTING=OFF} \
37         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
38         -DHTML_INSTALL_DIR=%{_kdedocdir} \
39         ..
40 %ninja_build
41
42 %if %{with tests}
43 ctest
44 %endif
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %ninja_install -C build
49
50 %find_lang %{kpname} --all-name --with-kde
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files -f %{kpname}.lang
56 %defattr(644,root,root,755)
57 %attr(755,root,root) %{_bindir}/aura-browser
58 %{_desktopdir}/org.aura.browser.desktop
59 %{_iconsdir}/hicolor/128x128/apps/aura-browser.png
60 %{_iconsdir}/hicolor/256x256/apps/aura-browser.png
61 %{_datadir}/metainfo/org.kde.invent.aura_browser.metainfo.xml
This page took 0.03886 seconds and 2 git commands to generate.