]> git.pld-linux.org Git - packages/koji.git/blob - koji.spec
a7a446e54a8814d3ad79d791b7945df5e46be699
[packages/koji.git] / koji.spec
1 # TODO
2 # - package real webapp
3 # - unpackaged:
4 #   /etc/koji-gc/koji-gc.conf
5 #   /etc/koji-hub/hub.conf
6 #   /etc/koji-hub/plugins/messagebus.conf
7 #   /etc/koji-shadow/koji-shadow.conf
8 #   /usr/lib/koji-hub-plugins/echo.py
9 #   /usr/lib/koji-hub-plugins/echo.pyc
10 #   /usr/lib/koji-hub-plugins/messagebus.py
11 #   /usr/lib/koji-hub-plugins/messagebus.pyc
12 #   /usr/libexec/koji-hub/rpmdiff
13 #   /usr/libexec/kojid/mergerepos
14 #   /usr/sbin/koji-gc
15 #   /usr/sbin/koji-shadow
16 #   /usr/share/koji-builder/lib/tasks.py
17 #   /usr/share/koji-builder/lib/tasks.pyc
18 # - need pld packages:
19 #   python-krbV, mocK
20 Summary:        Build system tools
21 Summary(pl.UTF-8):      Narzędzia systemu budującego
22 Name:           koji
23 Version:        1.6.0
24 Release:        0.3
25 License:        LGPL v2 and GPL v2+
26 Group:          Applications/System
27 Source0:        https://fedorahosted.org/releases/k/o/koji/%{name}-%{version}.tar.bz2
28 # Source0-md5:  069e8229aa2b44698bbbbdea8d24aff4
29 URL:            http://fedorahosted.org/koji
30 BuildRequires:  python
31 BuildRequires:  python-modules
32 BuildRequires:  rpm-pythonprov
33 #Requires:      python-krbV >= 1.0.13
34 Requires:       python-pyOpenSSL
35 Requires:       python-rpm
36 Requires:       python-urlgrabber
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Koji is a system for building and tracking RPMS. The base package
42 contains shared libraries and the command-line interface.
43
44 %description -l pl.UTF-8
45 Koji to system do budowania i śledzenia pakietów RPM. Podstawowy
46 pakiet zawiera biblioteki współdzielone i interfejs linii poleceń.
47
48 %package hub
49 Summary:        Koji XMLRPC interface
50 Summary(pl.UTF-8):      Interfejs XMLRPC do Koji
51 Group:          Applications/Networking
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       apache-mod_alias
54 Requires:       apache-mod_python
55 Requires:       python-PyGreSQL
56 Requires:       webapps
57
58 %description hub
59 koji-hub is the XMLRPC interface to the Koji database.
60
61 %description hub -l pl.UTF-8
62 koji-hub to interfejs XMLRPC do bazy danych Koji.
63
64 %package builder
65 Summary:        Koji RPM builder daemon
66 Summary(pl.UTF-8):      Demon systemu Koji budujący pakiety RPM
67 Group:          Applications/System
68 Requires(post): /sbin/chkconfig
69 Requires(post): /sbin/service
70 Requires(pre):  /usr/sbin/useradd
71 Requires(preun):        /sbin/chkconfig
72 Requires(preun):        /sbin/service
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       /usr/bin/cvs
75 Requires:       /usr/bin/git
76 Requires:       /usr/bin/svn
77 Requires:       createrepo >= 0.4.11
78 #Requires:      mock >= 0.9.14
79 Requires:       rpm-build
80
81 %description builder
82 koji-builder is the daemon that runs on build machines and executes
83 tasks that come through the Koji system.
84
85 %description builder -l pl.UTF-8
86 koji-builder to demon działający na maszynach budujących i wykonujący
87 zadania przychodzące poprzez system Koji.
88
89 %package utils
90 Summary:        Koji Utilities
91 Summary(pl.UTF-8):      Narzędzia Koji
92 Group:          Applications/Networking
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       python-PyGreSQL
95
96 %description utils
97 Utilities for the Koji system.
98
99 %description utils -l pl.UTF-8
100 Narzędzia dla systemu Koji.
101
102 %package web
103 Summary:        Koji Web UI
104 Summary(pl.UTF-8):      Interfejs WWW do Koji
105 Group:          Applications/Networking
106 Requires:       %{name} = %{version}-%{release}
107 Requires:       apache-mod_auth_kerb
108 Requires:       apache-mod_authz_host
109 Requires:       apache-mod_mime
110 Requires:       apache-mod_python
111 Requires:       python-PyGreSQL
112 Requires:       python-cheetah
113 #Requires:      python-krbV >= 1.0.13
114 Requires:       webapps
115
116 %description web
117 koji-web is a Web UI to the Koji system.
118
119 %description web -l pl.UTF-8
120 koji-web to interfejs WWW do systemu Koji.
121
122 %prep
123 %setup -q
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 mv $RPM_BUILD_ROOT%{_sysconfdir}/httpd/{conf.d,webapps.d}
131
132 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
133 mv $RPM_BUILD_ROOT{%{_prefix}/lib/python2.7/site-packages/koji,%{py_sitescriptdir}/%{name}}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %pre builder
139 %useradd -u 221 -r -d /home/services/koji -s /bin/sh -c "Koji builder" -g nobody kojibuilder
140
141 %post builder
142 /sbin/chkconfig --add kojid
143 %service kojid restart
144
145 %preun builder
146 if [ "$1" = "0" ]; then
147         %service kojid stop
148         /sbin/chkconfig --del kojid
149 fi
150
151 %post utils
152 /sbin/chkconfig --add kojira
153 %service kojira restart
154
155 %preun utils
156 if [ "$1" = "0" ]; then
157         %service kojira stop
158         /sbin/chkconfig --del kojira
159 fi
160
161 %files
162 %defattr(644,root,root,755)
163 %doc docs Authors COPYING
164 %attr(755,root,root) %{_bindir}/*
165 %{py_sitescriptdir}/%{name}
166 %config(noreplace) %{_sysconfdir}/koji.conf
167
168 %files hub
169 %defattr(644,root,root,755)
170 %{_datadir}/koji-hub
171 %config(noreplace) %{_sysconfdir}/httpd/webapps.d/kojihub.conf
172
173 %files utils
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_sbindir}/kojira
176 %attr(754,root,root) /etc/rc.d/init.d/kojira
177 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/kojira
178 %dir %{_sysconfdir}/kojira
179 %config(noreplace) %{_sysconfdir}/kojira/kojira.conf
180
181 %files web
182 %defattr(644,root,root,755)
183 %{_datadir}/koji-web
184 %dir %{_sysconfdir}/kojiweb
185 %config(noreplace) %{_sysconfdir}/httpd/webapps.d/kojiweb.conf
186
187 %files builder
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_sbindir}/kojid
190 %attr(754,root,root) /etc/rc.d/init.d/kojid
191 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/kojid
192 %dir %{_sysconfdir}/kojid
193 %config(noreplace) %{_sysconfdir}/kojid/kojid.conf
194 # TODO: kill -
195 %attr(-,kojibuilder,kojibuilder) %{_sysconfdir}/mock/koji
This page took 0.053556 seconds and 2 git commands to generate.