]> git.pld-linux.org Git - packages/kodi.git/blob - kodi.spec
- relup
[packages/kodi.git] / kodi.spec
1 # TODO:
2 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
3 #  - add and/or fix users/groups permissions
4 #  - split to subpackages?
5 # - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
6 #
7 # Conditional build:
8 # Features:
9 %bcond_with     afpclient       # AFP support via libafpclient
10 %bcond_without  airplay         # AirPlay support
11 %bcond_with     airtunes        # AirTunes support
12 %bcond_without  alsa            # ALSA support
13 %bcond_without  avahi           # Avahi support
14 %bcond_without  dbus            # DBUS support
15 %bcond_without  dvdcss          # DVDCSS support
16 %bcond_without  opengl          # OpenGL rendering
17 %bcond_with     gtest           # configure Google Test Framework
18 %bcond_without  joystick        # SDL joystick support
19 %bcond_without  libcap          # libcap support
20 %bcond_with     libcec          # libcec support
21 %bcond_without  gif             # GIF support via giflib
22 %bcond_without  libusb          # libusb support
23 %bcond_with     mdnsembedded    # mDNSEmbedded support
24 %bcond_without  mysql           # MySQL
25 %bcond_without  nfs             # NFS support via libnfs
26 %bcond_without  nonfree         # componentents with non-compliant licenses
27 %bcond_with     openmax         # OpenMax decoding, requires OpenGLES
28 %bcond_without  optical_drive   # optical drive
29 %bcond_without  projectm        # ProjectM visualisation
30 %bcond_without  pulse           # PulseAudio support
31 %bcond_without  rtmp            # RTMP support via librtmp
32 %bcond_without  samba           # SAMBA support
33 %bcond_without  sdl             # SDL
34 %bcond_without  ssh             # SSH SFTP support
35 %bcond_without  texturepacker   # texturepacker support
36 %bcond_without  udev            # udev support
37 %bcond_without  upnp            # UPnP support
38 %bcond_without  vaapi           # VAAPI decoding
39 %bcond_without  vdpau           # VDPAU decoding
40 %bcond_with     vtbdecoder      # VTBDecoder decoding (VTB Decoder not supported on this platform)
41 %bcond_without  webserver       # webserver
42 %bcond_without  x11             # x11 'Linux Only'
43 %bcond_without  xrandr          # XRandR support
44 %bcond_with     asap_codec      # ASAP ADPCM support
45 %bcond_with     gles            # OpenGLES rendering
46 %bcond_without  libbluray       # libbluray support
47 %bcond_without  mid             # MID support
48 %bcond_with     profiling       # gprof profiling
49 %bcond_with     tegra           # Tegra2 arm
50 %bcond_with     wayland         # wayland
51 # System libs:
52 %bcond_without  system_ffmpeg   # build with system ffmpeg
53 %bcond_with     system_dvdread  # build with system dvdread
54
55 %define codename Leia
56 #define subver  rc1
57 Summary:        Kodi is a free and open source media-player and entertainment hub
58 Name:           kodi
59 Version:        18.4
60 Release:        7
61 License:        GPL v2+ and GPL v3+
62 Group:          Applications/Multimedia
63 #Source0Download: https://github.com/xbmc/xbmc/releases
64 Source0:        https://github.com/xbmc/xbmc/archive/%{version}-%{codename}.tar.gz
65 # Source0-md5:  5e5e1e2527c2619785597b04e35fda6c
66 Patch0:         jpeglib-boolean.patch
67 Patch1:         disable-static.patch
68 Patch2:         dvdread.patch
69 Patch3:         ffmpeg3.patch
70 Patch4:         gcc5.patch
71 Patch5:         libdvd.patch
72 Patch6:         microhttpd.patch
73 Patch7:         assert.patch
74 Patch8:         fmt.patch
75 URL:            https://kodi.tv/
76 BuildRequires:  EGL-devel
77 BuildRequires:  OpenGL-GLU-devel
78 BuildRequires:  OpenGL-devel
79 BuildRequires:  SDL2-devel
80 BuildRequires:  alsa-lib-devel
81 BuildRequires:  avahi-devel
82 BuildRequires:  bluez-libs-devel >= 4.99
83 BuildRequires:  bzip2-devel
84 BuildRequires:  cmake >= 3.4
85 BuildRequires:  crossguid-devel
86 BuildRequires:  curl-devel
87 BuildRequires:  dbus-devel
88 BuildRequires:  libfmt-devel >= 3.0.1
89 BuildRequires:  rapidjson-devel >= 1.1.0
90 # libavcodec >= 56.26.100 libavfilter >= 5.11.102 libavformat >= 56.25.101 libavutil >= 54.20.100 libpostproc >= 53.3.100 libswscale >= 3.1.101 libswresample >= 1.1.100
91 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 2.4.4}
92 BuildRequires:  flac-devel
93 BuildRequires:  flatbuffers-devel >= 1.9.0
94 BuildRequires:  fontconfig-devel
95 BuildRequires:  freetype-devel
96 BuildRequires:  fribidi-devel
97 BuildRequires:  gawk
98 BuildRequires:  gettext-autopoint
99 BuildRequires:  gettext-tools
100 %{?with_gif:BuildRequires:      giflib-devel}
101 BuildRequires:  gperf
102 BuildRequires:  jre
103 BuildRequires:  lcms2-devel
104 BuildRequires:  libass-devel
105 BuildRequires:  libatomic-devel
106 BuildRequires:  libbluray-devel >= 0.7.0
107 BuildRequires:  libcap-devel
108 BuildRequires:  libcdio-devel
109 %{?with_libcec:BuildRequires:   libcec-devel >= 3.0.0}
110 BuildRequires:  libdrm-devel
111 BuildRequires:  libdvdcss-devel >= 1.4.1
112 %{?with_system_dvdread:BuildRequires:   libdvdread-devel}
113 BuildRequires:  libgcrypt-devel
114 BuildRequires:  libjpeg-devel
115 BuildRequires:  libltdl-devel
116 BuildRequires:  libmicrohttpd-devel >= 0.9.40
117 BuildRequires:  libogg-devel
118 BuildRequires:  libplist-devel
119 BuildRequires:  libpng-devel
120 BuildRequires:  librtmp-devel
121 BuildRequires:  libsmbclient-devel
122 BuildRequires:  libssh-devel
123 BuildRequires:  libstdc++-devel
124 BuildRequires:  libtool
125 BuildRequires:  libuuid-devel
126 BuildRequires:  libva-devel
127 BuildRequires:  libva-x11-devel
128 BuildRequires:  libvdpau-devel
129 BuildRequires:  libvorbis-devel
130 BuildRequires:  libxml2-devel >= 2.0
131 BuildRequires:  libxslt-devel
132 BuildRequires:  lzo-devel
133 BuildRequires:  mysql-devel
134 %ifarch %{ix86}
135 BuildRequires:  nasm
136 %endif
137 BuildRequires:  fstrcmp-devel >= 0.7
138 BuildRequires:  openssl-devel
139 BuildRequires:  pcre-cxx-devel
140 BuildRequires:  pkgconfig
141 BuildRequires:  pkgconfig(egl)
142 BuildRequires:  pkgconfig(gl)
143 BuildRequires:  pkgconfig(glu)
144 BuildRequires:  pulseaudio-devel >= 1.0
145 BuildRequires:  python-devel >= 1:2.6
146 BuildRequires:  rpm-pythonprov
147 BuildRequires:  rpmbuild(macros) >= 1.566
148 BuildRequires:  sed >= 4.0
149 BuildRequires:  sqlite3-devel
150 BuildRequires:  swig
151 BuildRequires:  taglib-devel >= 1.8
152 BuildRequires:  tinyxml-devel >= 2.6.2
153 BuildRequires:  udev-devel
154 BuildRequires:  unzip
155 BuildRequires:  xorg-lib-libX11-devel
156 BuildRequires:  xorg-lib-libXext-devel
157 BuildRequires:  xorg-lib-libXrandr-devel
158 BuildRequires:  yajl-devel >= 2
159 BuildRequires:  zip
160 BuildRequires:  zlib-devel
161 # kodi uses it's own, modified squish
162 BuildConflicts: squish-devel
163 #https://github.com/sahlberg/libnfs
164 BuildRequires:  libnfs-devel
165 #http://sites.google.com/site/alexthepuffin/home
166 #BuildRequires: afpfs-ng-devel
167 #BuildRequires: shairplay-devel
168 Requires:       /usr/bin/glxinfo
169 Requires:       SDL >= 1.2.14-5
170 Requires:       lsb-release
171 Requires:       xorg-app-xdpyinfo
172 # dlopened libraries:
173 # grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
174 Requires:       curl-libs
175 Requires:       libass
176 Requires:       libbluray
177 Requires:       libmodplug
178 Requires:       libmpeg2-libs
179 Requires:       libogg
180 Requires:       libplist
181 Requires:       libvorbis
182 Obsoletes:      xbmc < 14.0
183 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
184
185 # extracting debug info from /home/users/glen/tmp/kodi-18.0-root-glen/usr/lib64/kodi/kodi-x11
186 # /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
187 %define         _noautostrip    kodi-x11
188 %define         _enable_debug_packages  0
189
190 %description
191 Kodi Entertainment Center (formerly XBMC) is a free and open-source
192 media player software developed by the XBMC Foundation, a non-profit
193 technology consortium. Kodi is available for multiple operating
194 systems and hardware platforms, with a software 10-foot user interface
195 for use with televisions and remote controls. It allows users to play
196 and view most videos, music, such as podcasts from the internet, and
197 all common digital media files from local and network storage media.
198
199 %prep
200 %setup -q -n xbmc-%{version}%{?subver}-%{codename}
201 #%patch0 -p1
202 %patch1 -p1
203 %{?with_system_dvdread:%patch2 -p1}
204 #%patch3 -p1
205 #%patch4 -p1
206 %patch5 -p1
207 %patch6 -p1
208 %patch7 -p1
209 %patch8 -p1
210
211 %{__rm} -r lib/win32
212
213 %if %{without system_ffmpeg}
214 #ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
215 %endif
216
217 %build
218 install -d build
219 cd build
220 # cmake not picking up include path from pkgconfig
221 # https://trac.kodi.tv/ticket/16861
222 %define specflags -I/usr/include/freetype2
223 %cmake \
224         -DENABLE_AIRTUNES=%{__true_false airtunes} \
225         -DENABLE_DVDCSS=%{__true_false dvdcss} \
226         -DENABLE_INTERNAL_CROSSGUID=OFF \
227         -DENABLE_INTERNAL_FFMPEG=%{!?with_system_ffmpeg:ON}%{?with_system_ffmpeg:OFF} \
228         -DENABLE_INTERNAL_LIBDVD=OFF \
229         -DENABLE_OPTICAL=%{__true_false optical_drive} \
230         -DENABLE_UPNP=%{__true_false upnp} \
231         ..
232 %if 0
233 %configure \
234         ac_cv_type__Bool=yes \
235         --disable-silent-rules \
236         --disable-debug \
237         --disable-ccache \
238         --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
239         %{__enable_disable afpclient} \
240         %{__enable_disable airplay} \
241         %{__enable_disable alsa} \
242         %{__enable_disable asap_codec asap-codec} \
243         %{__enable_disable avahi} \
244         %{__enable_disable dbus} \
245         %{__enable_disable gles} \
246         %{__enable_disable opengl gl} \
247         %{__enable_disable gtest} \
248         %{__enable_disable joystick} \
249         %{__enable_disable libbluray} \
250         %{__enable_disable libcap} \
251         %{__enable_disable libcec} \
252         %{__enable_disable gif libgif} \
253         %{__enable_disable libusb} \
254         %{__enable_disable mdnsembedded} \
255         %{__enable_disable mid} \
256         %{__enable_disable mysql} \
257         %{__enable_disable nfs} \
258         %{__enable_disable nonfree non-free} \
259         %{__enable_disable openmax} \
260         %{__enable_disable profiling} \
261         %{__enable_disable pulse} \
262         %{__enable_disable rtmp} \
263         %{__enable_disable samba} \
264         %{__enable_disable sdl} \
265         %{__enable_disable ssh} \
266         %{__enable_disable tegra} \
267         %{__enable_disable texturepacker} \
268         %{__enable_disable udev} \
269         %{__enable_disable upnp} \
270         %{__enable_disable vaapi} \
271         %{__enable_disable vdpau} \
272         %{__enable_disable vtbdecoder} \
273         %{__enable_disable wayland} \
274         %{__enable_disable webserver} \
275         %{__enable_disable x11} \
276         %{__enable_disable xrandr} \
277         %{nil}
278 %endif
279
280 %{__make}
281
282 %install
283 rm -rf $RPM_BUILD_ROOT
284 %{__make} -C build install \
285         DESTDIR=$RPM_BUILD_ROOT
286
287 %{__rm} $RPM_BUILD_ROOT%{_docdir}/{version.txt,README.Linux.md,LICENSE.md}
288
289 # not packaged
290 %{__rm} $RPM_BUILD_ROOT%{_prefix}/lib/firewalld/services/kodi-*.xml
291
292 # no -devel package yet
293 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
294
295 %clean
296 rm -rf $RPM_BUILD_ROOT
297
298 %files
299 %defattr(644,root,root,755)
300 %doc README.md docs/README.Linux.md
301 %attr(755,root,root) %{_bindir}/TexturePacker
302 %attr(755,root,root) %{_bindir}/kodi
303 %attr(755,root,root) %{_bindir}/kodi-standalone
304 %{_datadir}/%{name}
305 %attr(755,root,root) %{_libdir}/%{name}
306 %{_desktopdir}/kodi.desktop
307 %{_iconsdir}/hicolor/*/apps/%{name}.png
308 %{_datadir}/xsessions/kodi.desktop
This page took 0.142096 seconds and 4 git commands to generate.