]> git.pld-linux.org Git - packages/kodi.git/blob - kodi.spec
buildsystem replaced with cmake
[packages/kodi.git] / kodi.spec
1 # TODO:
2 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
3 #  - add and/or fix users/groups permissions
4 #  - split to subpackages?
5 # - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
6 #
7 # Conditional build:
8 # Features:
9 %bcond_with     afpclient       # AFP support via libafpclient
10 %bcond_without  airplay         # AirPlay support
11 %bcond_with     airtunes        # AirTunes support
12 %bcond_without  alsa            # ALSA support
13 %bcond_without  avahi           # Avahi support
14 %bcond_without  dbus            # DBUS support
15 %bcond_without  dvdcss          # DVDCSS support
16 %bcond_without  gl              # OpenGL rendering
17 %bcond_with     gtest           # configure Google Test Framework
18 %bcond_without  joystick        # SDL joystick support
19 %bcond_without  libcap          # libcap support
20 %bcond_with     libcec          # libcec support
21 %bcond_without  libgif          # gif support via libgif
22 %bcond_without  libusb          # libusb support
23 %bcond_with     mdnsembedded    # mDNSEmbedded support
24 %bcond_without  mysql           # MySQL
25 %bcond_without  nfs             # NFS support via libnfs
26 %bcond_without  non_free        # componentents with non-compliant licenses
27 %bcond_with     openmax         # OpenMax decoding, requires OpenGLES
28 %bcond_without  optical_drive   # optical drive
29 %bcond_without  projectm        # ProjectM visualisation
30 %bcond_without  pulse           # PulseAudio support
31 %bcond_without  rtmp            # RTMP support via librtmp
32 %bcond_without  samba           # SAMBA support
33 %bcond_without  sdl             # SDL
34 %bcond_without  ssh             # SSH SFTP support
35 %bcond_without  texturepacker   # texturepacker support
36 %bcond_without  udev            # udev support
37 %bcond_without  upnp            # UPnP support
38 %bcond_without  vaapi           # VAAPI decoding
39 %bcond_without  vdpau           # VDPAU decoding
40 %bcond_with     vtbdecoder      # VTBDecoder decoding (VTB Decoder not supported on this platform)
41 %bcond_without  webserver       # webserver
42 %bcond_without  x11             # x11 'Linux Only'
43 %bcond_without  xrandr          # XRandR support
44 %bcond_with     asap_codec      # ASAP ADPCM support
45 %bcond_with     gles            # OpenGLES rendering
46 %bcond_without  libbluray       # libbluray support
47 %bcond_without  mid             # MID support
48 %bcond_with     profiling       # gprof profiling
49 %bcond_with     tegra           # Tegra2 arm
50 %bcond_with     wayland         # wayland
51 # System libs:
52 %bcond_without  system_ffmpeg   # build with system ffmpeg
53 %bcond_with     system_dvdread  # build with system dvdread
54
55 %define codename Leia
56 %define subver  a1
57 Summary:        Kodi is a free and open source media-player and entertainment hub
58 Name:           kodi
59 Version:        18.0
60 Release:        0.1
61 License:        GPL v2+ and GPL v3+
62 Group:          Applications/Multimedia
63 #Source0:       http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
64 Source0:        https://github.com/xbmc/xbmc/archive/%{version}%{subver}-%{codename}.tar.gz
65 # Source0-md5:  c1ae435c2d674262cee9a06791ba94bc
66 Patch0:         jpeglib-boolean.patch
67 Patch1:         disable-static.patch
68 Patch2:         dvdread.patch
69 Patch3:         ffmpeg3.patch
70 Patch4:         gcc5.patch
71 Patch5:         libdvd.patch
72 URL:            http://kodi.tv/
73 BuildRequires:  Mesa-libEGL-devel
74 BuildRequires:  OpenGL-GLU-devel
75 BuildRequires:  OpenGL-devel
76 BuildRequires:  SDL2-devel
77 BuildRequires:  alsa-lib-devel
78 BuildRequires:  avahi-devel
79 BuildRequires:  bluez-libs-devel >= 4.99
80 BuildRequires:  bzip2-devel
81 BuildRequires:  cmake >= 3.4
82 BuildRequires:  crossguid-devel
83 BuildRequires:  curl-devel
84 BuildRequires:  dbus-devel
85 # libavcodec >= 56.26.100 libavfilter >= 5.11.102 libavformat >= 56.25.101 libavutil >= 54.20.100 libpostproc >= 53.3.100 libswscale >= 3.1.101 libswresample >= 1.1.100
86 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 2.4.4}
87 BuildRequires:  flac-devel
88 BuildRequires:  fontconfig-devel
89 BuildRequires:  freetype-devel
90 BuildRequires:  fribidi-devel
91 BuildRequires:  gawk
92 BuildRequires:  gettext-autopoint
93 BuildRequires:  gettext-tools
94 BuildRequires:  giflib-devel
95 %{?with_libgif:BuildRequires:   giflib-devel}
96 BuildRequires:  gperf
97 BuildRequires:  jre
98 BuildRequires:  lcms2-devel
99 BuildRequires:  libass-devel
100 BuildRequires:  libatomic-devel
101 BuildRequires:  libbluray-devel >= 0.7.0
102 BuildRequires:  libcap-devel
103 BuildRequires:  libcdio-devel
104 %{?with_libcec:BuildRequires:   libcec-devel >= 3.0.0}
105 BuildRequires:  libdrm-devel
106 %{?with_system_dvdread:BuildRequires:   libdvdread-devel}
107 BuildRequires:  libgcrypt-devel
108 BuildRequires:  libjpeg-devel
109 BuildRequires:  libltdl-devel
110 BuildRequires:  libmicrohttpd-devel
111 BuildRequires:  libogg-devel
112 BuildRequires:  libplist-devel
113 BuildRequires:  libpng-devel
114 BuildRequires:  librtmp-devel
115 BuildRequires:  libsmbclient-devel
116 BuildRequires:  libssh-devel
117 BuildRequires:  libstdc++-devel
118 BuildRequires:  libtool
119 BuildRequires:  libuuid-devel
120 BuildRequires:  libva-devel
121 BuildRequires:  libva-x11-devel
122 BuildRequires:  libvdpau-devel
123 BuildRequires:  libvorbis-devel
124 BuildRequires:  libxml2-devel >= 2.0
125 BuildRequires:  libxslt-devel
126 BuildRequires:  lzo-devel
127 BuildRequires:  mysql-devel
128 %ifarch %{ix86}
129 BuildRequires:  nasm
130 %endif
131 BuildRequires:  openssl-devel
132 BuildRequires:  pcre-cxx-devel
133 BuildRequires:  pkgconfig
134 BuildRequires:  pulseaudio-devel >= 1.0
135 BuildRequires:  python-devel >= 1:2.6
136 BuildRequires:  rpm-pythonprov
137 BuildRequires:  rpmbuild(macros) >= 1.566
138 BuildRequires:  sed >= 4.0
139 BuildRequires:  sqlite3-devel
140 BuildRequires:  swig
141 BuildRequires:  taglib-devel >= 1.8
142 BuildRequires:  tinyxml-devel >= 2.6.2
143 BuildRequires:  udev-devel
144 BuildRequires:  unzip
145 BuildRequires:  xorg-lib-libX11-devel
146 BuildRequires:  xorg-lib-libXext-devel
147 BuildRequires:  xorg-lib-libXrandr-devel
148 BuildRequires:  yajl-devel >= 2
149 BuildRequires:  zip
150 BuildRequires:  zlib-devel
151 # kodi uses it's own, modified squish
152 BuildConflicts: squish-devel
153 #https://github.com/sahlberg/libnfs
154 BuildRequires:  libnfs-devel
155 #http://sites.google.com/site/alexthepuffin/home
156 #BuildRequires: afpfs-ng-devel
157 #BuildRequires: shairplay-devel
158 Requires:       /usr/bin/glxinfo
159 Requires:       SDL >= 1.2.14-5
160 Requires:       lsb-release
161 Requires:       xorg-app-xdpyinfo
162 # dlopened libraries:
163 # grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
164 Requires:       curl-libs
165 Requires:       libass
166 Requires:       libbluray
167 Requires:       libmodplug
168 Requires:       libmpeg2-libs
169 Requires:       libogg
170 Requires:       libplist
171 Requires:       libvorbis
172 Obsoletes:      xbmc < 14.0
173 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
174
175 %description
176 Kodi Entertainment Center (formerly XBMC) is a free and open-source
177 media player software developed by the XBMC Foundation, a non-profit
178 technology consortium. Kodi is available for multiple operating
179 systems and hardware platforms, with a software 10-foot user interface
180 for use with televisions and remote controls. It allows users to play
181 and view most videos, music, such as podcasts from the internet, and
182 all common digital media files from local and network storage media.
183
184 %prep
185 %setup -q -n xbmc-%{version}%{?subver}-%{codename}
186 #%patch0 -p1
187 %patch1 -p1
188 %{?with_system_dvdread:%patch2 -p1}
189 #%patch3 -p1
190 #%patch4 -p1
191 %{!?with_system_dvdread:%patch5 -p1}
192
193 #%{__rm} -r lib/cximage-6.0/zlib
194 #%{__rm} -r lib/libhdhomerun
195 #%{__rm} -r lib/libmpeg2
196 #%{__rm} -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
197 #%{__rm} -r lib/libbluray
198 #%{__rm} -r lib/librtmp
199 %{__rm} -r lib/win32
200 #%{?with_system_dvdread:%{__rm} -r lib/libdvd/libdvdread}
201
202 %if %{without system_ffmpeg}
203 #ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
204 %endif
205
206 %build
207 install -d build
208 cd build
209 %cmake ..
210 %if 0
211 %configure \
212         ac_cv_type__Bool=yes \
213         --disable-silent-rules \
214         --disable-debug \
215         --disable-ccache \
216         --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
217         %{__enable_disable afpclient} \
218         %{__enable_disable airplay} \
219         %{__enable_disable airtunes} \
220         %{__enable_disable alsa} \
221         %{__enable_disable asap_codec asap-codec} \
222         %{__enable_disable avahi} \
223         %{__enable_disable dbus} \
224         %{__enable_disable dvdcss} \
225         %{__enable_disable gles} \
226         %{__enable_disable gl} \
227         %{__enable_disable gtest} \
228         %{__enable_disable joystick} \
229         %{__enable_disable libbluray} \
230         %{__enable_disable libcap} \
231         %{__enable_disable libcec} \
232         %{__enable_disable libgif} \
233         %{__enable_disable libusb} \
234         %{__enable_disable mdnsembedded} \
235         %{__enable_disable mid} \
236         %{__enable_disable mysql} \
237         %{__enable_disable nfs} \
238         %{__enable_disable non_free non-free} \
239         %{__enable_disable openmax} \
240         %{__enable_disable optical_drive optical-drive} \
241         %{__enable_disable profiling} \
242         %{__enable_disable pulse} \
243         %{__enable_disable rtmp} \
244         %{__enable_disable samba} \
245         %{__enable_disable sdl} \
246         %{__enable_disable ssh} \
247         %{__enable_disable tegra} \
248         %{__enable_disable texturepacker} \
249         %{__enable_disable udev} \
250         %{__enable_disable upnp} \
251         %{__enable_disable vaapi} \
252         %{__enable_disable vdpau} \
253         %{__enable_disable vtbdecoder} \
254         %{__enable_disable wayland} \
255         %{__enable_disable webserver} \
256         %{__enable_disable x11} \
257         %{__enable_disable xrandr} \
258         %{nil}
259 %endif
260
261 %{__make}
262
263 %install
264 rm -rf $RPM_BUILD_ROOT
265 %{__make} -C build install \
266         DESTDIR=$RPM_BUILD_ROOT
267
268 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
269
270 # no -devel package yet
271 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
272 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
273
274 # no real use for symlinks to datadir, and make rpm packaging more difficult (symlink vs dir issues)
275 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xbmc
276 %{__rm} $RPM_BUILD_ROOT%{_datadir}/xbmc
277
278 %clean
279 rm -rf $RPM_BUILD_ROOT
280
281 %files
282 %defattr(644,root,root,755)
283 %doc README.md docs/README.linux
284 %attr(755,root,root) %{_bindir}/kodi
285 %attr(755,root,root) %{_bindir}/kodi-standalone
286 %{_datadir}/%{name}
287 %attr(755,root,root) %{_libdir}/%{name}
288 %{_desktopdir}/kodi.desktop
289 %{_iconsdir}/hicolor/*/apps/%{name}.png
290 %{_datadir}/xsessions/kodi.desktop
291
292 # legacy xbmc compatibility links
293 %attr(755,root,root) %{_bindir}/xbmc
294 %attr(755,root,root) %{_bindir}/xbmc-standalone
295 %{_datadir}/xsessions/xbmc.desktop
This page took 0.160526 seconds and 4 git commands to generate.