]> git.pld-linux.org Git - packages/kodi.git/blob - kodi.spec
ensure consistent build: add all 'default is yes' options
[packages/kodi.git] / kodi.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - add and/or fix users/groups permissions
6 #  - split to subpackages?
7 #
8 # Conditional build:
9 %bcond_without  cec     # build without cec support
10 %bcond_without  dvdcss  # DVDCSS support
11 %bcond_without  fishbmc         # FishBMC visualisation
12 %bcond_without  gl              # OpenGL rendering
13 %bcond_without  goom            # GOOM visualisation
14 %bcond_with     gtest   # configure Google Test Framework
15 %bcond_with     hal     # build with HAL
16 %bcond_without  joystick        # SDL joystick support
17 %bcond_without  projectm        # ProjectM visualisation
18 %bcond_without  rsxs            # really slick X screensavers
19 %bcond_without  spectrum        # Spectrum visualisation
20 %bcond_without  texturepacker   # texturepacker support
21 %bcond_without  waveform        # Waveform visualisation
22 %bcond_without  x11             # x11 'Linux Only'
23 %bcond_without  xrandr          # XRandR support
24
25 %define codename Helix
26 Summary:        Kodi is a free and open source media-player and entertainment hub
27 Name:           kodi
28 Version:        14.0
29 Release:        0.1
30 License:        GPL v2+ and GPL v3+
31 Group:          Applications/Multimedia
32 Source0:        http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
33 # Source0-md5:  9717c539789789b8aeaf1dcfdb9f2c69
34 Patch0:         jpeglib-boolean.patch
35 URL:            http://kodi.tv/
36 BuildRequires:  Mesa-libGLU-devel
37 BuildRequires:  OpenGL-devel
38 BuildRequires:  SDL_image-devel
39 BuildRequires:  SDL_mixer-devel
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 BuildRequires:  avahi-devel
44 BuildRequires:  bluez-libs-devel >= 4.99
45 BuildRequires:  boost-devel
46 BuildRequires:  bzip2-devel
47 BuildRequires:  cmake
48 BuildRequires:  curl-devel
49 BuildRequires:  dbus-devel
50 BuildRequires:  doxygen
51 BuildRequires:  ffmpeg-devel
52 BuildRequires:  flac-devel
53 BuildRequires:  fontconfig-devel
54 BuildRequires:  freetype-devel
55 BuildRequires:  fribidi-devel
56 BuildRequires:  gawk
57 BuildRequires:  gettext-autopoint
58 BuildRequires:  gettext-tools
59 BuildRequires:  glew-devel
60 BuildRequires:  gperf
61 %{?with_hal:BuildRequires:      hal-devel}
62 BuildRequires:  jasper-devel
63 BuildRequires:  jre
64 BuildRequires:  libass-devel
65 BuildRequires:  libbluray-devel >= 0.2.1
66 BuildRequires:  libcap-devel
67 BuildRequires:  libcdio-devel
68 %{?with_cec:BuildRequires:      libcec-devel}
69 %ifarch i686 pentium4 athlon %{x8664}
70 BuildRequires:  libcrystalhd-devel
71 %endif
72 BuildRequires:  libgcrypt-devel
73 BuildRequires:  libjpeg-devel
74 BuildRequires:  libltdl-devel
75 BuildRequires:  libmad-devel
76 BuildRequires:  libmicrohttpd-devel
77 BuildRequires:  libmodplug-devel
78 BuildRequires:  libmpeg2-devel
79 BuildRequires:  libogg-devel
80 BuildRequires:  libplist-devel
81 BuildRequires:  libpng-devel
82 BuildRequires:  librtmp-devel
83 BuildRequires:  libsamplerate-devel
84 BuildRequires:  libsmbclient-devel
85 BuildRequires:  libssh-devel
86 BuildRequires:  libtiff-devel
87 BuildRequires:  libtool
88 BuildRequires:  libva-devel
89 BuildRequires:  libva-glx-devel
90 BuildRequires:  libvdpau-devel
91 BuildRequires:  libvorbis-devel
92 BuildRequires:  libxslt-devel
93 BuildRequires:  lzo-devel
94 BuildRequires:  mysql-devel
95 %ifarch %{ix86}
96 BuildRequires:  nasm
97 %endif
98 BuildRequires:  openssl-devel
99 BuildRequires:  pcre-cxx-devel
100 BuildRequires:  pkgconfig
101 BuildRequires:  pulseaudio-devel
102 BuildRequires:  python-devel >= 2.4
103 BuildRequires:  rpm-pythonprov
104 BuildRequires:  rpmbuild(macros) >= 1.566
105 # used internally
106 BuildRequires:  sed >= 4.0
107 BuildRequires:  sqlite3-devel
108 BuildRequires:  swig
109 BuildRequires:  taglib-devel >= 1.8
110 BuildRequires:  tinyxml-devel
111 BuildRequires:  udev-devel
112 BuildRequires:  unzip
113 BuildRequires:  xorg-lib-libX11-devel
114 BuildRequires:  xorg-lib-libXext-devel
115 BuildRequires:  xorg-lib-libXinerama-devel
116 BuildRequires:  xorg-lib-libXmu-devel
117 BuildRequires:  xorg-lib-libXrandr-devel
118 BuildRequires:  xorg-lib-libXt-devel
119 BuildRequires:  xorg-lib-libXtst-devel
120 BuildRequires:  yajl-devel
121 BuildRequires:  yasm
122 BuildRequires:  zip
123 BuildRequires:  zlib-devel
124 #https://github.com/sahlberg/libnfs
125 #BuildRequires: libnfs-devel
126 #http://sites.google.com/site/alexthepuffin/home
127 #BuildRequires: afpfs-ng-devel
128 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
129 #https://github.com/albertz/shairport
130 #BuildRequires: libshairport
131 Requires:       /usr/bin/glxinfo
132 Requires:       SDL >= 1.2.14-5
133 Requires:       lsb-release
134 Requires:       xorg-app-xdpyinfo
135 # dlopened libraries:
136 # grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
137 Requires:       curl-libs
138 Requires:       libass
139 Requires:       libbluray
140 Requires:       libmodplug
141 Requires:       libmpeg2-libs
142 Requires:       libogg
143 Requires:       libplist
144 Requires:       libvorbis
145 Obsoletes:      xbmc < 14.0
146 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
147
148 %description
149 Kodi Entertainment Center (formerly XBMC) is a free and open-source
150 media player software developed by the XBMC Foundation, a non-profit
151 technology consortium. Kodi is available for multiple operating
152 systems and hardware platforms, with a software 10-foot user interface
153 for use with televisions and remote controls. It allows users to play
154 and view most videos, music, such as podcasts from the internet, and
155 all common digital media files from local and network storage media.
156
157 %prep
158 %setup -q -n xbmc-%{version}-%{codename}
159 %patch0 -p1
160
161 %build
162 ./bootstrap
163 %configure \
164         --disable-silent-rules \
165         --disable-debug \
166         --disable-afpclient \
167         --disable-airtunes \
168         --disable-ccache \
169         --disable-libusb \
170         --disable-nfs \
171         --enable-pulse \
172         --enable-udev \
173         %{__enable_disable dvdcss} \
174         %{__enable_disable fishbmc} \
175         %{__enable_disable gl} \
176         %{__enable_disable goom} \
177         %{__enable_disable gtest} \
178         %{__enable_disable gtexturepacker} \
179         %{__enable_disable hal} \
180         %{__enable_disable joystick} \
181         %{__enable_disable libcec} \
182         %{__enable_disable projectm} \
183         %{__enable_disable rsxs} \
184         %{__enable_disable spectrum} \
185         %{__enable_disable waveform} \
186         %{__enable_disable x11} \
187         %{__enable_disable xrandr} \
188         %{nil}
189
190 %{__make}
191
192 %install
193 rm -rf $RPM_BUILD_ROOT
194 %{__make} install \
195         DESTDIR=$RPM_BUILD_ROOT
196
197 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
198
199 # no -devel package yet
200 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
201 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
202
203 %clean
204 rm -rf $RPM_BUILD_ROOT
205
206 %files
207 %defattr(644,root,root,755)
208 %doc README.md docs/README.linux
209 %attr(755,root,root) %{_bindir}/kodi
210 %attr(755,root,root) %{_bindir}/kodi-standalone
211 %{_datadir}/%{name}
212 %attr(755,root,root) %{_libdir}/%{name}
213 %{_desktopdir}/kodi.desktop
214 %{_iconsdir}/hicolor/*/apps/%{name}.png
215 %{_datadir}/xsessions/kodi.desktop
216
217 # legacy xbmc compatibility links
218 %attr(755,root,root) %{_bindir}/xbmc
219 %attr(755,root,root) %{_bindir}/xbmc-standalone
220 %{_libdir}/xbmc
221 %{_datadir}/xbmc
222 %{_datadir}/xsessions/xbmc.desktop
This page took 0.664025 seconds and 4 git commands to generate.