]> git.pld-linux.org Git - packages/kodi.git/blob - kodi.spec
xbmc renamed to kodi, update to 14.0-Helix
[packages/kodi.git] / kodi.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - add and/or fix users/groups permissions
6 #  - split to subpackages?
7 #
8 # Conditional build:
9 %bcond_without  cec     # build without cec support
10 %bcond_without  goom    # build without goom visualisation
11 %bcond_with     hal     # build with HAL
12
13 %define codename Helix
14 Summary:        XBMC is a free and open source media-player and entertainment hub
15 Name:           kodi
16 Version:        14.0
17 Release:        0.1
18 License:        GPL v2+ and GPL v3+
19 Group:          Applications/Multimedia
20 Source0:        http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
21 # Source0-md5:  9717c539789789b8aeaf1dcfdb9f2c69
22 Patch0:         jpeglib-boolean.patch
23 URL:            http://kodi.tv/
24 BuildRequires:  Mesa-libGLU-devel
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  SDL_image-devel
27 BuildRequires:  SDL_mixer-devel
28 BuildRequires:  alsa-lib-devel
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  avahi-devel
32 BuildRequires:  bluez-libs-devel >= 4.99
33 BuildRequires:  boost-devel
34 BuildRequires:  bzip2-devel
35 BuildRequires:  cmake
36 BuildRequires:  curl-devel
37 BuildRequires:  dbus-devel
38 BuildRequires:  ffmpeg-devel
39 BuildRequires:  flac-devel
40 BuildRequires:  fontconfig-devel
41 BuildRequires:  freetype-devel
42 BuildRequires:  fribidi-devel
43 BuildRequires:  gawk
44 BuildRequires:  gettext-autopoint
45 BuildRequires:  gettext-tools
46 BuildRequires:  glew-devel
47 BuildRequires:  gperf
48 %{?with_hal:BuildRequires:      hal-devel}
49 BuildRequires:  jasper-devel
50 BuildRequires:  jre
51 BuildRequires:  libass-devel
52 BuildRequires:  libbluray-devel >= 0.2.1
53 BuildRequires:  libcap-devel
54 BuildRequires:  libcdio-devel
55 %{?with_cec:BuildRequires:      libcec-devel}
56 %ifarch i686 pentium4 athlon %{x8664}
57 BuildRequires:  libcrystalhd-devel
58 %endif
59 BuildRequires:  libgcrypt-devel
60 BuildRequires:  libjpeg-devel
61 BuildRequires:  libltdl-devel
62 BuildRequires:  libmad-devel
63 BuildRequires:  libmicrohttpd-devel
64 BuildRequires:  libmodplug-devel
65 BuildRequires:  libmpeg2-devel
66 BuildRequires:  libogg-devel
67 BuildRequires:  libplist-devel
68 BuildRequires:  libpng-devel
69 BuildRequires:  librtmp-devel
70 BuildRequires:  libsamplerate-devel
71 BuildRequires:  libsmbclient-devel
72 BuildRequires:  libssh-devel
73 BuildRequires:  libtiff-devel
74 BuildRequires:  libtool
75 BuildRequires:  libva-devel
76 BuildRequires:  libva-glx-devel
77 BuildRequires:  libvdpau-devel
78 BuildRequires:  libvorbis-devel
79 BuildRequires:  lzo-devel
80 BuildRequires:  mysql-devel
81 %ifarch %{ix86}
82 BuildRequires:  nasm
83 %endif
84 BuildRequires:  openssl-devel
85 BuildRequires:  pcre-cxx-devel
86 BuildRequires:  pkgconfig
87 BuildRequires:  pulseaudio-devel
88 BuildRequires:  python-devel >= 2.4
89 BuildRequires:  rpm-pythonprov
90 BuildRequires:  rpmbuild(macros) >= 1.566
91 # used internally
92 BuildRequires:  sed >= 4.0
93 BuildRequires:  sqlite3-devel
94 BuildRequires:  swig
95 BuildRequires:  taglib-devel >= 1.8
96 BuildRequires:  tinyxml-devel
97 BuildRequires:  udev-devel
98 BuildRequires:  unzip
99 BuildRequires:  xorg-lib-libX11-devel
100 BuildRequires:  xorg-lib-libXext-devel
101 BuildRequires:  xorg-lib-libXinerama-devel
102 BuildRequires:  xorg-lib-libXmu-devel
103 BuildRequires:  xorg-lib-libXrandr-devel
104 BuildRequires:  xorg-lib-libXt-devel
105 BuildRequires:  xorg-lib-libXtst-devel
106 BuildRequires:  yajl-devel
107 BuildRequires:  zip
108 BuildRequires:  zlib-devel
109 #https://github.com/sahlberg/libnfs
110 #BuildRequires: libnfs-devel
111 #http://sites.google.com/site/alexthepuffin/home
112 #BuildRequires: afpfs-ng-devel
113 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
114 #https://github.com/albertz/shairport
115 #BuildRequires: libshairport
116 Requires:       /usr/bin/glxinfo
117 Requires:       SDL >= 1.2.14-5
118 Requires:       lsb-release
119 Requires:       xorg-app-xdpyinfo
120 Obsoletes:      xbmc < 14.0
121 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123 %description
124 XBMC media center is a free cross-platform media-player jukebox and
125 entertainment hub. XBMC can play a spectrum of of multimedia formats,
126 and featuring playlist, audio visualizations, slideshow, and weather
127 forecast functions, together third-party plugins.
128
129 %prep
130 %setup -q -n xbmc-%{version}-%{codename}
131 %patch0 -p1
132
133 %build
134 ./bootstrap
135 %configure \
136         --disable-debug \
137         --enable-external-libraries \
138         --enable-pulse \
139         --enable-udev \
140         --disable-libusb \
141         --disable-nfs \
142         --disable-afpclient \
143         --disable-airtunes \
144         %{__enable_disable goom} \
145         %{__enable_disable hal} \
146         %{__enable_disable libcec}
147
148 LIBS="-lpthread"
149 %{__make} V=1
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %files
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/*
162 %{_datadir}/%{name}
163 %attr(755,root,root) %{_libdir}/%{name}
164 %{_docdir}/%{name}
165 %{_desktopdir}/%{name}.desktop
166 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
167 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
168 %{_datadir}/xsessions/XBMC.desktop
This page took 0.044303 seconds and 4 git commands to generate.