]> git.pld-linux.org Git - packages/kodi.git/blob - kodi.spec
build without dvd support if without system dvd
[packages/kodi.git] / kodi.spec
1 # TODO:
2 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
3 #  - add and/or fix users/groups permissions
4 #  - split to subpackages?
5 # - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
6 #
7 # Conditional build:
8 # Features:
9 %bcond_with     afpclient       # AFP support via libafpclient
10 %bcond_without  airplay         # AirPlay support
11 %bcond_with     airtunes        # AirTunes support
12 %bcond_without  alsa            # ALSA support
13 %bcond_without  avahi           # Avahi support
14 %bcond_without  dbus            # DBUS support
15 %bcond_without  dvdcss          # DVDCSS support
16 %bcond_without  gl              # OpenGL rendering
17 %bcond_with     gtest           # configure Google Test Framework
18 %bcond_without  joystick        # SDL joystick support
19 %bcond_without  libcap          # libcap support
20 %bcond_with     libcec          # libcec support
21 %bcond_without  libgif          # gif support via libgif
22 %bcond_without  libusb          # libusb support
23 %bcond_with     mdnsembedded    # mDNSEmbedded support
24 %bcond_without  mysql           # MySQL
25 %bcond_without  nfs             # NFS support via libnfs
26 %bcond_without  non_free        # componentents with non-compliant licenses
27 %bcond_with     openmax         # OpenMax decoding, requires OpenGLES
28 %bcond_without  optical_drive   # optical drive
29 %bcond_without  projectm        # ProjectM visualisation
30 %bcond_without  pulse           # PulseAudio support
31 %bcond_without  rtmp            # RTMP support via librtmp
32 %bcond_without  samba           # SAMBA support
33 %bcond_without  sdl             # SDL
34 %bcond_without  ssh             # SSH SFTP support
35 %bcond_without  texturepacker   # texturepacker support
36 %bcond_without  udev            # udev support
37 %bcond_without  upnp            # UPnP support
38 %bcond_without  vaapi           # VAAPI decoding
39 %bcond_without  vdpau           # VDPAU decoding
40 %bcond_with     vtbdecoder      # VTBDecoder decoding (VTB Decoder not supported on this platform)
41 %bcond_without  webserver       # webserver
42 %bcond_without  x11             # x11 'Linux Only'
43 %bcond_without  xrandr          # XRandR support
44 %bcond_with     asap_codec      # ASAP ADPCM support
45 %bcond_with     gles            # OpenGLES rendering
46 %bcond_without  libbluray       # libbluray support
47 %bcond_without  mid             # MID support
48 %bcond_with     profiling       # gprof profiling
49 %bcond_with     tegra           # Tegra2 arm
50 %bcond_with     wayland         # wayland
51 # System libs:
52 %bcond_without  system_ffmpeg   # build with system ffmpeg
53 %bcond_with     system_dvdread  # build with system dvdread
54
55 %define codename Krypton
56 Summary:        Kodi is a free and open source media-player and entertainment hub
57 Name:           kodi
58 Version:        17.6
59 Release:        1
60 License:        GPL v2+ and GPL v3+
61 Group:          Applications/Multimedia
62 #Source0:       http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
63 Source0:        https://github.com/xbmc/xbmc/archive/%{version}-%{codename}.tar.gz
64 # Source0-md5:  a64c2fc56ddc41b9b0dded55eaabf170
65 Patch0:         jpeglib-boolean.patch
66 Patch1:         disable-static.patch
67 Patch2:         dvdread.patch
68 Patch3:         ffmpeg3.patch
69 Patch4:         gcc5.patch
70 Patch5:         libdvd.patch
71 URL:            http://kodi.tv/
72 BuildRequires:  Mesa-libEGL-devel
73 BuildRequires:  OpenGL-GLU-devel
74 BuildRequires:  OpenGL-devel
75 BuildRequires:  SDL2-devel
76 BuildRequires:  alsa-lib-devel
77 BuildRequires:  autoconf >= 2.59
78 BuildRequires:  automake
79 BuildRequires:  avahi-devel
80 BuildRequires:  bluez-libs-devel >= 4.99
81 BuildRequires:  boost-devel
82 BuildRequires:  bzip2-devel
83 BuildRequires:  cmake
84 BuildRequires:  crossguid-devel
85 BuildRequires:  curl-devel
86 BuildRequires:  dbus-devel
87 BuildRequires:  dcadec-devel
88 BuildRequires:  doxygen
89 # libavcodec >= 56.26.100 libavfilter >= 5.11.102 libavformat >= 56.25.101 libavutil >= 54.20.100 libpostproc >= 53.3.100 libswscale >= 3.1.101 libswresample >= 1.1.100
90 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 2.4.4}
91 BuildRequires:  flac-devel
92 BuildRequires:  fontconfig-devel
93 BuildRequires:  freetype-devel
94 BuildRequires:  fribidi-devel
95 BuildRequires:  gawk
96 BuildRequires:  gettext-autopoint
97 BuildRequires:  gettext-tools
98 BuildRequires:  giflib-devel
99 %{?with_libgif:BuildRequires:   giflib-devel}
100 BuildRequires:  glew-devel
101 BuildRequires:  gperf
102 BuildRequires:  jasper-devel
103 BuildRequires:  jre
104 BuildRequires:  libass-devel
105 BuildRequires:  libatomic-devel
106 BuildRequires:  libbluray-devel >= 0.7.0
107 BuildRequires:  libcap-devel
108 BuildRequires:  libcdio-devel
109 %{?with_libcec:BuildRequires:   libcec-devel >= 3.0.0}
110 BuildRequires:  libdrm-devel
111 %{?with_system_dvdread:BuildRequires:   libdvdread-devel}
112 %ifarch i686 pentium4 athlon %{x8664}
113 BuildRequires:  libcrystalhd-devel
114 %endif
115 BuildRequires:  libgcrypt-devel
116 BuildRequires:  libjpeg-devel
117 BuildRequires:  libltdl-devel
118 BuildRequires:  libmicrohttpd-devel
119 BuildRequires:  libmodplug-devel
120 BuildRequires:  libmpeg2-devel
121 BuildRequires:  libogg-devel
122 BuildRequires:  libplist-devel
123 BuildRequires:  libpng-devel
124 BuildRequires:  librtmp-devel
125 BuildRequires:  libsamplerate-devel
126 BuildRequires:  libsmbclient-devel
127 BuildRequires:  libssh-devel
128 BuildRequires:  libstdc++-devel
129 BuildRequires:  libtiff-devel
130 BuildRequires:  libtool
131 BuildRequires:  libuuid-devel
132 BuildRequires:  libva-devel
133 BuildRequires:  libva-x11-devel
134 BuildRequires:  libvdpau-devel
135 BuildRequires:  libvorbis-devel
136 BuildRequires:  libxml2-devel >= 2.0
137 BuildRequires:  libxslt-devel
138 BuildRequires:  lzo-devel
139 BuildRequires:  mysql-devel
140 %ifarch %{ix86}
141 BuildRequires:  nasm
142 %endif
143 BuildRequires:  openssl-devel
144 BuildRequires:  pcre-cxx-devel
145 BuildRequires:  pkgconfig
146 BuildRequires:  pulseaudio-devel >= 1.0
147 BuildRequires:  python-devel >= 1:2.6
148 BuildRequires:  rpm-pythonprov
149 BuildRequires:  rpmbuild(macros) >= 1.566
150 BuildRequires:  sed >= 4.0
151 BuildRequires:  sqlite3-devel
152 BuildRequires:  swig
153 BuildRequires:  taglib-devel >= 1.8
154 BuildRequires:  tinyxml-devel >= 2.6.2
155 BuildRequires:  udev-devel
156 BuildRequires:  unzip
157 BuildRequires:  xorg-lib-libX11-devel
158 BuildRequires:  xorg-lib-libXext-devel
159 BuildRequires:  xorg-lib-libXrandr-devel
160 BuildRequires:  yajl-devel >= 2
161 BuildRequires:  zip
162 BuildRequires:  zlib-devel
163 # kodi uses it's own, modified squish
164 BuildConflicts: squish-devel
165 #https://github.com/sahlberg/libnfs
166 BuildRequires:  libnfs-devel
167 #http://sites.google.com/site/alexthepuffin/home
168 #BuildRequires: afpfs-ng-devel
169 #BuildRequires: shairplay-devel
170 Requires:       /usr/bin/glxinfo
171 Requires:       SDL >= 1.2.14-5
172 Requires:       lsb-release
173 Requires:       xorg-app-xdpyinfo
174 # dlopened libraries:
175 # grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
176 Requires:       curl-libs
177 Requires:       libass
178 Requires:       libbluray
179 Requires:       libmodplug
180 Requires:       libmpeg2-libs
181 Requires:       libogg
182 Requires:       libplist
183 Requires:       libvorbis
184 Obsoletes:      xbmc < 14.0
185 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
186
187 %description
188 Kodi Entertainment Center (formerly XBMC) is a free and open-source
189 media player software developed by the XBMC Foundation, a non-profit
190 technology consortium. Kodi is available for multiple operating
191 systems and hardware platforms, with a software 10-foot user interface
192 for use with televisions and remote controls. It allows users to play
193 and view most videos, music, such as podcasts from the internet, and
194 all common digital media files from local and network storage media.
195
196 %prep
197 %setup -q -n xbmc-%{version}-%{codename}
198 #%patch0 -p1
199 %patch1 -p1
200 %{?with_system_dvdread:%patch2 -p1}
201 #%patch3 -p1
202 #%patch4 -p1
203 %{!?with_system_dvdread:%patch5 -p1}
204
205 #%{__rm} -r lib/cximage-6.0/zlib
206 #%{__rm} -r lib/libhdhomerun
207 #%{__rm} -r lib/libmpeg2
208 #%{__rm} -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
209 #%{__rm} -r lib/libbluray
210 #%{__rm} -r lib/librtmp
211 %{__rm} -r lib/win32
212 #%{?with_system_dvdread:%{__rm} -r lib/libdvd/libdvdread}
213
214 %if %{without system_ffmpeg}
215 #ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
216 %endif
217
218 %build
219 #%{__make} -C tools/depends/native/libsquish-native \
220 #       CXX="%{__cxx}"
221
222 ./bootstrap
223 %configure \
224         ac_cv_type__Bool=yes \
225         --disable-silent-rules \
226         --disable-debug \
227         --disable-ccache \
228         --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
229         %{__enable_disable afpclient} \
230         %{__enable_disable airplay} \
231         %{__enable_disable airtunes} \
232         %{__enable_disable alsa} \
233         %{__enable_disable asap_codec asap-codec} \
234         %{__enable_disable avahi} \
235         %{__enable_disable dbus} \
236         %{__enable_disable dvdcss} \
237         %{__enable_disable gles} \
238         %{__enable_disable gl} \
239         %{__enable_disable gtest} \
240         %{__enable_disable joystick} \
241         %{__enable_disable libbluray} \
242         %{__enable_disable libcap} \
243         %{__enable_disable libcec} \
244         %{__enable_disable libgif} \
245         %{__enable_disable libusb} \
246         %{__enable_disable mdnsembedded} \
247         %{__enable_disable mid} \
248         %{__enable_disable mysql} \
249         %{__enable_disable nfs} \
250         %{__enable_disable non_free non-free} \
251         %{__enable_disable openmax} \
252         %{__enable_disable optical_drive optical-drive} \
253         %{__enable_disable profiling} \
254         %{__enable_disable pulse} \
255         %{__enable_disable rtmp} \
256         %{__enable_disable samba} \
257         %{__enable_disable sdl} \
258         %{__enable_disable ssh} \
259         %{__enable_disable tegra} \
260         %{__enable_disable texturepacker} \
261         %{__enable_disable udev} \
262         %{__enable_disable upnp} \
263         %{__enable_disable vaapi} \
264         %{__enable_disable vdpau} \
265         %{__enable_disable vtbdecoder} \
266         %{__enable_disable wayland} \
267         %{__enable_disable webserver} \
268         %{__enable_disable x11} \
269         %{__enable_disable xrandr} \
270         %{nil}
271
272 %{__make} V=1
273
274 %install
275 rm -rf $RPM_BUILD_ROOT
276 %{__make} install \
277         DESTDIR=$RPM_BUILD_ROOT
278
279 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
280
281 # no -devel package yet
282 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
283 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
284
285 # no real use for symlinks to datadir, and make rpm packaging more difficult (symlink vs dir issues)
286 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xbmc
287 %{__rm} $RPM_BUILD_ROOT%{_datadir}/xbmc
288
289 %clean
290 rm -rf $RPM_BUILD_ROOT
291
292 %files
293 %defattr(644,root,root,755)
294 %doc README.md docs/README.linux
295 %attr(755,root,root) %{_bindir}/kodi
296 %attr(755,root,root) %{_bindir}/kodi-standalone
297 %{_datadir}/%{name}
298 %attr(755,root,root) %{_libdir}/%{name}
299 %{_desktopdir}/kodi.desktop
300 %{_iconsdir}/hicolor/*/apps/%{name}.png
301 %{_datadir}/xsessions/kodi.desktop
302
303 # legacy xbmc compatibility links
304 %attr(755,root,root) %{_bindir}/xbmc
305 %attr(755,root,root) %{_bindir}/xbmc-standalone
306 %{_datadir}/xsessions/xbmc.desktop
This page took 0.11622 seconds and 4 git commands to generate.