]> git.pld-linux.org Git - packages/kodi.git/blob - kodi.spec
- added wrapper.c.patch to build agains libva soname change
[packages/kodi.git] / kodi.spec
1 # TODO:
2 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
3 #  - add and/or fix users/groups permissions
4 #  - split to subpackages?
5 # - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
6 #
7 # Conditional build:
8 # Features:
9 %bcond_with     afpclient       # AFP support via libafpclient
10 %bcond_without  airplay         # AirPlay support
11 %bcond_with     airtunes        # AirTunes support
12 %bcond_without  alsa            # ALSA support
13 %bcond_without  avahi           # Avahi support
14 %bcond_without  dbus            # DBUS support
15 %bcond_without  dvdcss          # DVDCSS support
16 %bcond_without  gl              # OpenGL rendering
17 %bcond_with     gtest           # configure Google Test Framework
18 %bcond_without  joystick        # SDL joystick support
19 %bcond_without  libcap          # libcap support
20 %bcond_with     libcec          # libcec support
21 %bcond_without  libgif          # gif support via libgif
22 %bcond_without  libusb          # libusb support
23 %bcond_with     mdnsembedded    # mDNSEmbedded support
24 %bcond_without  mysql           # MySQL
25 %bcond_without  nfs             # NFS support via libnfs
26 %bcond_without  non_free        # componentents with non-compliant licenses
27 %bcond_with     openmax         # OpenMax decoding, requires OpenGLES
28 %bcond_without  optical_drive   # optical drive
29 %bcond_without  projectm        # ProjectM visualisation
30 %bcond_without  pulse           # PulseAudio support
31 %bcond_without  rtmp            # RTMP support via librtmp
32 %bcond_without  samba           # SAMBA support
33 %bcond_without  sdl             # SDL
34 %bcond_without  ssh             # SSH SFTP support
35 %bcond_without  texturepacker   # texturepacker support
36 %bcond_without  udev            # udev support
37 %bcond_without  upnp            # UPnP support
38 %bcond_without  vaapi           # VAAPI decoding
39 %bcond_without  vdpau           # VDPAU decoding
40 %bcond_with     vtbdecoder      # VTBDecoder decoding (VTB Decoder not supported on this platform)
41 %bcond_without  webserver       # webserver
42 %bcond_without  x11             # x11 'Linux Only'
43 %bcond_without  xrandr          # XRandR support
44 %bcond_with     asap_codec      # ASAP ADPCM support
45 %bcond_with     gles            # OpenGLES rendering
46 %bcond_without  libbluray       # libbluray support
47 %bcond_without  mid             # MID support
48 %bcond_with     profiling       # gprof profiling
49 %bcond_with     tegra           # Tegra2 arm
50 %bcond_with     wayland         # wayland
51 # System libs:
52 %bcond_without  system_ffmpeg   # build with system ffmpeg
53 %bcond_with     system_dvdread  # build with system dvdread
54
55 %define codename Krypton
56 Summary:        Kodi is a free and open source media-player and entertainment hub
57 Name:           kodi
58 # 18.x being prepared on dev-18-leia branch
59 Version:        17.6
60 Release:        3.1
61 License:        GPL v2+ and GPL v3+
62 Group:          Applications/Multimedia
63 #Source0:       http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
64 Source0:        https://github.com/xbmc/xbmc/archive/%{version}-%{codename}.tar.gz
65 # Source0-md5:  a64c2fc56ddc41b9b0dded55eaabf170
66 Patch0:         jpeglib-boolean.patch
67 Patch1:         disable-static.patch
68 Patch2:         dvdread.patch
69 Patch3:         ffmpeg3.patch
70 Patch4:         gcc5.patch
71 Patch5:         libdvd.patch
72 Patch6:         ffmpeg4.patch
73 Patch7:         wrapper.c.patch
74 URL:            http://kodi.tv/
75 BuildRequires:  Mesa-libEGL-devel
76 BuildRequires:  OpenGL-GLU-devel
77 BuildRequires:  OpenGL-devel
78 BuildRequires:  SDL2-devel
79 BuildRequires:  alsa-lib-devel
80 BuildRequires:  autoconf >= 2.59
81 BuildRequires:  automake
82 BuildRequires:  avahi-devel
83 BuildRequires:  bluez-libs-devel >= 4.99
84 BuildRequires:  bzip2-devel
85 BuildRequires:  cmake
86 BuildRequires:  crossguid-devel
87 BuildRequires:  curl-devel
88 BuildRequires:  dbus-devel
89 # libavcodec >= 56.26.100 libavfilter >= 5.11.102 libavformat >= 56.25.101 libavutil >= 54.20.100 libpostproc >= 53.3.100 libswscale >= 3.1.101 libswresample >= 1.1.100
90 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 2.4.4}
91 BuildRequires:  flac-devel
92 BuildRequires:  fontconfig-devel
93 BuildRequires:  freetype-devel
94 BuildRequires:  fribidi-devel
95 BuildRequires:  gawk
96 BuildRequires:  gettext-autopoint
97 BuildRequires:  gettext-tools
98 BuildRequires:  giflib-devel
99 %{?with_libgif:BuildRequires:   giflib-devel}
100 BuildRequires:  gperf
101 BuildRequires:  jre
102 BuildRequires:  lcms2-devel
103 BuildRequires:  libass-devel
104 BuildRequires:  libatomic-devel
105 BuildRequires:  libbluray-devel >= 0.7.0
106 BuildRequires:  libcap-devel
107 BuildRequires:  libcdio-devel
108 %{?with_libcec:BuildRequires:   libcec-devel >= 3.0.0}
109 BuildRequires:  libdrm-devel
110 %{?with_system_dvdread:BuildRequires:   libdvdread-devel}
111 BuildRequires:  libgcrypt-devel
112 BuildRequires:  libjpeg-devel
113 BuildRequires:  libltdl-devel
114 BuildRequires:  libmicrohttpd-devel
115 BuildRequires:  libogg-devel
116 BuildRequires:  libplist-devel
117 BuildRequires:  libpng-devel
118 BuildRequires:  librtmp-devel
119 BuildRequires:  libsmbclient-devel
120 BuildRequires:  libssh-devel
121 BuildRequires:  libstdc++-devel
122 BuildRequires:  libtool
123 BuildRequires:  libuuid-devel
124 BuildRequires:  libva-devel
125 BuildRequires:  libva-x11-devel
126 BuildRequires:  libvdpau-devel
127 BuildRequires:  libvorbis-devel
128 BuildRequires:  libxml2-devel >= 2.0
129 BuildRequires:  libxslt-devel
130 BuildRequires:  lzo-devel
131 BuildRequires:  mysql-devel
132 %ifarch %{ix86}
133 BuildRequires:  nasm
134 %endif
135 BuildRequires:  openssl-devel
136 BuildRequires:  pcre-cxx-devel
137 BuildRequires:  pkgconfig
138 BuildRequires:  pulseaudio-devel >= 1.0
139 BuildRequires:  python-devel >= 1:2.6
140 BuildRequires:  rpm-pythonprov
141 BuildRequires:  rpmbuild(macros) >= 1.566
142 BuildRequires:  sed >= 4.0
143 BuildRequires:  sqlite3-devel
144 BuildRequires:  swig
145 BuildRequires:  taglib-devel >= 1.8
146 BuildRequires:  tinyxml-devel >= 2.6.2
147 BuildRequires:  udev-devel
148 BuildRequires:  unzip
149 BuildRequires:  xorg-lib-libX11-devel
150 BuildRequires:  xorg-lib-libXext-devel
151 BuildRequires:  xorg-lib-libXrandr-devel
152 BuildRequires:  yajl-devel >= 2
153 BuildRequires:  zip
154 BuildRequires:  zlib-devel
155 # kodi uses it's own, modified squish
156 BuildConflicts: squish-devel
157 #https://github.com/sahlberg/libnfs
158 BuildRequires:  libnfs-devel
159 #http://sites.google.com/site/alexthepuffin/home
160 #BuildRequires: afpfs-ng-devel
161 #BuildRequires: shairplay-devel
162 Requires:       /usr/bin/glxinfo
163 Requires:       SDL >= 1.2.14-5
164 Requires:       lsb-release
165 Requires:       xorg-app-xdpyinfo
166 # dlopened libraries:
167 # grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
168 Requires:       curl-libs
169 Requires:       libass
170 Requires:       libbluray
171 Requires:       libmodplug
172 Requires:       libmpeg2-libs
173 Requires:       libogg
174 Requires:       libplist
175 Requires:       libvorbis
176 Obsoletes:      xbmc < 14.0
177 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
178
179 %description
180 Kodi Entertainment Center (formerly XBMC) is a free and open-source
181 media player software developed by the XBMC Foundation, a non-profit
182 technology consortium. Kodi is available for multiple operating
183 systems and hardware platforms, with a software 10-foot user interface
184 for use with televisions and remote controls. It allows users to play
185 and view most videos, music, such as podcasts from the internet, and
186 all common digital media files from local and network storage media.
187
188 %prep
189 %setup -q -n xbmc-%{version}-%{codename}
190 #%patch0 -p1
191 %patch1 -p1
192 %{?with_system_dvdread:%patch2 -p1}
193 #%patch3 -p1
194 #%patch4 -p1
195 %{!?with_system_dvdread:%patch5 -p1}
196 %patch6 -p1
197 %patch7 -p1
198
199 #%{__rm} -r lib/cximage-6.0/zlib
200 #%{__rm} -r lib/libhdhomerun
201 #%{__rm} -r lib/libmpeg2
202 #%{__rm} -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
203 #%{__rm} -r lib/libbluray
204 #%{__rm} -r lib/librtmp
205 %{__rm} -r lib/win32
206 #%{?with_system_dvdread:%{__rm} -r lib/libdvd/libdvdread}
207
208 %if %{without system_ffmpeg}
209 #ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
210 %endif
211
212 %build
213 #%{__make} -C tools/depends/native/libsquish-native \
214 #       CXX="%{__cxx}"
215
216 ./bootstrap
217 %configure \
218         ac_cv_type__Bool=yes \
219         --disable-silent-rules \
220         --disable-debug \
221         --disable-ccache \
222         --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
223         %{__enable_disable afpclient} \
224         %{__enable_disable airplay} \
225         %{__enable_disable airtunes} \
226         %{__enable_disable alsa} \
227         %{__enable_disable asap_codec asap-codec} \
228         %{__enable_disable avahi} \
229         %{__enable_disable dbus} \
230         %{__enable_disable dvdcss} \
231         %{__enable_disable gles} \
232         %{__enable_disable gl} \
233         %{__enable_disable gtest} \
234         %{__enable_disable joystick} \
235         %{__enable_disable libbluray} \
236         %{__enable_disable libcap} \
237         %{__enable_disable libcec} \
238         %{__enable_disable libgif} \
239         %{__enable_disable libusb} \
240         %{__enable_disable mdnsembedded} \
241         %{__enable_disable mid} \
242         %{__enable_disable mysql} \
243         %{__enable_disable nfs} \
244         %{__enable_disable non_free non-free} \
245         %{__enable_disable openmax} \
246         %{__enable_disable optical_drive optical-drive} \
247         %{__enable_disable profiling} \
248         %{__enable_disable pulse} \
249         %{__enable_disable rtmp} \
250         %{__enable_disable samba} \
251         %{__enable_disable sdl} \
252         %{__enable_disable ssh} \
253         %{__enable_disable tegra} \
254         %{__enable_disable texturepacker} \
255         %{__enable_disable udev} \
256         %{__enable_disable upnp} \
257         %{__enable_disable vaapi} \
258         %{__enable_disable vdpau} \
259         %{__enable_disable vtbdecoder} \
260         %{__enable_disable wayland} \
261         %{__enable_disable webserver} \
262         %{__enable_disable x11} \
263         %{__enable_disable xrandr} \
264         %{nil}
265
266 %{__make} V=1
267
268 %install
269 rm -rf $RPM_BUILD_ROOT
270 %{__make} install \
271         DESTDIR=$RPM_BUILD_ROOT
272
273 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
274
275 # no -devel package yet
276 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
277 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
278
279 # no real use for symlinks to datadir, and make rpm packaging more difficult (symlink vs dir issues)
280 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xbmc
281 %{__rm} $RPM_BUILD_ROOT%{_datadir}/xbmc
282
283 %clean
284 rm -rf $RPM_BUILD_ROOT
285
286 %files
287 %defattr(644,root,root,755)
288 %doc README.md docs/README.linux
289 %attr(755,root,root) %{_bindir}/kodi
290 %attr(755,root,root) %{_bindir}/kodi-standalone
291 %{_datadir}/%{name}
292 %attr(755,root,root) %{_libdir}/%{name}
293 %{_desktopdir}/kodi.desktop
294 %{_iconsdir}/hicolor/*/apps/%{name}.png
295 %{_datadir}/xsessions/kodi.desktop
296
297 # legacy xbmc compatibility links
298 %attr(755,root,root) %{_bindir}/xbmc
299 %attr(755,root,root) %{_bindir}/xbmc-standalone
300 %{_datadir}/xsessions/xbmc.desktop
This page took 0.067377 seconds and 4 git commands to generate.