]> git.pld-linux.org Git - packages/kodi.git/blob - kodi.spec
57c0d5b5c497bf2ef570a4bc78d79a428ddfaaa7
[packages/kodi.git] / kodi.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - add and/or fix users/groups permissions
6 #  - split to subpackages?
7 #
8 # Conditional build:
9 %bcond_without  cec     # build without cec support
10 %bcond_without  goom    # build without goom visualisation
11 %bcond_with     hal     # build with HAL
12
13 %define codename Helix
14 Summary:        Kodi is a free and open source media-player and entertainment hub
15 Name:           kodi
16 Version:        14.0
17 Release:        0.1
18 License:        GPL v2+ and GPL v3+
19 Group:          Applications/Multimedia
20 Source0:        http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
21 # Source0-md5:  9717c539789789b8aeaf1dcfdb9f2c69
22 Patch0:         jpeglib-boolean.patch
23 URL:            http://kodi.tv/
24 BuildRequires:  Mesa-libGLU-devel
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  SDL_image-devel
27 BuildRequires:  SDL_mixer-devel
28 BuildRequires:  alsa-lib-devel
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  avahi-devel
32 BuildRequires:  bluez-libs-devel >= 4.99
33 BuildRequires:  boost-devel
34 BuildRequires:  bzip2-devel
35 BuildRequires:  cmake
36 BuildRequires:  curl-devel
37 BuildRequires:  dbus-devel
38 BuildRequires:  doxygen
39 BuildRequires:  ffmpeg-devel
40 BuildRequires:  flac-devel
41 BuildRequires:  fontconfig-devel
42 BuildRequires:  freetype-devel
43 BuildRequires:  fribidi-devel
44 BuildRequires:  gawk
45 BuildRequires:  gettext-autopoint
46 BuildRequires:  gettext-tools
47 BuildRequires:  glew-devel
48 BuildRequires:  gperf
49 %{?with_hal:BuildRequires:      hal-devel}
50 BuildRequires:  jasper-devel
51 BuildRequires:  jre
52 BuildRequires:  libass-devel
53 BuildRequires:  libbluray-devel >= 0.2.1
54 BuildRequires:  libcap-devel
55 BuildRequires:  libcdio-devel
56 %{?with_cec:BuildRequires:      libcec-devel}
57 %ifarch i686 pentium4 athlon %{x8664}
58 BuildRequires:  libcrystalhd-devel
59 %endif
60 BuildRequires:  libgcrypt-devel
61 BuildRequires:  libjpeg-devel
62 BuildRequires:  libltdl-devel
63 BuildRequires:  libmad-devel
64 BuildRequires:  libmicrohttpd-devel
65 BuildRequires:  libmodplug-devel
66 BuildRequires:  libmpeg2-devel
67 BuildRequires:  libogg-devel
68 BuildRequires:  libplist-devel
69 BuildRequires:  libpng-devel
70 BuildRequires:  librtmp-devel
71 BuildRequires:  libsamplerate-devel
72 BuildRequires:  libsmbclient-devel
73 BuildRequires:  libssh-devel
74 BuildRequires:  libtiff-devel
75 BuildRequires:  libtool
76 BuildRequires:  libva-devel
77 BuildRequires:  libva-glx-devel
78 BuildRequires:  libvdpau-devel
79 BuildRequires:  libvorbis-devel
80 BuildRequires:  libxslt-devel
81 BuildRequires:  lzo-devel
82 BuildRequires:  mysql-devel
83 %ifarch %{ix86}
84 BuildRequires:  nasm
85 %endif
86 BuildRequires:  openssl-devel
87 BuildRequires:  pcre-cxx-devel
88 BuildRequires:  pkgconfig
89 BuildRequires:  pulseaudio-devel
90 BuildRequires:  python-devel >= 2.4
91 BuildRequires:  rpm-pythonprov
92 BuildRequires:  rpmbuild(macros) >= 1.566
93 # used internally
94 BuildRequires:  sed >= 4.0
95 BuildRequires:  sqlite3-devel
96 BuildRequires:  swig
97 BuildRequires:  taglib-devel >= 1.8
98 BuildRequires:  tinyxml-devel
99 BuildRequires:  udev-devel
100 BuildRequires:  unzip
101 BuildRequires:  xorg-lib-libX11-devel
102 BuildRequires:  xorg-lib-libXext-devel
103 BuildRequires:  xorg-lib-libXinerama-devel
104 BuildRequires:  xorg-lib-libXmu-devel
105 BuildRequires:  xorg-lib-libXrandr-devel
106 BuildRequires:  xorg-lib-libXt-devel
107 BuildRequires:  xorg-lib-libXtst-devel
108 BuildRequires:  yajl-devel
109 BuildRequires:  yasm
110 BuildRequires:  zip
111 BuildRequires:  zlib-devel
112 #https://github.com/sahlberg/libnfs
113 #BuildRequires: libnfs-devel
114 #http://sites.google.com/site/alexthepuffin/home
115 #BuildRequires: afpfs-ng-devel
116 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
117 #https://github.com/albertz/shairport
118 #BuildRequires: libshairport
119 Requires:       /usr/bin/glxinfo
120 Requires:       SDL >= 1.2.14-5
121 Requires:       lsb-release
122 Requires:       xorg-app-xdpyinfo
123 # dlopened libraries:
124 # grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
125 Requires:       curl-libs
126 Requires:       libass
127 Requires:       libbluray
128 Requires:       libmodplug
129 Requires:       libmpeg2-libs
130 Requires:       libogg
131 Requires:       libplist
132 Requires:       libvorbis
133 Obsoletes:      xbmc < 14.0
134 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
135
136 %description
137 Kodi Entertainment Center (formerly XBMC) is a free and open-source
138 media player software developed by the XBMC Foundation, a non-profit
139 technology consortium. Kodi is available for multiple operating
140 systems and hardware platforms, with a software 10-foot user interface
141 for use with televisions and remote controls. It allows users to play
142 and view most videos, music, such as podcasts from the internet, and
143 all common digital media files from local and network storage media.
144
145 %prep
146 %setup -q -n xbmc-%{version}-%{codename}
147 %patch0 -p1
148
149 %build
150 ./bootstrap
151 %configure \
152         --disable-silent-rules \
153         --disable-debug \
154         --enable-external-libraries \
155         --disable-afpclient \
156         --disable-airtunes \
157         --disable-ccache \
158         --disable-libusb \
159         --disable-nfs \
160         --enable-pulse \
161         --enable-udev \
162         %{__enable_disable goom} \
163         %{__enable_disable hal} \
164         %{__enable_disable libcec}
165
166 %{__make}
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170 %{__make} install \
171         DESTDIR=$RPM_BUILD_ROOT
172
173 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
174
175 # no -devel package yet
176 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
177 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %files
183 %defattr(644,root,root,755)
184 %doc README.md docs/README.linux
185 %attr(755,root,root) %{_bindir}/kodi
186 %attr(755,root,root) %{_bindir}/kodi-standalone
187 %{_datadir}/%{name}
188 %attr(755,root,root) %{_libdir}/%{name}
189 %{_desktopdir}/kodi.desktop
190 %{_iconsdir}/hicolor/*/apps/%{name}.png
191 %{_datadir}/xsessions/kodi.desktop
192
193 # legacy xbmc compatibility links
194 %attr(755,root,root) %{_bindir}/xbmc
195 %attr(755,root,root) %{_bindir}/xbmc-standalone
196 %{_libdir}/xbmc
197 %{_datadir}/xbmc
198 %{_datadir}/xsessions/xbmc.desktop
This page took 0.085761 seconds and 2 git commands to generate.