]> git.pld-linux.org Git - packages/kodi-addon-pvr-hts.git/blob - kodi-addon-pvr-hts.spec
up to 20.6.3
[packages/kodi-addon-pvr-hts.git] / kodi-addon-pvr-hts.spec
1 %define         kodi_ver        20
2 %define         next_kodi_ver   %(echo $((%{kodi_ver}+1)))
3 %define         codename        Nexus
4 %define         addon           pvr.hts
5
6 Summary:        Kodi's Tvheadend HTSP client addon
7 Name:           kodi-addon-pvr-hts
8 Version:        %{kodi_ver}.6.3
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/Multimedia
12 Source0:        https://github.com/kodi-pvr/pvr.hts/archive/%{version}-%{codename}/%{version}-%{codename}.tar.gz
13 # Source0-md5:  1a212761a77cf05cb03cea0c149cc574
14 URL:            https://github.com/kodi-pvr/pvr.hts
15 BuildRequires:  cmake >= 3.5
16 BuildRequires:  kodi-devel >= %{kodi_ver}
17 BuildRequires:  kodi-devel < %{next_kodi_ver}
18 BuildRequires:  libstdc++-devel >= 6:7
19 BuildRequires:  rpmbuild(macros) >= 1.605
20 Requires:       kodi >= %{kodi_ver}
21 Requires:       kodi < %{next_kodi_ver}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Kodi's Tvheadend HTSP client addon.
26
27 %prep
28 %setup -q -n %{addon}-%{version}-%{codename}
29
30 %build
31 %cmake -B build
32 %{__make} -C build
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 %{__make} -C build install \
37         DESTDIR=$RPM_BUILD_ROOT
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %dir %{_libdir}/kodi/addons/%{addon}
45 %attr(755,root,root) %{_libdir}/kodi/addons/%{addon}/%{addon}.so.%{version}
46 %dir %{_datadir}/kodi/addons/%{addon}
47 %{_datadir}/kodi/addons/%{addon}/addon.xml
48 %{_datadir}/kodi/addons/%{addon}/changelog.txt
49 %{_datadir}/kodi/addons/%{addon}/icon.png
50 %{_datadir}/kodi/addons/%{addon}/resources
This page took 0.085732 seconds and 3 git commands to generate.